summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2024-04-16 17:36:23 +0200
committerAlexis Ballier <aballier@gentoo.org>2024-04-16 17:36:33 +0200
commit4e4cb3179c40d12bd9adda012c5c6a60cc217a4f (patch)
treebf820dc6f021858ed7fc8e42f1c5d38e5ea8c82d /sci-electronics
parentsys-process/systemd-cron: Require split-usr in deps and no longer die. (diff)
downloadgentoo-4e4cb3179c40d12bd9adda012c5c6a60cc217a4f.tar.gz
gentoo-4e4cb3179c40d12bd9adda012c5c6a60cc217a4f.tar.bz2
gentoo-4e4cb3179c40d12bd9adda012c5c6a60cc217a4f.zip
sci-electronics/gazebo: add upstream patch to build with graphviz 10
Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/gazebo/files/gv10.patch45
-rw-r--r--sci-electronics/gazebo/gazebo-11.14.0.ebuild3
2 files changed, 47 insertions, 1 deletions
diff --git a/sci-electronics/gazebo/files/gv10.patch b/sci-electronics/gazebo/files/gv10.patch
new file mode 100644
index 000000000000..f3ab5eb1e686
--- /dev/null
+++ b/sci-electronics/gazebo/files/gv10.patch
@@ -0,0 +1,45 @@
+From 660ae15f4af1f5ea8d9d50d4a24e4d91a94f9c2d Mon Sep 17 00:00:00 2001
+From: Steve Peters <scpeters@openrobotics.org>
+Date: Tue, 20 Feb 2024 17:25:23 -0800
+Subject: [PATCH] Fix build with graphviz 10.0
+
+Replace TRUE with 1, since the TRUE macro has been removed.
+
+Signed-off-by: Steve Peters <scpeters@openrobotics.org>
+---
+ gazebo/gui/qgv/QGVSubGraph.cpp | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/gazebo/gui/qgv/QGVSubGraph.cpp b/gazebo/gui/qgv/QGVSubGraph.cpp
+index 51925aba30..c16b69d065 100644
+--- a/gazebo/gui/qgv/QGVSubGraph.cpp
++++ b/gazebo/gui/qgv/QGVSubGraph.cpp
+@@ -44,13 +44,13 @@ QString QGVSubGraph::name() const
+
+ QGVNode *QGVSubGraph::addNode(const QString &label)
+ {
+- Agnode_t *node = agnode(_sgraph->graph(), NULL, TRUE);
++ Agnode_t *node = agnode(_sgraph->graph(), NULL, 1);
+ if (node == NULL)
+ {
+ qWarning()<<"Invalid sub node :"<<label;
+ return 0;
+ }
+- agsubnode(_sgraph->graph(), node, TRUE);
++ agsubnode(_sgraph->graph(), node, 1);
+
+ QGVNode *item = new QGVNode(new QGVNodePrivate(node), _scene);
+ item->setLabel(label);
+@@ -66,10 +66,10 @@ QGVSubGraph *QGVSubGraph::addSubGraph(const QString &_name, bool cluster)
+ if (cluster)
+ {
+ sgraph = agsubg(_sgraph->graph(),
+- ("cluster_" + _name).toLocal8Bit().data(), TRUE);
++ ("cluster_" + _name).toLocal8Bit().data(), 1);
+ }
+ else
+- sgraph = agsubg(_sgraph->graph(), _name.toLocal8Bit().data(), TRUE);
++ sgraph = agsubg(_sgraph->graph(), _name.toLocal8Bit().data(), 1);
+
+ if (sgraph == NULL)
+ {
diff --git a/sci-electronics/gazebo/gazebo-11.14.0.ebuild b/sci-electronics/gazebo/gazebo-11.14.0.ebuild
index 0a321f61f496..1746085d2235 100644
--- a/sci-electronics/gazebo/gazebo-11.14.0.ebuild
+++ b/sci-electronics/gazebo/gazebo-11.14.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -65,6 +65,7 @@ CMAKE_BUILD_TYPE=RelWithDebInfo
PATCHES=(
"${FILESDIR}/qwt2.patch"
"${FILESDIR}/cmake.patch"
+ "${FILESDIR}/gv10.patch"
)
src_configure() {