summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-geosciences/tilecache
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-geosciences/tilecache')
-rw-r--r--sci-geosciences/tilecache/Manifest1
-rw-r--r--sci-geosciences/tilecache/files/tilecache-2.11-pil.patch21
-rw-r--r--sci-geosciences/tilecache/metadata.xml5
-rw-r--r--sci-geosciences/tilecache/tilecache-2.11-r1.ebuild33
4 files changed, 60 insertions, 0 deletions
diff --git a/sci-geosciences/tilecache/Manifest b/sci-geosciences/tilecache/Manifest
new file mode 100644
index 000000000000..da46746acce6
--- /dev/null
+++ b/sci-geosciences/tilecache/Manifest
@@ -0,0 +1 @@
+DIST tilecache-2.11.tar.gz 68705 SHA256 b46dc2731a19b40e3207cf3c9b43ea59b899a622a586aaa3c397c3b5aa00f887 SHA512 234fdba3465b9f940b4bf45a4427c61a803f4458266c59ac08d52bdaace4a186d7bf37cce7af6f273ba0ade9e8d6118fa58ce6dd37645a0667230dc507ee991a WHIRLPOOL aa3da22b95b35da7b6612ed6078ccec34828c0488ddff18b33642cdcbb7dc45a502f6b5717f25264b6d9ffc0b5d2bdd1fb4091bc49277d5c135d216f24b3567c
diff --git a/sci-geosciences/tilecache/files/tilecache-2.11-pil.patch b/sci-geosciences/tilecache/files/tilecache-2.11-pil.patch
new file mode 100644
index 000000000000..b596ae449ff7
--- /dev/null
+++ b/sci-geosciences/tilecache/files/tilecache-2.11-pil.patch
@@ -0,0 +1,21 @@
+diff -Nuar tilecache-2.11.orig/TileCache/Layer.py tilecache-2.11/TileCache/Layer.py
+--- tilecache-2.11.orig/TileCache/Layer.py 2010-10-15 04:00:18.000000000 -0700
++++ tilecache-2.11/TileCache/Layer.py 2013-11-09 11:05:17.620475332 -0800
+@@ -391,7 +391,7 @@
+ return MetaTile(self, x, y, tile.z)
+
+ def renderMetaTile (self, metatile, tile):
+- import StringIO, Image
++ import StringIO, PIL.Image as Image
+
+ data = self.renderTile(metatile)
+ image = Image.open( StringIO.StringIO(data) )
+@@ -444,7 +444,7 @@
+ return self.renderTile(tile)
+
+ def watermark (self, img):
+- import StringIO, Image, ImageEnhance
++ import StringIO, PIL.Image as Image, PIL.ImageEnhance as ImageEnhance
+ tileImage = Image.open( StringIO.StringIO(img) )
+ wmark = Image.open(self.watermarkimage)
+ assert self.watermarkopacity >= 0 and self.watermarkopacity <= 1
diff --git a/sci-geosciences/tilecache/metadata.xml b/sci-geosciences/tilecache/metadata.xml
new file mode 100644
index 000000000000..d21d11884553
--- /dev/null
+++ b/sci-geosciences/tilecache/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-geosciences</herd>
+</pkgmetadata>
diff --git a/sci-geosciences/tilecache/tilecache-2.11-r1.ebuild b/sci-geosciences/tilecache/tilecache-2.11-r1.ebuild
new file mode 100644
index 000000000000..b06e82a84d7f
--- /dev/null
+++ b/sci-geosciences/tilecache/tilecache-2.11-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Web map tile caching system"
+HOMEPAGE="http://tilecache.org/"
+SRC_URI="http://${PN}.org/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="virtual/python-imaging
+ dev-python/paste"
+DEPEND="${RDEPEND}
+ dev-python/setuptools
+"
+
+PATCHES=( "${FILESDIR}/tilecache-2.11-pil.patch" )
+
+src_install() {
+ distutils-r1_src_install "--debian"
+}
+
+python_test() {
+ python setup.py test || die "Failed tests"
+}