summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2024-10-01 13:35:46 +0700
committerAndrey Grozin <grozin@gentoo.org>2024-10-01 13:35:46 +0700
commitec8a846f1826a8a59983b2b7a9dc26419836d7a2 (patch)
tree0afadfcfff7fba9f2818a314d32bd98fd8db8339 /sci-geosciences
parentnet-im/zoom: drop 6.2.2.2028 (diff)
downloadgentoo-ec8a846f1826a8a59983b2b7a9dc26419836d7a2.tar.gz
gentoo-ec8a846f1826a8a59983b2b7a9dc26419836d7a2.tar.bz2
gentoo-ec8a846f1826a8a59983b2b7a9dc26419836d7a2.zip
sci-geosciences/qmapshack: fix dbus support
Closes: https://bugs.gentoo.org/940194 Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/qmapshack/Manifest1
-rw-r--r--sci-geosciences/qmapshack/files/dbus-r1.patch63
-rw-r--r--sci-geosciences/qmapshack/qmapshack-1.17.1_p601.ebuild48
3 files changed, 112 insertions, 0 deletions
diff --git a/sci-geosciences/qmapshack/Manifest b/sci-geosciences/qmapshack/Manifest
index 986bf4932766..895cbf62129f 100644
--- a/sci-geosciences/qmapshack/Manifest
+++ b/sci-geosciences/qmapshack/Manifest
@@ -1,2 +1,3 @@
DIST qmapshack-1.17.1.tar.gz 56704889 BLAKE2B 1fda3f9874f39eb6b7a0c71ac7b681ebc0f6ea7ae2eefae2b6de4d780556fc5aee45aff230bebcf6ba025959beccffe14a59002fd9552b339892956d2fdd5c50 SHA512 79bdeb59e366cefb2d2a6c9bd084760b5935c93f385a6f2d26bdd25bb4af6939003decc4659afd1567a3b6698a0048e5c79baa716139fc20a96cc0e8dc206d9c
DIST qmapshack-1.17.1_p600.tar.gz 56720384 BLAKE2B 0a76b90273838898c74d6fcf81de0903cd24c294e5ccb7333cdc478b22f01bb771bcc155683c27e0310b018b2c47cf23235b3cd65b81779f97104e389b79450b SHA512 05729eddaca0fd845490eb56e0a0c4ed6d3a721433c24c3e8a6a424a2d6dbb6f9a16dfc8babe4a4ae1b48d8215f586654b1385f748ee8497d629ecdbe4fae2f9
+DIST qmapshack-1.17.1_p601.tar.gz 56720740 BLAKE2B 7fd8232e0c5b693d565897dff90ac6c6012918f2739d9cbfa48e7629e3a905609f47b9665d1a7666a131da64739a499a54f9959d275ab4c7f013db0e83d9760a SHA512 9378e1d42a6217cbf169fc67476765f6700886b59518a1c800c5a639b2822e8116cabaac28c147f3a52014bb2393deb1a8e8b7b9c4112f1990361d0376530c80
diff --git a/sci-geosciences/qmapshack/files/dbus-r1.patch b/sci-geosciences/qmapshack/files/dbus-r1.patch
new file mode 100644
index 000000000000..0ab4294f63ad
--- /dev/null
+++ b/sci-geosciences/qmapshack/files/dbus-r1.patch
@@ -0,0 +1,63 @@
+diff '--color=auto' -ur qmapshack-1f009ac0be1d1c2a4c31aa1283f4009e88685d34.orig/CMakeLists.txt qmapshack-1f009ac0be1d1c2a4c31aa1283f4009e88685d34/CMakeLists.txt
+--- qmapshack-1f009ac0be1d1c2a4c31aa1283f4009e88685d34.orig/CMakeLists.txt 2024-09-30 20:02:57.701618381 +0200
++++ qmapshack-1f009ac0be1d1c2a4c31aa1283f4009e88685d34/CMakeLists.txt 2024-09-30 20:05:59.159600329 +0200
+@@ -200,9 +200,9 @@
+
+ if(USE_QT6DBus)
+ find_package(Qt6DBus REQUIRED)
+- if(Qt5DBus_FOUND)
++ if(Qt6DBus_FOUND)
+ add_definitions(-DHAVE_DBUS)
+- endif(Qt5DBus_FOUND)
++ endif(Qt6DBus_FOUND)
+ endif(USE_QT6DBus)
+
+ # Everything included. Let's finetune the mess a bit more
+diff '--color=auto' -ur qmapshack-1f009ac0be1d1c2a4c31aa1283f4009e88685d34.orig/src/qmapshack/CMakeLists.txt qmapshack-1f009ac0be1d1c2a4c31aa1283f4009e88685d34/src/qmapshack/CMakeLists.txt
+--- qmapshack-1f009ac0be1d1c2a4c31aa1283f4009e88685d34.orig/src/qmapshack/CMakeLists.txt 2024-09-30 20:02:57.687618460 +0200
++++ qmapshack-1f009ac0be1d1c2a4c31aa1283f4009e88685d34/src/qmapshack/CMakeLists.txt 2024-09-30 20:06:51.470306845 +0200
+@@ -368,12 +368,12 @@
+ )
+
+
+-if(Qt5DBus_FOUND)
++if(Qt6DBus_FOUND)
+ set( SRCS
+ ${SRCS}
+ device/CDeviceWatcherLinux.cpp
+ )
+-endif(Qt5DBus_FOUND)
++endif(Qt6DBus_FOUND)
+
+
+ if (APPLE)
+@@ -746,12 +746,12 @@
+ )
+
+
+-if(Qt5DBus_FOUND)
++if(Qt6DBus_FOUND)
+ set( HDRS
+ ${HDRS}
+ device/CDeviceWatcherLinux.h
+ )
+-endif(Qt5DBus_FOUND)
++endif(Qt6DBus_FOUND)
+
+
+ if(APPLE)
+@@ -977,11 +977,11 @@
+ )
+ endif(${DEVELOPMENT_VERSION})
+
+-if(Qt5DBus_FOUND)
++if(Qt6DBus_FOUND)
+ set(DBUS_LIB Qt6::DBus)
+-else(Qt5DBus_FOUND)
++else(Qt6DBus_FOUND)
+ set(DBUS_LIB)
+-endif(Qt5DBus_FOUND)
++endif(Qt6DBus_FOUND)
+
+ target_link_libraries(${APPLICATION_NAME}
+ Qt6::Widgets
diff --git a/sci-geosciences/qmapshack/qmapshack-1.17.1_p601.ebuild b/sci-geosciences/qmapshack/qmapshack-1.17.1_p601.ebuild
new file mode 100644
index 000000000000..d8473b11f33a
--- /dev/null
+++ b/sci-geosciences/qmapshack/qmapshack-1.17.1_p601.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg
+
+DESCRIPTION="GPS mapping utility"
+HOMEPAGE="https://github.com/Maproom/qmapshack/wiki"
+COMMIT="b53959a305587f0a7f2330b99267b3b24abb76f4"
+SRC_URI="https://github.com/Maproom/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-${COMMIT}
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dbus"
+
+RDEPEND="
+ dev-db/sqlite
+ >=dev-libs/quazip-1.3:0=[qt6]
+ dev-qt/qt5compat:6
+ dev-qt/qtbase:6[dbus,gui,network,sql,widgets,xml]
+ dev-qt/qtdeclarative:6
+ dev-qt/qttools:6[assistant,widgets]
+ dev-qt/qtwebengine:6[widgets]
+ sci-geosciences/routino
+ sci-libs/alglib
+ sci-libs/gdal:=
+ sci-libs/proj:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-qt/qttools:6[linguist]"
+
+PATCHES=( "${FILESDIR}"/dbus-r1.patch )
+
+src_configure() {
+ local mycmakeargs=( -DUSE_QT6DBus=$(usex dbus) )
+ cmake_src_configure
+}
+
+src_install() {
+ docompress -x /usr/share/doc/${PF}/html
+ cmake_src_install
+ mv "${D}"/usr/share/doc/HTML "${D}"/usr/share/doc/${PF}/html || die "mv Qt help failed"
+ ewarn "An experimental Qt6 port"
+ ewarn "Translations and the help system are broken"
+ ewarn "Other bugs to https://github.com/Maproom/qmapshack/issues"
+}