summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/gaul-devel/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/gaul-devel/files')
-rw-r--r--sci-libs/gaul-devel/files/gaul-devel-0.1849-as-needed.patch26
-rw-r--r--sci-libs/gaul-devel/files/gaul-devel-0.1849-slang2-error.patch30
2 files changed, 56 insertions, 0 deletions
diff --git a/sci-libs/gaul-devel/files/gaul-devel-0.1849-as-needed.patch b/sci-libs/gaul-devel/files/gaul-devel-0.1849-as-needed.patch
new file mode 100644
index 000000000000..aadea97e6929
--- /dev/null
+++ b/sci-libs/gaul-devel/files/gaul-devel-0.1849-as-needed.patch
@@ -0,0 +1,26 @@
+--- gaul-devel-0.1849-0.orig/src/Makefile.am 2005-04-20 16:25:27.000000000 +0200
++++ gaul-devel-0.1849-0/src/Makefile.am 2010-02-13 16:57:55.051370268 +0100
+@@ -83,7 +83,7 @@
+ gaul/ga_tabu.h \
+ gaul.h
+
+-libgaul_la_LIBFLAGS = -lm
++libgaul_la_LIBADD = $(top_srcdir)/util/libgaul_util.la -lm
+ libgaul_la_LDFLAGS = -version-info ${GA_MAJOR_VERSION}:${GA_LT_MINOR_VERSION}:0
+
+
+--- gaul-devel-0.1849-0.orig/util/Makefile.am 2005-04-20 16:25:53.000000000 +0200
++++ gaul-devel-0.1849-0/util/Makefile.am 2010-02-13 17:00:00.128370192 +0100
+@@ -64,10 +64,10 @@
+ gaul/table_util.h \
+ gaul/timer_util.h
+
+-libgaul_util_a_LIBFLAGS =
++libgaul_util_la_LIBADD = -lm
+ libgaul_util_la_LDFLAGS = -version-info ${GA_MAJOR_VERSION}:${GA_LT_MINOR_VERSION}:0
+
+-libnn_util_a_LIBFLAGS =
++libnn_util_la_LIBADD = -lm
+ libnn_util_la_LDFLAGS = -version-info ${GA_MAJOR_VERSION}:${GA_LT_MINOR_VERSION}:0
+
+ # Regenerate gaul_config.h with config.status whenever gaul_config.h.in changes.
diff --git a/sci-libs/gaul-devel/files/gaul-devel-0.1849-slang2-error.patch b/sci-libs/gaul-devel/files/gaul-devel-0.1849-slang2-error.patch
new file mode 100644
index 000000000000..64b3c59a28bb
--- /dev/null
+++ b/sci-libs/gaul-devel/files/gaul-devel-0.1849-slang2-error.patch
@@ -0,0 +1,30 @@
+diff -Naur gaul-devel-0.1849-0/tests/test_slang.c gaul-devel-0.1849-0.new/tests/test_slang.c
+--- gaul-devel-0.1849-0/tests/test_slang.c 2003-08-19 17:41:20.000000000 -0400
++++ gaul-devel-0.1849-0.new/tests/test_slang.c 2008-02-09 10:42:43.000000000 -0500
+@@ -287,10 +287,11 @@
+ */
+ if (-1 == SLang_load_file(script_fname))
+ {
++ int error = SLang_get_error();
+ dief("Error %d interpreting the S-Lang script \"%s\".",
+- SLang_Error, script_fname);
++ error, script_fname);
+ SLang_restart(1); /* reset interpreter. */
+- SLang_Error = 0;
++ SLang_set_error(0);
+ return FALSE;
+ }
+
+@@ -315,9 +316,10 @@
+ */
+ if (-1 == SLang_load_file(NULL))
+ {
+- dief("Error %d interpreting the SLang script from stdin.", SLang_Error);
++ int error = SLang_get_error();
++ dief("Error %d interpreting the SLang script from stdin.", error);
+ SLang_restart(1);
+- SLang_Error = 0;
++ SLang_set_error(0);
+ return FALSE;
+ }
+