summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSv. Lockal <lockalsash@gmail.com>2024-03-18 18:25:28 +0000
committerSam James <sam@gentoo.org>2024-06-26 10:19:18 +0100
commit233805ea2de8f036521ac04cf130ec63b1737b56 (patch)
tree4c306fbd74de867b440e2f043525800256cba7ff /sci-libs/hipRAND
parentsci-libs/hipBLAS: add 6.1.1 (diff)
downloadgentoo-233805ea2de8f036521ac04cf130ec63b1737b56.tar.gz
gentoo-233805ea2de8f036521ac04cf130ec63b1737b56.tar.bz2
gentoo-233805ea2de8f036521ac04cf130ec63b1737b56.zip
sci-libs/hipRAND: add 6.1.1
* Rename ROCmSoftwarePlatform to ROCm in URLs * Add myself as a maintainer Signed-off-by: Sv. Lockal <lockalsash@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs/hipRAND')
-rw-r--r--sci-libs/hipRAND/Manifest1
-rw-r--r--sci-libs/hipRAND/hipRAND-5.6.0-r1.ebuild3
-rw-r--r--sci-libs/hipRAND/hipRAND-5.7.1.ebuild3
-rw-r--r--sci-libs/hipRAND/hipRAND-6.1.1.ebuild35
-rw-r--r--sci-libs/hipRAND/metadata.xml6
5 files changed, 43 insertions, 5 deletions
diff --git a/sci-libs/hipRAND/Manifest b/sci-libs/hipRAND/Manifest
index 39e54dc94d02..0459d75805d5 100644
--- a/sci-libs/hipRAND/Manifest
+++ b/sci-libs/hipRAND/Manifest
@@ -1,2 +1,3 @@
DIST hipRAND-rocm-5.6.0.tar.gz 477597 BLAKE2B fdc88ac7076ab6b31ba794f9274881323fba32295bab5b90e38d8c8f336e0255b7d20dcba6e334b7bacd8b67eaac8a3ac6e11e3d490e7c95a973d16c9598922f SHA512 47d0cca92b458f8ef682b3c15fe4ccc5201370b1458e541080dc2150e98256962b78806c20b26d789b232d420eb305639fa50180e379ba123851d35d24d40cb2
DIST hipRAND-rocm-5.7.1.tar.gz 478352 BLAKE2B 5f435cf53d213b1d95ee8b766df2c9bc4b4d590ccf63fe867bd033eeb4b7fef67e2bde22242525686a8dee59fd811363857312481e9cb3575357c612ab519a41 SHA512 b3c51728c1d7cc37760f49f36ab7765c166f105bc5b1b6ce65ac4a1de9bb70f8e2c10f5c41f89040288b09c9257d913d745a416bd4785b71f170a4f57e1f95e2
+DIST hipRAND-rocm-6.1.1.tar.gz 119063 BLAKE2B dc314d8b09c15351075594335d14f65024be54597e7cbdfb7671ebea29fa208c9a33530a2d406a8a2a9d8738f0aae7e9fc25d8c39304ef2ef27aaf8b327b5975 SHA512 4c350c8a75e6b4064e22cd73679f66e5caf28f7922fc47ef9670c1023b58b36bf3a2a35580463ee7c89e26ed924aaaa68166a11f64823b99f2f8302f80d6e87a
diff --git a/sci-libs/hipRAND/hipRAND-5.6.0-r1.ebuild b/sci-libs/hipRAND/hipRAND-5.6.0-r1.ebuild
index 006440bb6a29..1674ad72718f 100644
--- a/sci-libs/hipRAND/hipRAND-5.6.0-r1.ebuild
+++ b/sci-libs/hipRAND/hipRAND-5.6.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -21,7 +21,6 @@ RESTRICT="test"
RDEPEND="dev-util/hip
sci-libs/rocRAND:${SLOT}[${ROCM_USEDEP}]"
DEPEND="${RDEPEND}"
-BDEPEND=""
S="${WORKDIR}/hipRAND-rocm-${PV}"
diff --git a/sci-libs/hipRAND/hipRAND-5.7.1.ebuild b/sci-libs/hipRAND/hipRAND-5.7.1.ebuild
index 006440bb6a29..1674ad72718f 100644
--- a/sci-libs/hipRAND/hipRAND-5.7.1.ebuild
+++ b/sci-libs/hipRAND/hipRAND-5.7.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -21,7 +21,6 @@ RESTRICT="test"
RDEPEND="dev-util/hip
sci-libs/rocRAND:${SLOT}[${ROCM_USEDEP}]"
DEPEND="${RDEPEND}"
-BDEPEND=""
S="${WORKDIR}/hipRAND-rocm-${PV}"
diff --git a/sci-libs/hipRAND/hipRAND-6.1.1.ebuild b/sci-libs/hipRAND/hipRAND-6.1.1.ebuild
new file mode 100644
index 000000000000..2a123df19544
--- /dev/null
+++ b/sci-libs/hipRAND/hipRAND-6.1.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ROCM_VERSION=${PV}
+
+inherit cmake rocm
+
+DESCRIPTION="CU / ROCM agnostic hip RAND implementation"
+HOMEPAGE="https://github.com/ROCm/hipRAND"
+SRC_URI="https://github.com/ROCm/hipRAND/archive/refs/tags/rocm-${PV}.tar.gz -> hipRAND-rocm-${PV}.tar.gz"
+S="${WORKDIR}/hipRAND-rocm-${PV}"
+
+REQUIRED_USE="${ROCM_REQUIRED_USE}"
+
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64"
+
+RESTRICT="test"
+
+RDEPEND="dev-util/hip
+ sci-libs/rocRAND:${SLOT}[${ROCM_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DAMDGPU_TARGETS="$(get_amdgpu_flags)"
+ -DBUILD_FILE_REORG_BACKWARD_COMPATIBILITY=OFF
+ -DROCM_SYMLINK_LIBS=OFF
+ )
+
+ CXX=hipcc cmake_src_configure
+}
diff --git a/sci-libs/hipRAND/metadata.xml b/sci-libs/hipRAND/metadata.xml
index 27c8916b67d4..c47caac8ebdf 100644
--- a/sci-libs/hipRAND/metadata.xml
+++ b/sci-libs/hipRAND/metadata.xml
@@ -9,7 +9,11 @@
<email>xgreenlandforwyy@gmail.com</email>
<name>Yiyang Wu</name>
</maintainer>
+ <maintainer type="person">
+ <email>lockalsash@gmail.com</email>
+ <name>Sv. Lockal</name>
+ </maintainer>
<upstream>
- <remote-id type="github">ROCmSoftwarePlatform/hipRAND</remote-id>
+ <remote-id type="github">ROCm/hipRAND</remote-id>
</upstream>
</pkgmetadata>