summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <floss@bsd.ac>2021-04-23 18:46:36 +0200
committerDavid Seifert <soap@gentoo.org>2021-04-23 18:46:36 +0200
commit395eb9c6329ad0d2790d190b0441928563b116ad (patch)
tree1c4a0585110f25cec1d9bc1717ebb5ac3ebaad28 /sci-libs/kissfft/kissfft-9999.ebuild
parentapp-misc/gtypist: Keyword 2.9.5-r1 arm64, #728262 (diff)
downloadgentoo-395eb9c6329ad0d2790d190b0441928563b116ad.tar.gz
gentoo-395eb9c6329ad0d2790d190b0441928563b116ad.tar.bz2
gentoo-395eb9c6329ad0d2790d190b0441928563b116ad.zip
sci-libs/kissfft: new fft library
* new dependency of vtk Closes: https://github.com/gentoo/gentoo/pull/20513 Closes: https://bugs.gentoo.org/754690 Bug: https://bugs.gentoo.org/754684 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Aisha Tammy <gentoo@aisha.cc> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-libs/kissfft/kissfft-9999.ebuild')
-rw-r--r--sci-libs/kissfft/kissfft-9999.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/sci-libs/kissfft/kissfft-9999.ebuild b/sci-libs/kissfft/kissfft-9999.ebuild
new file mode 100644
index 000000000000..ad2bc1ff31a9
--- /dev/null
+++ b/sci-libs/kissfft/kissfft-9999.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit cmake python-any-r1 toolchain-funcs
+
+DESCRIPTION="A Fast Fourier Transform (FFT) library that tries to Keep it Simple, Stupid"
+HOMEPAGE="https://github.com/mborgerding/kissfft"
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/mborgerding/kissfft"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/mborgerding/kissfft/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="alloca cpu_flags_x86_sse openmp test tools"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ test? (
+ sci-libs/fftw:3.0
+ $(python_gen_any_dep '
+ dev-python/numpy[${PYTHON_USEDEP}]
+ ')
+ )
+"
+
+python_check_deps() {
+ has_version -d "dev-python/numpy[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DKISSFFT_OPENMP=$(usex openmp)
+ -DKISSFFT_TEST=$(usex test)
+ -DKISSFFT_TOOLS=$(usex tools)
+ -DKISSFFT_USE_ALLOCA=$(usex alloca)
+ -DKISSFFT_DATATYPE=$(usex cpu_flags_x86_sse simd float)
+ )
+
+ cmake_src_configure
+}