summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2018-02-06 18:39:29 -0600
committerMatthias Maier <tamiko@gentoo.org>2018-02-06 18:54:22 -0600
commit7e5da8074cbce28ae6a7da1eefa43d6650c2e301 (patch)
tree266ee290ddebafc35f1627b4e1e7db81d97afa81 /sci-libs/libqalculate
parentmedia-sound/quodlibet: version bump to 4.0.2 (diff)
downloadgentoo-7e5da8074cbce28ae6a7da1eefa43d6650c2e301.tar.gz
gentoo-7e5da8074cbce28ae6a7da1eefa43d6650c2e301.tar.bz2
gentoo-7e5da8074cbce28ae6a7da1eefa43d6650c2e301.zip
sci-libs/libqalculate: version bump to 2.2.0
Closes: https://bugs.gentoo.org/637022 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'sci-libs/libqalculate')
-rw-r--r--sci-libs/libqalculate/Manifest1
-rw-r--r--sci-libs/libqalculate/libqalculate-2.2.0.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/sci-libs/libqalculate/Manifest b/sci-libs/libqalculate/Manifest
index db4468919364..32acb8c9cef2 100644
--- a/sci-libs/libqalculate/Manifest
+++ b/sci-libs/libqalculate/Manifest
@@ -1,2 +1,3 @@
DIST libqalculate-0.9.7.tar.gz 1256271 BLAKE2B 47481d3288d04211dd060b87a723fd93fccb2bb34b3111a2f5ea4071db5cac59454d28e717638a1cb86fe51c86be6d6793f41d9c3446aad5a845a452e378cb22 SHA512 9aae8540481df4aa1cb24b1c6e8e9424e87758444f0b9689cd809bdf4230c4b5257c74363e6f084cea4e3be1935f45c53e7fc592f76d25d709ad88c97884bc42
DIST libqalculate-0.9.9.tar.gz 1509180 BLAKE2B 3f309add80ddb6b21730eab25d37c2d8fee163a79768a09ec5e7e5d329aa11ed9dafbf77f4ce194a96c2ac6a3b55a9c0d16755d5e106123cc2a5f931f6872d91 SHA512 c7692dcd91e0a7aea8184ca5366a3caf704b6e716c9e8552f4214ce7fc3157cf127daf7a063196383e4d5a99f8703486f2282c7fb01acafee5e1b3d8993de384
+DIST libqalculate-2.2.0.tar.gz 1717207 BLAKE2B 020ca544683ff140ab5f8256a5a955c895a6ea09a581e9e75ab6c0a0657886c352a1ec2d34400057fe80004481d3198998613113ca40fb4feebfca010445dced SHA512 e6f3693e4dba2beffca300b673657b90037a6b7acc5bbd4e659863f4f5aec148d6d385fc3c666b16b2be713d0a8ad1b4d7fda557cef0e2be340ca2435f62aae7
diff --git a/sci-libs/libqalculate/libqalculate-2.2.0.ebuild b/sci-libs/libqalculate/libqalculate-2.2.0.ebuild
new file mode 100644
index 000000000000..4b4799063525
--- /dev/null
+++ b/sci-libs/libqalculate/libqalculate-2.2.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="A modern multi-purpose calculator library"
+HOMEPAGE="https://qalculate.github.io/"
+SRC_URI="https://github.com/Qalculate/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/7"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="gnuplot readline static-libs"
+
+COMMON_DEPEND="
+ dev-libs/glib:2
+ dev-libs/libxml2:2
+ >=sci-libs/cln-1.2
+ sys-libs/zlib
+ readline? ( sys-libs/readline:0= )"
+DEPEND="${COMMON_DEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+RDEPEND="${COMMON_DEPEND}
+ net-misc/wget
+ gnuplot? ( >=sci-visualization/gnuplot-3.7 )"
+
+src_prepare() {
+ default
+
+ cat >po/POTFILES.skip <<-EOF
+ # Required by make check
+ data/currencies.xml.in
+ data/datasets.xml.in
+ data/elements.xml.in
+ data/functions.xml.in
+ data/planets.xml.in
+ data/units.xml.in
+ data/variables.xml.in
+ src/defs2doc.cc
+ EOF
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_with readline)
+}
+
+src_install() {
+ # docs/reference/Makefile.am -> referencedir=
+ emake \
+ DESTDIR="${D}" \
+ referencedir="${EPREFIX}/usr/share/doc/${PF}/html" \
+ install
+
+ dodoc AUTHORS ChangeLog NEWS README* TODO
+
+ find "${ED}" -name '*.la' -delete || die
+}