summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernd Waibel <waebbl@gmail.com>2019-09-15 18:18:51 +0200
committerSam James <sam@gentoo.org>2020-09-18 16:21:14 +0000
commit4a1cc44e67e78a4d2f507e585df4deea4a91cb81 (patch)
tree6af9759f5cb2d143a4148356ba4bb6604624f23b /sci-libs/mumps
parentprofiles: Re-add empty, hidden ABI_RISCV *and* mask all flags to avoid rebuilds (diff)
downloadgentoo-4a1cc44e67e78a4d2f507e585df4deea4a91cb81.tar.gz
gentoo-4a1cc44e67e78a4d2f507e585df4deea4a91cb81.tar.bz2
gentoo-4a1cc44e67e78a4d2f507e585df4deea4a91cb81.zip
sci-libs/mumps: update scotch dependency
- Use >=sci-libs/scotch-6.0.1 for mumps as recommended by upstream - Re-order inherits - Bump to EAPI 7 - Fix missing / after ${EROOT} Closes: https://bugs.gentoo.org/670759 Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Bernd Waibel <waebbl@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/12936 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs/mumps')
-rw-r--r--sci-libs/mumps/mumps-5.1.2-r1.ebuild (renamed from sci-libs/mumps/mumps-5.1.2.ebuild)27
1 files changed, 16 insertions, 11 deletions
diff --git a/sci-libs/mumps/mumps-5.1.2.ebuild b/sci-libs/mumps/mumps-5.1.2-r1.ebuild
index 477d6dbaeef7..be2c5c64986c 100644
--- a/sci-libs/mumps/mumps-5.1.2.ebuild
+++ b/sci-libs/mumps/mumps-5.1.2-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit eutils toolchain-funcs flag-o-matic versionator fortran-2 multilib
+inherit flag-o-matic fortran-2 toolchain-funcs multilib
MYP=MUMPS_${PV}
@@ -20,18 +20,23 @@ RDEPEND="
virtual/blas
metis? ( || ( >=sci-libs/metis-5 >=sci-libs/parmetis-4 )
mpi? ( >=sci-libs/parmetis-4 ) )
- scotch? ( <sci-libs/scotch-6[mpi=] )
- mpi? ( sci-libs/scalapack )"
-
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+ mpi? ( sci-libs/scalapack )
+ scotch? ( >=sci-libs/scotch-6.0.1[mpi=] )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
S="${WORKDIR}/${MYP}"
+get_version_component_count() {
+ local cnt=( $(ver_rs 1- ' ') )
+ echo ${#cnt[@]}
+}
+
static_to_shared() {
local libstatic=${1}; shift
local libname=$(basename ${libstatic%.a})
- local soname=${libname}$(get_libname $(get_version_component_range 1-2))
+ local soname=${libname}$(get_libname $(ver_cut 1-2))
local libdir=$(dirname ${libstatic})
einfo "Making ${soname} from ${libstatic}"
@@ -46,7 +51,7 @@ static_to_shared() {
-Wl,--whole-archive ${libstatic} -Wl,--no-whole-archive \
"$@" -o ${libdir}/${soname} || die "${soname} failed"
[[ $(get_version_component_count) -gt 1 ]] && \
- ln -s ${soname} ${libdir}/${libname}$(get_libname $(get_major_version))
+ ln -s ${soname} ${libdir}/${libname}$(get_libname $(ver_cut 1))
ln -s ${soname} ${libdir}/${libname}$(get_libname)
fi
}
@@ -90,14 +95,14 @@ src_configure() {
if use scotch && use mpi; then
sed -i \
-e "s:#\s*\(LSCOTCH\s*=\).*:\1-lptesmumps -lptscotch -lptscotcherr:" \
- -e "s:#\s*\(ISCOTCH\s*=\).*:\1-I${EROOT}usr/include/scotch:" \
+ -e "s:#\s*\(ISCOTCH\s*=\).*:\1-I${EROOT}/usr/include/scotch:" \
Makefile.inc || die
LIBADD="${LIBADD} -lptesmumps -lptscotch -lptscotcherr"
ord="${ord} -Dptscotch"
elif use scotch; then
sed -i \
-e "s:#\s*\(LSCOTCH\s*=\).*:\1-lesmumps -lscotch -lscotcherr:" \
- -e "s:#\s*\(ISCOTCH\s*=\).*:\1-I${EROOT}usr/include/scotch:" \
+ -e "s:#\s*\(ISCOTCH\s*=\).*:\1-I${EROOT}/usr/include/scotch:" \
Makefile.inc || die
LIBADD="${LIBADD} -lesmumps -lscotch -lscotcherr"
ord="${ord} -Dscotch"