summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2018-01-06 13:07:27 +0000
committerJustin Lecher <jlec@gentoo.org>2018-01-06 13:35:37 +0000
commit9c91c5aeeeab659d33ed526773c1d1a7fe2ddcf3 (patch)
treebcc52b3884888e35c65a808a0c79d88703404b17 /sci-libs/rosetta-fragments
parentsci-libs/mmdb: Build shared libs (diff)
downloadgentoo-9c91c5aeeeab659d33ed526773c1d1a7fe2ddcf3.tar.gz
gentoo-9c91c5aeeeab659d33ed526773c1d1a7fe2ddcf3.tar.bz2
gentoo-9c91c5aeeeab659d33ed526773c1d1a7fe2ddcf3.zip
sci-libs/rosetta-fragments: Bump to EAPI=6
Add latest hashes Closes: https://bugs.gentoo.org/642910 Signed-off-by: Justin Lecher <jlec@gentoo.org> Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'sci-libs/rosetta-fragments')
-rw-r--r--sci-libs/rosetta-fragments/rosetta-fragments-3.1-r1.ebuild18
1 files changed, 12 insertions, 6 deletions
diff --git a/sci-libs/rosetta-fragments/rosetta-fragments-3.1-r1.ebuild b/sci-libs/rosetta-fragments/rosetta-fragments-3.1-r1.ebuild
index 055c225edf1d..63666973b31e 100644
--- a/sci-libs/rosetta-fragments/rosetta-fragments-3.1-r1.ebuild
+++ b/sci-libs/rosetta-fragments/rosetta-fragments-3.1-r1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
inherit eutils flag-o-matic prefix toolchain-funcs
@@ -24,15 +24,18 @@ RESTRICT="fetch"
S="${WORKDIR}"/${PN/-/_}
+PATCHES=(
+ "${FILESDIR}"/${P}-nnmake.patch
+ "${FILESDIR}"/${P}-chemshift.patch
+)
+
pkg_nofetch() {
einfo "Go to ${HOMEPAGE} and get ${PN}.tgz and rename it to ${A}"
einfo "which must be placed in ${DISTDIR}"
}
src_prepare() {
- epatch \
- "${FILESDIR}"/${P}-nnmake.patch \
- "${FILESDIR}"/${P}-chemshift.patch
+ default
tc-export F77
eprefixify nnmake/*.pl
}
@@ -52,5 +55,8 @@ src_install() {
insinto /usr/share/${PN}
doins -r *_database
- dodoc fragments.README nnmake/{nnmake.README,vall/*.pl} chemshift/chemshift.README
+ dodoc \
+ fragments.README \
+ nnmake/{nnmake.README,vall/*.pl} \
+ chemshift/chemshift.README
}