summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernd Waibel <waebbl-gentoo@posteo.net>2022-06-18 12:29:13 +0200
committerSam James <sam@gentoo.org>2022-06-26 08:09:32 +0100
commitd699c8995b81d8cd0be7d051485af755d25cdf11 (patch)
treef34db4cb4d88ddae384e830504c5bc5afa0eabc1 /sci-libs/vtk
parentsys-cluster/slurm: unpin hdf5 dep; fix MissingUseDepDefault (diff)
downloadgentoo-d699c8995b81d8cd0be7d051485af755d25cdf11.tar.gz
gentoo-d699c8995b81d8cd0be7d051485af755d25cdf11.tar.bz2
gentoo-d699c8995b81d8cd0be7d051485af755d25cdf11.zip
sci-libs/vtk: fix build against netcdf-4.9.0
Closes: https://bugs.gentoo.org/851594 Signed-off-by: Bernd Waibel <waebbl-gentoo@posteo.net> Closes: https://github.com/gentoo/gentoo/pull/25954 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs/vtk')
-rw-r--r--sci-libs/vtk/files/vtk-9.1.0-avoid-naming-collision-with-netcdf-4.9.0.patch26
-rw-r--r--sci-libs/vtk/vtk-9.1.0-r2.ebuild1
2 files changed, 27 insertions, 0 deletions
diff --git a/sci-libs/vtk/files/vtk-9.1.0-avoid-naming-collision-with-netcdf-4.9.0.patch b/sci-libs/vtk/files/vtk-9.1.0-avoid-naming-collision-with-netcdf-4.9.0.patch
new file mode 100644
index 000000000000..7549c240ee51
--- /dev/null
+++ b/sci-libs/vtk/files/vtk-9.1.0-avoid-naming-collision-with-netcdf-4.9.0.patch
@@ -0,0 +1,26 @@
+https://bugs.gentoo.org/851594
+
+From b155e9716a1cf4a03948c01f49c4097e466da4f0 Mon Sep 17 00:00:00 2001
+From: Bernd Waibel <waebbl-gentoo@posteo.net>
+Date: Mon, 20 Jun 2022 07:07:19 +0200
+Subject: [PATCH] avoid naming collision with netcdf-4.9.0
+
+The identifier has already been #defined with netcdf-4.9.0. To avoid
+conflicts guard the declaration.
+
+Signed-off-by: Bernd Waibel <waebbl-gentoo@posteo.net>
+--- a/ThirdParty/exodusII/vtkexodusII/src/ex_utils.c
++++ b/ThirdParty/exodusII/vtkexodusII/src/ex_utils.c
+@@ -1770,7 +1770,9 @@ void ex__compress_variable(int exoid, int varid, int type)
+ */
+
+ /* const int NC_SZIP_EC = 4; */ /* Selects entropy coding method for szip. */
++#ifndef NC_SZIP_NN
+ const int NC_SZIP_NN = 32; /* Selects nearest neighbor coding method for szip. */
++#endif
+ /* Even and between 4 and 32; typical values are 8, 10, 16, 32 */
+ const int SZIP_PIXELS_PER_BLOCK =
+ file->compression_level == 0 ? 32 : file->compression_level;
+--
+2.35.1
+
diff --git a/sci-libs/vtk/vtk-9.1.0-r2.ebuild b/sci-libs/vtk/vtk-9.1.0-r2.ebuild
index 13d7663c5bbf..1e80b96b80b4 100644
--- a/sci-libs/vtk/vtk-9.1.0-r2.ebuild
+++ b/sci-libs/vtk/vtk-9.1.0-r2.ebuild
@@ -144,6 +144,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-8.2.0-freetype-2.10.3-provide-FT_CALLBACK_DEF.patch
"${FILESDIR}"/${PN}-9.0.3-IO-FFMPEG-support-FFmpeg-5.0-API-changes.patch
"${FILESDIR}"/${P}-adjust-to-find-binaries.patch
+ "${FILESDIR}"/${P}-avoid-naming-collision-with-netcdf-4.9.0.patch
)
DOCS=( CONTRIBUTING.md README.md )