summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Torokhov <torokhov-s-a@yandex.ru>2023-01-15 01:07:50 +0300
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-01-30 10:59:57 +0100
commitf7863f22616f8bc02740874a95c084187444b10d (patch)
treeaf900fc858ccea8c67383399fef37124105fffed /sci-libs
parentsci-libs/cantera: 2.6.0-r2 revision bump (diff)
downloadgentoo-f7863f22616f8bc02740874a95c084187444b10d.tar.gz
gentoo-f7863f22616f8bc02740874a95c084187444b10d.tar.bz2
gentoo-f7863f22616f8bc02740874a95c084187444b10d.zip
sci-libs/cantera: drop old 2.5.1-r4
Signed-off-by: Sergey Torokhov <torokhov-s-a@yandex.ru> Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/cantera/Manifest1
-rw-r--r--sci-libs/cantera/cantera-2.5.1-r4.ebuild145
-rw-r--r--sci-libs/cantera/files/cantera-2.5.1_env.patch130
3 files changed, 0 insertions, 276 deletions
diff --git a/sci-libs/cantera/Manifest b/sci-libs/cantera/Manifest
index beccad729392..6b5da97bd886 100644
--- a/sci-libs/cantera/Manifest
+++ b/sci-libs/cantera/Manifest
@@ -1,2 +1 @@
-DIST cantera-2.5.1.tar.gz 2492422 BLAKE2B b48c5d12fc2b69d309759afd20b55dc2533c23ccba840109cf7a85c4ebb8306eb48d9f007914184a9d409f7bf296814fe09e6e62a29cf8384edd954fdff2af4e SHA512 8cd65f6b86b3009f22ec243cb7cb833e26919c4925fd15fba8fb98aad2180d8c0fe7550e13efeb7cce55abab06d9400230d59c9c43b4d3be6b0575b1164a56bc
DIST cantera-2.6.0.tar.gz 2586243 BLAKE2B 3562dc3641c70cdbd5e07062ecee56c0658b098c20bb477c3e741731db01e38fccf624e6769377420b01dd4bac72a0608cf226cce40ac12f13e71081090e06bc SHA512 74e12c89af38236bcc064034f74edcc690895151a9e453e728d130b83f5f527e675750c68a3fe36eea3c6aec6969685aa8828ae740a2e27b5df72a8ccc4d2856
diff --git a/sci-libs/cantera/cantera-2.5.1-r4.ebuild b/sci-libs/cantera/cantera-2.5.1-r4.ebuild
deleted file mode 100644
index 9d87e7aa5b6f..000000000000
--- a/sci-libs/cantera/cantera-2.5.1-r4.ebuild
+++ /dev/null
@@ -1,145 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{9..10} )
-
-FORTRAN_NEEDED=fortran
-FORTRAN_STANDARD="77 90"
-
-inherit fortran-2 python-single-r1 scons-utils toolchain-funcs
-
-DESCRIPTION="Object-oriented tool suite for chemical kinetics, thermodynamics, and transport"
-HOMEPAGE="https://www.cantera.org"
-SRC_URI="https://github.com/Cantera/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~x86"
-IUSE="+cti fortran lapack +python test"
-RESTRICT="!test? ( test )"
-
-REQUIRED_USE="
- python? ( cti )
- ${PYTHON_REQUIRED_USE}
-"
-
-RDEPEND="
- ${PYTHON_DEPS}
- lapack? ( virtual/lapack )
- cti? (
- $(python_gen_cond_dep '
- dev-python/ruamel-yaml[${PYTHON_USEDEP}]
- ')
- )
- python? (
- $(python_gen_cond_dep '
- dev-python/numpy[${PYTHON_USEDEP}]
- ')
- )
- dev-cpp/yaml-cpp
- !lapack? ( <sci-libs/sundials-5.9.0:0= )
- lapack? ( <sci-libs/sundials-5.3.0:0=[lapack] )
-"
-
-DEPEND="
- ${RDEPEND}
- dev-cpp/eigen:3
- dev-libs/boost
- dev-libs/libfmt
- python? (
- $(python_gen_cond_dep '
- dev-python/cython[${PYTHON_USEDEP}]
- ')
- )
- test? (
- >=dev-cpp/gtest-1.8.0
- python? (
- $(python_gen_cond_dep '
- dev-python/h5py[${PYTHON_USEDEP}]
- dev-python/pandas[${PYTHON_USEDEP}]
- ')
- )
- )
-"
-
-PATCHES=( "${FILESDIR}/${P}_env.patch" )
-
-pkg_setup() {
- fortran-2_pkg_setup
- python-single-r1_pkg_setup
-}
-
-## Full list of configuration options of Cantera is presented here:
-## http://cantera.org/docs/sphinx/html/compiling/config-options.html
-src_configure() {
- scons_vars=(
- AR="$(tc-getAR)"
- CC="$(tc-getCC)"
- CXX="$(tc-getCXX)"
- cc_flags="${CXXFLAGS}"
- cxx_flags="-std=c++11"
- debug="no"
- FORTRAN="$(tc-getFC)"
- FORTRANFLAGS="${FCFLAGS}"
- optimize_flags="-Wno-inline"
- renamed_shared_libraries="no"
- use_pch="no"
- ## In some cases other order can break the detection of right location of Boost: ##
- system_fmt="y"
- system_sundials="y"
- system_eigen="y"
- system_yamlcpp="y"
- env_vars="all"
- extra_inc_dirs="/usr/include/eigen3"
- )
- use lapack && scons_vars+=( blas_lapack_libs="lapack,blas" )
- use test || scons_vars+=( googletest="none" )
-
- scons_targets=(
- f90_interface=$(usex fortran y n)
- )
-
- if use cti ; then
- local scons_python=$(usex python full minimal)
- scons_targets+=( python_package="${scons_python}" python_cmd="${EPYTHON}" )
- else
- scons_targets+=( python_package="none" )
- fi
-}
-
-src_compile() {
- escons build "${scons_vars[@]}" "${scons_targets[@]}" prefix="/usr"
-}
-
-src_test() {
- escons test
-}
-
-src_install() {
- escons install stage_dir="${D}" libdirname="$(get_libdir)" python_prefix="$(python_get_sitedir)"
- if ! use cti ; then
- rm -r "${D}/usr/share/man" || die "Can't remove man files."
- else
- # Run the byte-compile of modules
- python_optimize "${D}$(python_get_sitedir)/${PN}"
- fi
-
- # User could remove this line if require static libs for development purpose
- find "${ED}" -name '*.a' -delete || die
-}
-
-pkg_postinst() {
- if use cti && ! use python ; then
- elog "Cantera was build without 'python' use-flag therefore the CTI tools 'ck2cti' and 'ck2yaml"
- elog "will convert Chemkin files to Cantera format without verification of kinetic mechanism."
- fi
-
- local post_msg=$(usex fortran "and Fortran " "")
- elog "C++ ${post_msg}samples are installed to '/usr/share/${PN}/samples/' directory."
-
- if use python ; then
- elog "Python examples are installed to '$(python_get_sitedir)/${PN}/examples/' directories."
- fi
-}
diff --git a/sci-libs/cantera/files/cantera-2.5.1_env.patch b/sci-libs/cantera/files/cantera-2.5.1_env.patch
deleted file mode 100644
index 77004803b127..000000000000
--- a/sci-libs/cantera/files/cantera-2.5.1_env.patch
+++ /dev/null
@@ -1,130 +0,0 @@
-diff -Naur old/SConstruct new/SConstruct
---- old/SConstruct 2021-03-21 01:18:43.000000000 +0300
-+++ new/SConstruct 2021-03-21 01:27:06.000000000 +0300
-@@ -193,7 +193,7 @@
- toolchain = ['default']
-
- env = Environment(tools=toolchain+['textfile', 'subst', 'recursiveInstall', 'wix', 'gch'],
-- ENV={'PATH': os.environ['PATH']},
-+ ENV={'PATH': os.environ['PATH'], 'CCACHE_DIR': os.environ.get('CCACHE_DIR','')},
- toolchain=toolchain,
- **extraEnvArgs)
-
-@@ -239,6 +239,9 @@
- sys.exit(1)
-
- compiler_options = [
-+ ('AR',
-+ """The archiver to use.""",
-+ env['AR']),
- ('CXX',
- """The C++ compiler to use.""",
- env['CXX']),
-@@ -734,10 +734,7 @@
- env['cantera_pure_version'] = re.match(r'(\d+\.\d+\.\d+)', env['cantera_version']).group(0)
- env['cantera_short_version'] = re.match(r'(\d+\.\d+)', env['cantera_version']).group(0)
-
--try:
-- env['git_commit'] = getCommandOutput('git', 'rev-parse', '--short', 'HEAD')
--except Exception:
-- env['git_commit'] = 'unknown'
-+env['git_commit'] = 'unknown'
-
- # Print values of all build options:
- print("Configuration variables read from 'cantera.conf' and command line:")
-@@ -1149,10 +1149,24 @@
- if retcode == 0:
- config_error("Failed to determine Sundials BLAS/LAPACK.")
- env['has_sundials_lapack'] = int(has_sundials_lapack.strip())
-- else:
-- # In Sundials 2.6, SUNDIALS_BLAS_LAPACK is either defined or undefined
-+ elif sundials_ver < parse_version('5.5'):
-+ # In Sundials 2.6-5.5, SUNDIALS_BLAS_LAPACK is either defined or undefined
- env['has_sundials_lapack'] = conf.CheckDeclaration('SUNDIALS_BLAS_LAPACK',
- '#include "sundials/sundials_config.h"', 'C++')
-+ else:
-+ # In Sundials 5.5 and higher, two defines are included specific to the
-+ # SUNLINSOL packages indicating whether SUNDIALS has been built with LAPACK
-+ lapackband = conf.CheckDeclaration(
-+ "SUNDIALS_SUNLINSOL_LAPACKBAND",
-+ '#include "sundials/sundials_config.h"',
-+ "C++",
-+ )
-+ lapackdense = conf.CheckDeclaration(
-+ "SUNDIALS_SUNLINSOL_LAPACKDENSE",
-+ '#include "sundials/sundials_config.h"',
-+ "C++",
-+ )
-+ env["has_sundials_lapack"] = lapackband and lapackdense
-
- # In the case where a user is trying to link Cantera to an external BLAS/LAPACK
- # library, but Sundials was configured without this support, print a Warning.
-diff -Naur old/interfaces/cython/SConscript new/interfaces/cython/SConscript
---- old/interfaces/cython/SConscript 2021-03-21 01:18:43.000000000 +0300
-+++ new/interfaces/cython/SConscript 2021-03-21 01:59:29.000000000 +0300
-@@ -108,8 +108,7 @@
- elif localenv['libdirname'] != 'lib':
- # 64-bit RHEL / Fedora etc. or e.g. x32 Gentoo profile
- extra = localenv.subst(
-- ' --prefix=${{python_prefix}}'
-- ' --install-lib=${{python_prefix}}/${{libdirname}}/python{}/site-packages'.format(py_version))
-+ ' --prefix=${stage_dir}${prefix} --install-lib=${python_prefix}')
- else:
- extra = '--user'
- localenv.AppendENVPath(
-diff -Naur old/interfaces/python_minimal/SConscript new/interfaces/python_minimal/SConscript
---- old/interfaces/python_minimal/SConscript 2021-02-13 00:57:15.000000000 +0300
-+++ new/interfaces/python_minimal/SConscript 2021-04-09 23:26:28.000000000 +0300
-@@ -8,7 +8,7 @@
- make_setup = build(localenv.SubstFile('setup.py', 'setup.py.in'))
-
- # copy scripts from the full Cython module
--for script in ['ctml_writer', 'ck2cti']:
-+for script in ['ctml_writer', 'ck2cti', 'ck2yaml', 'cti2yaml', 'ctml2yaml']:
- # The actual script
- s = build(env.Command('cantera/{}.py'.format(script),
- '#interfaces/cython/cantera/{}.py'.format(script),
-@@ -38,8 +38,7 @@
- elif localenv['libdirname'] != 'lib':
- # 64-bit RHEL / Fedora etc. or e.g. x32 Gentoo profile
- extra = localenv.subst(
-- ' --prefix=${{python_prefix}}'
-- ' --install-lib=${{python_prefix}}/${{libdirname}}/python{}/site-packages'.format(py_version))
-+ ' --prefix=${stage_dir}${prefix} --install-lib=${python_prefix}')
- else:
- extra = '--user'
- localenv.AppendENVPath(
-diff -Naur old/interfaces/python_minimal/cantera/__init__.py new/interfaces/python_minimal/cantera/__init__.py
---- old/interfaces/python_minimal/cantera/__init__.py 2021-02-13 00:57:15.000000000 +0300
-+++ new/interfaces/python_minimal/cantera/__init__.py 2021-04-10 00:07:38.000000000 +0300
-@@ -1,2 +1,5 @@
- from . import ck2cti
- from . import ctml_writer
-+from . import ck2yaml
-+from . import cti2yaml
-+from . import ctml2yaml
-diff -Naur old/interfaces/python_minimal/setup.py.in new/interfaces/python_minimal/setup.py.in
---- old/interfaces/python_minimal/setup.py.in 2021-02-13 00:57:15.000000000 +0300
-+++ new/interfaces/python_minimal/setup.py.in 2021-04-09 23:32:09.000000000 +0300
-@@ -12,6 +12,9 @@
- 'console_scripts': [
- 'ck2cti=cantera.ck2cti:script_entry_point',
- 'ctml_writer=cantera.ctml_writer:main',
-+ 'ck2yaml=cantera.ck2yaml:script_entry_point',
-+ 'cti2yaml=cantera.cti2yaml:main',
-+ 'ctml2yaml=cantera.ctml2yaml:main',
- ],
- },
- )
-diff -Naur old/test_problems/SConscript new/test_problems/SConscript
---- old/test_problems/SConscript 2021-03-21 01:18:43.000000000 +0300
-+++ new/test_problems/SConscript 2021-03-21 01:42:19.000000000 +0300
-@@ -222,7 +222,7 @@
- CompileAndTest('VPsilane_test')
-
- CompileAndTest('clib', 'clib_test', 'clib_test',
-- extensions=['^clib_test.c'], libs=['cantera_shared'])
-+ extensions=['^clib_test.c'])
-
- # C++ Samples
- Test('cxx-bvp', 'cxx_samples', '#build/samples/cxx/bvp/blasius', None,