summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-03-17 03:09:00 -0400
committerSam James <sam@gentoo.org>2024-03-17 07:49:46 +0000
commitffbde6e64183dd733002c25aaa649564c37ff813 (patch)
tree6742594d9c13114db522ba37a4c80b9384a5ddb2 /sci-libs
parentsci-libs/silo: add github upstream metadata (diff)
downloadgentoo-ffbde6e64183dd733002c25aaa649564c37ff813.tar.gz
gentoo-ffbde6e64183dd733002c25aaa649564c37ff813.tar.bz2
gentoo-ffbde6e64183dd733002c25aaa649564c37ff813.zip
sci-libs/pdal: mark as LTO-unsafe, strict-aliasing unsafe
... but only for USE=debug, since the bug is inside the obscure libunwind support which most people don't use anyway. Closes: https://bugs.gentoo.org/862915 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/pdal/pdal-2.6.2.ebuild12
1 files changed, 11 insertions, 1 deletions
diff --git a/sci-libs/pdal/pdal-2.6.2.ebuild b/sci-libs/pdal/pdal-2.6.2.ebuild
index 5a1dd8a8193e..a5c701ad7ee0 100644
--- a/sci-libs/pdal/pdal-2.6.2.ebuild
+++ b/sci-libs/pdal/pdal-2.6.2.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit cmake
+inherit cmake flag-o-matic
DESCRIPTION="A C++ library for translating and manipulating point cloud data"
HOMEPAGE="https://pdal.io/"
@@ -39,6 +39,16 @@ DEPEND="
S="${WORKDIR}/PDAL-${PV}-src"
src_configure() {
+ # -Werror=strict-aliasing
+ # https://bugs.gentoo.org/862915
+ # https://github.com/PDAL/PDAL/issues/3836
+ #
+ # only occurs inside unwind support
+ if use debug; then
+ append-flags -fno-strict-aliasing
+ filter-lto
+ fi
+
local mycmakeargs=(
-DBUILD_PLUGIN_PGPOINTCLOUD="$(usex postgres)"
-DWITH_COMPLETION=ON