summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2021-04-08 20:04:14 -0400
committerMichael Orlitzky <mjo@gentoo.org>2021-04-08 21:04:14 -0400
commitf2b86c15023bdd36dea0ce710e87ddc664f2a3b5 (patch)
tree96a0f08587362ba60a947a417954ecdb6b2105e9 /sci-mathematics/arb
parentnet-p2p/cpuminer-opt: Cleanup old version (diff)
downloadgentoo-f2b86c15023bdd36dea0ce710e87ddc664f2a3b5.tar.gz
gentoo-f2b86c15023bdd36dea0ce710e87ddc664f2a3b5.tar.bz2
gentoo-f2b86c15023bdd36dea0ce710e87ddc664f2a3b5.zip
sci-mathematics/arb: new upstream version 2.19.0.
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-mathematics/arb')
-rw-r--r--sci-mathematics/arb/Manifest1
-rw-r--r--sci-mathematics/arb/arb-2.19.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/sci-mathematics/arb/Manifest b/sci-mathematics/arb/Manifest
index 292c10dbf4c7..15e552469781 100644
--- a/sci-mathematics/arb/Manifest
+++ b/sci-mathematics/arb/Manifest
@@ -1,2 +1,3 @@
DIST arb-2.17.0.tar.gz 1589083 BLAKE2B 68d5b04dca24129ceaec4e05124e35b474157cf1efbb6505121a03058e014cd4eb67b99497dbbafcf62e9e31f9d11c92f749f6e047e6b1513b6c0cc5ef8f22da SHA512 201e0cebbd1c4857d194e5531c76c6e45a478cf6965b836818919adf0fc04f0fe25e16ecd49c62a438876b67f009b872c4f3c774fe35620be0b22c5e08bdb824
DIST arb-2.18.1.tar.gz 1595831 BLAKE2B 010ae7a17a9cc1c11ded5806ff761115f3e78c48a5d8fc058eae0715b1e00e40345d4e6445a84c71c37627879648f445663dcc3bbcebdeaac8439a993ade38ee SHA512 07afb45829119bc695926dab4221051b221c2cc3952e42c9928efc74570b05fc01c97ea86b1b67c16d7a19a55b4e32dce97e08c9b72f36b33dd62bfccd19bb05
+DIST arb-2.19.0.tar.gz 1606463 BLAKE2B 85d832113ae42737a460198cbf485f825a9435963a888c0d0ab87b7ed7277d158480b573fd8ace42484dd4767bf4f1a372f637cfff01f18c105fd2b62d0d019e SHA512 199d1a26edd01e3b30f7aef69a9ae29456e3db384037744a1e073007ddb93a248873dfe83f3e48f9de58a9d17ebd7dc9a22a058f4adf766599d01d7eb17db204
diff --git a/sci-mathematics/arb/arb-2.19.0.ebuild b/sci-mathematics/arb/arb-2.19.0.ebuild
new file mode 100644
index 000000000000..7a20eee66908
--- /dev/null
+++ b/sci-mathematics/arb/arb-2.19.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_BUILD_TYPE=Release
+inherit cmake
+
+DESCRIPTION="C library for arbitrary-precision interval arithmetic"
+HOMEPAGE="https://fredrikj.net/arb/"
+SRC_URI="https://github.com/fredrik-johansson/arb/archive/${PV}.tar.gz -> ${P}.tar.gz"
+IUSE="test"
+
+RESTRICT="!test? ( test )"
+
+LICENSE="GPL-2+"
+SLOT="0/2"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+RDEPEND="
+ dev-libs/gmp:0=
+ dev-libs/mpfr:0=
+ sci-mathematics/flint:="
+
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.18.0-multilib-strict.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING="$(usex test)"
+ )
+
+ cmake_src_configure
+}