summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-11-19 20:45:22 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-11-19 20:52:08 +0100
commit585c3c9caae3a47255532f85d2595f8bf048a5ac (patch)
tree67e2f17d3d475ed0792b4fc59127c40b80a5c79c /sci-mathematics/coq
parentsci-mathematics/coq: drop old 8.19.0 (diff)
downloadgentoo-585c3c9caae3a47255532f85d2595f8bf048a5ac.tar.gz
gentoo-585c3c9caae3a47255532f85d2595f8bf048a5ac.tar.bz2
gentoo-585c3c9caae3a47255532f85d2595f8bf048a5ac.zip
sci-mathematics/coq: drop old 8.19.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'sci-mathematics/coq')
-rw-r--r--sci-mathematics/coq/Manifest1
-rw-r--r--sci-mathematics/coq/coq-8.19.1.ebuild122
2 files changed, 0 insertions, 123 deletions
diff --git a/sci-mathematics/coq/Manifest b/sci-mathematics/coq/Manifest
index d35ed18e4b25..25ce5290b45c 100644
--- a/sci-mathematics/coq/Manifest
+++ b/sci-mathematics/coq/Manifest
@@ -1,3 +1,2 @@
-DIST coq-8.19.1.tar.gz 7675945 BLAKE2B 62ee346f50d0a22ab217a8e689c3078347519d159619b75f20a8decace356b49c60bcd5b2cec5fbcaffc758a8944f8a7940298df1c0ddddfbd858ed9269c12f3 SHA512 ec8379df34ba6e72bcf0218c66fef248b0e4c5c436fb3f2d7dd83a2c5f349dd0874a67484fcf9c0df3e5d5937d7ae2b2a79274725595b4b0065a381f70769b42
DIST coq-8.19.2.tar.gz 7678311 BLAKE2B 5f9617fbe0127b0c8357c63f331ba3e9fb5a931be9a4a8e8de2e27820a0d986bf99ed9a512740a0f721c742504225ae56e240af893510aa0e449931499d10aab SHA512 91bc81530fa4f6498961583ad51eac5001f139881788b88e360a866ad8e2a6e2c5bce86d1a580ab4cd4782bf49d48318767df82471ce33ba3ac143e5569ad33c
DIST coq-8.20.0.tar.gz 7839432 BLAKE2B 9b489db0cc6874b0a629f3bdb4b503201005ec95a3375441538cd7e51d371a39561b9d0ab23ac485652782fdc7ae8d90c97ca1ff4d9a85fb8727a39ed4a6f48c SHA512 1a7eac6e2f58724a3f9d68bbb321e4cfe963ba1a5551b9b011db4b3f559c79be433d810ff262593d753770ee41ea68fbd6a60daa1e2319ea00dff64c8851d70b
diff --git a/sci-mathematics/coq/coq-8.19.1.ebuild b/sci-mathematics/coq/coq-8.19.1.ebuild
deleted file mode 100644
index a4d16f2c2b48..000000000000
--- a/sci-mathematics/coq/coq-8.19.1.ebuild
+++ /dev/null
@@ -1,122 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-MY_PV="${PV/_p/pl}"
-MY_P="${PN}-${MY_PV}"
-
-inherit check-reqs desktop dune edo
-
-DESCRIPTION="Proof assistant written in O'Caml"
-HOMEPAGE="http://coq.inria.fr/
- https://github.com/coq/coq/"
-SRC_URI="https://github.com/coq/coq/archive/V${MY_PV}.tar.gz
- -> ${P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="LGPL-2.1"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug doc gui +ocamlopt test"
-
-# TODO: Lots of failing tests. Maybe investigate later.
-# RESTRICT="!test? ( test )"
-RESTRICT="test"
-
-RDEPEND="
- dev-ml/num:=
- dev-ml/zarith:=
- gui? (
- >=dev-ml/lablgtk-3.1.2:3=[sourceview,ocamlopt?]
- >=dev-ml/lablgtk-sourceview-3.1.2:3=[ocamlopt?]
- )
-"
-DEPEND="
- ${RDEPEND}
-"
-BDEPEND="
- dev-ml/findlib
- doc? (
- >=dev-java/antlr-4.7:4
- dev-python/antlr4-python3-runtime
- dev-python/beautifulsoup4
- dev-python/pexpect
- dev-python/sphinx-rtd-theme
- dev-python/sphinxcontrib-bibtex
- dev-tex/latexmk
- dev-texlive/texlive-fontsextra
- dev-texlive/texlive-latexextra
- dev-texlive/texlive-xetex
- media-fonts/freefont
- )
- test? (
- dev-ml/ounit2
- )
-"
-
-CHECKREQS_DISK_BUILD="2G"
-
-DOCS=( CODE_OF_CONDUCT.md CONTRIBUTING.md CREDITS INSTALL.md README.md )
-declare -a DUNE_PACKAGES
-
-src_prepare() {
- # Remove failing tests. bug #904186
- rm -r test-suite/coq-makefile/timing || die
-
- default
-}
-
-src_configure() {
- export CAML_LD_LIBRARY_PATH="${S}/kernel/byterun/"
-
- DUNE_PACKAGES=(
- coq-core
- coq-stdlib
- coqide-server
- coq
- )
- use gui && DUNE_PACKAGES+=( coqide )
-
- emake clean
-
- local -a myconf=(
- -prefix /usr
- -libdir "/usr/$(get_libdir)/coq"
- -mandir /usr/share/man
- -docdir "/usr/share/doc/${PF}"
- -datadir /usr/share/coq
- -configdir "/etc/xdg/${PN}"
- -native-compiler "$(usex ocamlopt yes no)"
- )
- use debug && myconf+=( -debug )
- edo sh ./configure "${myconf[@]}"
-}
-
-src_compile() {
- emake DUNEOPT="--display=short --profile release" VERBOSE=1 dunestrap
-
- dune-compile "${DUNE_PACKAGES[@]}"
-
- use doc && emake refman-html
-}
-
-src_install() {
- dune-install "${DUNE_PACKAGES[@]}"
-
- if use gui ; then
- make_desktop_entry coqide "Coq IDE" "${EPREFIX}/usr/share/coq/coq.png"
- fi
-
- local ocamlc_where
- ocamlc_where="$(ocamlc -where)"
-
- # Dune installs into /usr/<libdir>/ocaml/<coq> but
- # Coq wants /usr/<libdir>/<coq> ; symlink those directories
- local sym
- for sym in "${DUNE_PACKAGES[@]}" ; do
- dosym "${ocamlc_where}/${sym}" "/usr/$(get_libdir)/${sym}"
- done
-
- einstalldocs
-}