summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2024-08-04 22:06:11 -0400
committerMichael Orlitzky <mjo@gentoo.org>2024-08-04 22:07:06 -0400
commit5a2f1b6fc00dc71645a0fd06b742ee05d6c51159 (patch)
treee00af138515d58f852e10c3c73c90b6bfa614b42 /sci-mathematics/dunshire/dunshire-0.1.3-r1.ebuild
parentmedia-libs/raptor: Stabilize 2.0.16 ppc, #937305 (diff)
downloadgentoo-5a2f1b6fc00dc71645a0fd06b742ee05d6c51159.tar.gz
gentoo-5a2f1b6fc00dc71645a0fd06b742ee05d6c51159.tar.bz2
gentoo-5a2f1b6fc00dc71645a0fd06b742ee05d6c51159.zip
sci-mathematics/dunshire: don't use setup.py for tests
Closes: https://bugs.gentoo.org/937324 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-mathematics/dunshire/dunshire-0.1.3-r1.ebuild')
-rw-r--r--sci-mathematics/dunshire/dunshire-0.1.3-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sci-mathematics/dunshire/dunshire-0.1.3-r1.ebuild b/sci-mathematics/dunshire/dunshire-0.1.3-r1.ebuild
new file mode 100644
index 000000000000..36354f6a301d
--- /dev/null
+++ b/sci-mathematics/dunshire/dunshire-0.1.3-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Python library to solve linear games over symmetric cones"
+HOMEPAGE="https://michael.orlitzky.com/code/dunshire/"
+SRC_URI="https://michael.orlitzky.com/code/releases/${P}.tar.gz"
+LICENSE="AGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="dev-python/cvxopt[${PYTHON_USEDEP}]"
+DOCS=( doc/README.rst )
+
+distutils_enable_sphinx doc/source
+
+# There are no additional dependencies even though we're not really
+# using setup.py to run the test suite any more. The __main__.py
+# runner has its own exit code handling.
+distutils_enable_tests setup.py
+
+python_test() {
+ PYTHONPATH="." "${EPYTHON}" test/__main__.py --verbose
+}