summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2024-07-23 03:45:38 -0500
committerMatthias Maier <tamiko@gentoo.org>2024-07-23 07:54:32 -0500
commitcc3e510253b21d46c0ed77447daa4f6e5ab33bf4 (patch)
treef1154e22fda5ddbb742322ae93ab8193b12d1acb /sci-mathematics
parentdev-python/clang-python: Stabilize 18.1.8 amd64, #935984 (diff)
downloadgentoo-cc3e510253b21d46c0ed77447daa4f6e5ab33bf4.tar.gz
gentoo-cc3e510253b21d46c0ed77447daa4f6e5ab33bf4.tar.bz2
gentoo-cc3e510253b21d46c0ed77447daa4f6e5ab33bf4.zip
sci-mathematics/cgal: add 6.0_beta1
Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/cgal/Manifest2
-rw-r--r--sci-mathematics/cgal/cgal-6.0_beta1.ebuild61
2 files changed, 63 insertions, 0 deletions
diff --git a/sci-mathematics/cgal/Manifest b/sci-mathematics/cgal/Manifest
index 652c959d0f12..f2646d88d31a 100644
--- a/sci-mathematics/cgal/Manifest
+++ b/sci-mathematics/cgal/Manifest
@@ -2,3 +2,5 @@ DIST CGAL-5.6-doc_html.tar.xz 72825232 BLAKE2B 08a5148592771c933126e38a74d77a982
DIST CGAL-5.6.1-doc_html.tar.xz 55148128 BLAKE2B 526d71be5c474570f5d17734a0931ecc3ba4564a7660d798dc00ea901cc27a421e02032490f3355d58dc6ed0b213e916288a025d3d3de4be2887fcb7b42e52a3 SHA512 88b313bc62007412a3b31ae494bd6e03ee4910d689fbc6dbd22c3a38bbd02ffcad5fcf7e71583dfc5a0ef32577e2a1639972d9e5c5e8bef38443e7dd953e7543
DIST CGAL-5.6.1.tar.xz 24893904 BLAKE2B 51abb85af785a6428893df282ce8e8dd6f2aed705d89b057e52f08e4cc42bf2696f676553bd89adb5178915b980b2566bae61bc9809ba58913b9244dac26034d SHA512 34b0b5958253fd4bcfd83ec40d3232bcd1f3ee4c07739ad3e19bf97104c628d10601909cc2343e48fceca0407a41f2c31a686b182b795e471a9a02f1964574f0
DIST CGAL-5.6.tar.xz 24874364 BLAKE2B 556c05177f8b3bcecfd16f2bd38cb6505ab04fb41f1fdcfc97a300f539c7642c3529c75cbe29fd6186b329b3ea844698e752d04690d010a7a5c3f5b6ad3a141f SHA512 1d91ad870b63bce36e060c0de7fa2e7ab98f9d9f6cf7c94d91a6677db237f50c28f8fc49f24bef943b2adcb5a4a8acf01dd94092a97024c33413763348131ea4
+DIST CGAL-6.0-beta1-doc_html.tar.xz 60360336 BLAKE2B cf9612d1168caa03985b432aba5b272ccfc879bbf7ee4cd8d22196f29c74957481aa6704a3c653bd2bfd8aee2d1d05beb1f966201d28d9a186f06441f10087f8 SHA512 9d547114a29abbcf0a3ac486b7073fed77a4bc240f2c565c14acc857e4bb52af348bb73ef318280da577beb2346b79b14db92e33816b9d564ae27dbec924e6f7
+DIST CGAL-6.0-beta1.tar.xz 26383632 BLAKE2B df1e2b00ea5f4a936080d2f308c77fc4053d34b0924dea34431c657f2bdee7a7122aaffb89d323877c360cec65ae238fa188cb03140b337805c26d48a812c05a SHA512 bcbfd6f8704a9d64c3371b1ba0bf4ecd601178a2a849065bff2c5ec3651317237e2d4ee961dcc68936bb0c0a8e7d00220943067bfd18b51f35bc035f76a10891
diff --git a/sci-mathematics/cgal/cgal-6.0_beta1.ebuild b/sci-mathematics/cgal/cgal-6.0_beta1.ebuild
new file mode 100644
index 000000000000..99f0659b8999
--- /dev/null
+++ b/sci-mathematics/cgal/cgal-6.0_beta1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Modules provided by dev-cpp/eigen
+CMAKE_REMOVE_MODULES_LIST=( FindEigen3 )
+inherit cmake
+
+MY_PV="${PV/_/-}"
+MY_P="CGAL-${PV/_/-}"
+DESCRIPTION="C++ library for geometric algorithms and data structures"
+HOMEPAGE="https://www.cgal.org/"
+SRC_URI="
+ https://github.com/CGAL/cgal/releases/download/v${MY_PV}/${MY_P}.tar.xz
+ doc? ( https://github.com/CGAL/cgal/releases/download/v${MY_PV}/${MY_P}-doc_html.tar.xz )"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="LGPL-3 GPL-3 Boost-1.0"
+SLOT="0/14"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples"
+
+RDEPEND="
+ dev-cpp/eigen
+ dev-libs/boost:=
+ dev-libs/gmp:=[cxx]
+ dev-libs/mpfr:=
+ sys-libs/zlib
+ x11-libs/libX11:=
+ virtual/glu:=
+ virtual/opengl:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-arch/xz-utils
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.11.1-fix-buildsystem.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DCGAL_INSTALL_LIB_DIR="$(get_libdir)"
+ -DCGAL_INSTALL_CMAKE_DIR="$(get_libdir)/cmake/CGAL"
+ )
+
+ cmake_src_configure
+}
+
+src_install() {
+ use doc && local HTML_DOCS=( "${WORKDIR}"/doc_html/. )
+
+ cmake_src_install
+
+ if use examples; then
+ dodoc -r examples demo
+ fi
+}