summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <junghans@gentoo.org>2016-12-14 13:58:15 -0700
committerChristoph Junghans <junghans@gentoo.org>2016-12-14 14:00:54 -0700
commit54e8cfb04662c51df8f5fba8076a2da2827fa204 (patch)
treec0d418eca51422bf35ae31f4a676ec70bb095048 /sci-physics/espresso++/espresso++-1.9.4.ebuild
parentwww-client/chromium: require >=gcc-5 (diff)
downloadgentoo-54e8cfb04662c51df8f5fba8076a2da2827fa204.tar.gz
gentoo-54e8cfb04662c51df8f5fba8076a2da2827fa204.tar.bz2
gentoo-54e8cfb04662c51df8f5fba8076a2da2827fa204.zip
sci-physics/espresso++: version bump
Package-Manager: Portage-2.3.0, Repoman-2.3.1
Diffstat (limited to 'sci-physics/espresso++/espresso++-1.9.4.ebuild')
-rw-r--r--sci-physics/espresso++/espresso++-1.9.4.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/sci-physics/espresso++/espresso++-1.9.4.ebuild b/sci-physics/espresso++/espresso++-1.9.4.ebuild
new file mode 100644
index 000000000000..d011256b2fe7
--- /dev/null
+++ b/sci-physics/espresso++/espresso++-1.9.4.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+CMAKE_MAKEFILE_GENERATOR="ninja"
+
+inherit cmake-utils python-r1
+
+DESCRIPTION="A Modern Multiscale Simulation Package for Soft Matter Systems"
+HOMEPAGE="https://www.espresso-pp.de"
+
+MY_PN="${PN//+/p}"
+if [[ ${PV} = 9999 ]]; then
+ EGIT_REPO_URI="git://github.com/${MY_PN}/${MY_PN}.git http://github.com/${MY_PN}/${MY_PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/${MY_PN}/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-macos"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="test"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ virtual/mpi
+ dev-libs/boost:=[python,mpi,${PYTHON_USEDEP}]
+ sci-libs/fftw:3.0
+ >=dev-python/mpi4py-2[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_configure() {
+ src_configure_internal() {
+ local mycmakeargs=(
+ -DEXTERNAL_BOOST=ON
+ -DEXTERNAL_MPI4PY=ON
+ -DWITH_RC_FILES=OFF
+ )
+ cmake-utils_src_configure
+ }
+ python_foreach_impl src_configure_internal
+}
+
+src_compile() {
+ python_foreach_impl cmake-utils_src_make
+}
+
+src_test() {
+ python_foreach_impl cmake-utils_src_test
+}
+
+src_install() {
+ python_foreach_impl cmake-utils_src_install
+}