summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Puck Neuwirth <alexander@neuwirth-informatik.de>2022-10-18 15:14:25 +0200
committerSam James <sam@gentoo.org>2022-10-30 09:33:26 +0000
commit964acd7a91465e4acd930e0616e31e313149e0c0 (patch)
tree51d8e088ed8966f42c238f4cffcb09d64be6051e /sci-physics/lhapdf
parentsci-physics/lhapdf: add 6.5.3 (diff)
downloadgentoo-964acd7a91465e4acd930e0616e31e313149e0c0.tar.gz
gentoo-964acd7a91465e4acd930e0616e31e313149e0c0.tar.bz2
gentoo-964acd7a91465e4acd930e0616e31e313149e0c0.zip
sci-physics/lhapdf: Revbump 6.5.2
Signed-off-by: Alexander Puck Neuwirth <alexander@neuwirth-informatik.de> Closes: https://github.com/gentoo/gentoo/pull/27806 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-physics/lhapdf')
-rw-r--r--sci-physics/lhapdf/lhapdf-6.5.2-r1.ebuild61
-rw-r--r--sci-physics/lhapdf/lhapdf-6.5.2.ebuild4
2 files changed, 62 insertions, 3 deletions
diff --git a/sci-physics/lhapdf/lhapdf-6.5.2-r1.ebuild b/sci-physics/lhapdf/lhapdf-6.5.2-r1.ebuild
new file mode 100644
index 000000000000..847df333d690
--- /dev/null
+++ b/sci-physics/lhapdf/lhapdf-6.5.2-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DOCS_BUILDER="doxygen"
+DOCS_DEPEND="
+ dev-texlive/texlive-bibtexextra
+ dev-texlive/texlive-fontsextra
+ dev-texlive/texlive-fontutils
+ dev-texlive/texlive-latex
+ dev-texlive/texlive-latexextra
+"
+inherit python-single-r1 docs
+
+MY_PV=$(ver_cut 1-3)
+MY_PF=LHAPDF-${MY_PV}
+
+DESCRIPTION="Les Houches Parton Density Function unified library"
+HOMEPAGE="https://lhapdf.hepforge.org/"
+SRC_URI="https://www.hepforge.org/downloads/lhapdf/${MY_PF}.tar.gz"
+S="${WORKDIR}/${MY_PF}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ dev-libs/boost:=
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+PATCHES=(
+ "${FILESDIR}"/${P}-py.patch
+)
+src_configure() {
+ CONFIG_SHELL="${EPREFIX}/bin/bash" \
+ econf \
+ --disable-static \
+ --enable-python
+}
+
+src_compile() {
+ emake all $(use doc && echo doxy)
+}
+
+src_test() {
+ emake -C tests
+}
+
+src_install() {
+ default
+ use doc && dodoc -r doc/doxygen/.
+ use examples && dodoc examples/*.cc
+
+ python_optimize
+
+ find "${ED}" -name '*.la' -delete || die
+}
diff --git a/sci-physics/lhapdf/lhapdf-6.5.2.ebuild b/sci-physics/lhapdf/lhapdf-6.5.2.ebuild
index 847df333d690..3655b125aee8 100644
--- a/sci-physics/lhapdf/lhapdf-6.5.2.ebuild
+++ b/sci-physics/lhapdf/lhapdf-6.5.2.ebuild
@@ -32,9 +32,7 @@ RDEPEND="
dev-libs/boost:=
${PYTHON_DEPS}"
DEPEND="${RDEPEND}"
-PATCHES=(
- "${FILESDIR}"/${P}-py.patch
-)
+
src_configure() {
CONFIG_SHELL="${EPREFIX}/bin/bash" \
econf \