summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuilherme Amadio <amadio@gentoo.org>2020-04-01 13:28:30 +0200
committerGuilherme Amadio <amadio@gentoo.org>2020-04-01 13:28:43 +0200
commit33e57de11ce61793afbbfa7f498297e14be13bda (patch)
treee8dbec4cb14e15ab9715a4a15976d89fe1a03eae /sci-physics
parentsci-physics/root: version bump to 6.20.04 (diff)
downloadgentoo-33e57de11ce61793afbbfa7f498297e14be13bda.tar.gz
gentoo-33e57de11ce61793afbbfa7f498297e14be13bda.tar.bz2
gentoo-33e57de11ce61793afbbfa7f498297e14be13bda.zip
sci-physics/root: use same compiler for C++ and CUDA in live ebuild
Package-Manager: Portage-2.3.96, Repoman-2.3.22 Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/root/root-9999.ebuild3
1 files changed, 3 insertions, 0 deletions
diff --git a/sci-physics/root/root-9999.ebuild b/sci-physics/root/root-9999.ebuild
index 5a0ccb7679d6..60e7f05e2b16 100644
--- a/sci-physics/root/root-9999.ebuild
+++ b/sci-physics/root/root-9999.ebuild
@@ -154,6 +154,9 @@ src_prepare() {
src_configure() {
local mycmakeargs=(
+ -DCMAKE_C_COMPILER=$(tc-getCC)
+ -DCMAKE_CXX_COMPILER=$(tc-getCXX)
+ -DCMAKE_CUDA_HOST_COMPILER=$(tc-getCXX)
-DCMAKE_C_FLAGS="${CFLAGS}"
-DCMAKE_CXX_FLAGS="${CXXFLAGS}"
-DCMAKE_CXX_STANDARD=$((usev c++11 || usev c++14 || usev c++17) | cut -c4-)