summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-12-11 12:12:10 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-11 12:53:13 +0100
commitc614d9691e23ef798e5f7ca78768803f9be57c53 (patch)
treec16b3ceeb65682e6489aabe2d31894e8f459f84f /sci-physics
parentMove {sys-libs → llvm-runtimes}/libcxxabi (diff)
downloadgentoo-c614d9691e23ef798e5f7ca78768803f9be57c53.tar.gz
gentoo-c614d9691e23ef798e5f7ca78768803f9be57c53.tar.bz2
gentoo-c614d9691e23ef798e5f7ca78768803f9be57c53.zip
Move {sys-libs → llvm-runtimes}/libcxx
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/root/metadata.xml2
-rw-r--r--sci-physics/root/root-6.30.08.ebuild4
-rw-r--r--sci-physics/root/root-6.32.06.ebuild4
-rw-r--r--sci-physics/root/root-6.32.08.ebuild4
-rw-r--r--sci-physics/root/root-6.34.00.ebuild4
-rw-r--r--sci-physics/root/root-6.34.9999.ebuild4
-rw-r--r--sci-physics/root/root-9999.ebuild4
7 files changed, 13 insertions, 13 deletions
diff --git a/sci-physics/root/metadata.xml b/sci-physics/root/metadata.xml
index dfd83214b030..43f736970470 100644
--- a/sci-physics/root/metadata.xml
+++ b/sci-physics/root/metadata.xml
@@ -31,7 +31,7 @@
<flag name="gdml">Enable GDML writer and reader</flag>
<flag name="http">Enable http server support including but not limited to fastcgi support</flag>
<flag name="jupyter">Install dependencies to enable ROOT's C++ kernel in Jupyter notebooks</flag>
- <flag name="libcxx">Build ROOT against <pkg>sys-libs/libcxx</pkg></flag>
+ <flag name="libcxx">Build ROOT against <pkg>llvm-runtimes/libcxx</pkg></flag>
<flag name="minuit">Build ROOT's internal versions of minuit (fortran) and minuit2 (C++)</flag>
<flag name="pythia6">Build the interface for <pkg>sci-physics/pythia</pkg> version 6.x </flag>
<flag name="pythia8">Build the interface for <pkg>sci-physics/pythia</pkg> version 8.x </flag>
diff --git a/sci-physics/root/root-6.30.08.ebuild b/sci-physics/root/root-6.30.08.ebuild
index 8cbfeef8d40d..652ded3c9a34 100644
--- a/sci-physics/root/root-6.30.08.ebuild
+++ b/sci-physics/root/root-6.30.08.ebuild
@@ -6,7 +6,7 @@ EAPI=8
# ninja does not work due to fortran
CMAKE_MAKEFILE_GENERATOR=emake
FORTRAN_NEEDED="fortran"
-PYTHON_COMPAT=( python3_{9..12} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit cmake cuda flag-o-matic fortran-2 python-single-r1 toolchain-funcs
@@ -95,7 +95,7 @@ CDEPEND="
graphviz? ( media-gfx/graphviz )
gsl? ( sci-libs/gsl:= )
http? ( dev-libs/fcgi:0= )
- libcxx? ( sys-libs/libcxx )
+ libcxx? ( llvm-runtimes/libcxx )
unuran? ( sci-mathematics/unuran:0= )
mpi? ( virtual/mpi[fortran?] )
mysql? ( dev-db/mysql-connector-c )
diff --git a/sci-physics/root/root-6.32.06.ebuild b/sci-physics/root/root-6.32.06.ebuild
index f0e0690cfb51..44fcdf275fdd 100644
--- a/sci-physics/root/root-6.32.06.ebuild
+++ b/sci-physics/root/root-6.32.06.ebuild
@@ -6,7 +6,7 @@ EAPI=8
# ninja does not work due to fortran
CMAKE_MAKEFILE_GENERATOR=emake
FORTRAN_NEEDED="fortran"
-PYTHON_COMPAT=( python3_{9..12} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit cmake cuda flag-o-matic fortran-2 python-single-r1 toolchain-funcs
@@ -94,7 +94,7 @@ CDEPEND="
graphviz? ( media-gfx/graphviz )
gsl? ( sci-libs/gsl:= )
http? ( dev-libs/fcgi:0= )
- libcxx? ( sys-libs/libcxx )
+ libcxx? ( llvm-runtimes/libcxx )
unuran? ( sci-mathematics/unuran:0= )
mpi? ( virtual/mpi[fortran?] )
mysql? ( dev-db/mysql-connector-c )
diff --git a/sci-physics/root/root-6.32.08.ebuild b/sci-physics/root/root-6.32.08.ebuild
index f0e0690cfb51..44fcdf275fdd 100644
--- a/sci-physics/root/root-6.32.08.ebuild
+++ b/sci-physics/root/root-6.32.08.ebuild
@@ -6,7 +6,7 @@ EAPI=8
# ninja does not work due to fortran
CMAKE_MAKEFILE_GENERATOR=emake
FORTRAN_NEEDED="fortran"
-PYTHON_COMPAT=( python3_{9..12} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit cmake cuda flag-o-matic fortran-2 python-single-r1 toolchain-funcs
@@ -94,7 +94,7 @@ CDEPEND="
graphviz? ( media-gfx/graphviz )
gsl? ( sci-libs/gsl:= )
http? ( dev-libs/fcgi:0= )
- libcxx? ( sys-libs/libcxx )
+ libcxx? ( llvm-runtimes/libcxx )
unuran? ( sci-mathematics/unuran:0= )
mpi? ( virtual/mpi[fortran?] )
mysql? ( dev-db/mysql-connector-c )
diff --git a/sci-physics/root/root-6.34.00.ebuild b/sci-physics/root/root-6.34.00.ebuild
index 0c7cfa523aa8..453459c31cfb 100644
--- a/sci-physics/root/root-6.34.00.ebuild
+++ b/sci-physics/root/root-6.34.00.ebuild
@@ -6,7 +6,7 @@ EAPI=8
# ninja does not work due to fortran
CMAKE_MAKEFILE_GENERATOR=emake
FORTRAN_NEEDED="fortran"
-PYTHON_COMPAT=( python3_{9..12} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit cmake cuda flag-o-matic fortran-2 python-single-r1 toolchain-funcs
@@ -89,7 +89,7 @@ CDEPEND="
graphviz? ( media-gfx/graphviz )
gsl? ( sci-libs/gsl:= )
http? ( dev-libs/fcgi:0= )
- libcxx? ( sys-libs/libcxx )
+ libcxx? ( llvm-runtimes/libcxx )
unuran? ( sci-mathematics/unuran:0= )
mpi? ( virtual/mpi[fortran?] )
mysql? ( dev-db/mysql-connector-c )
diff --git a/sci-physics/root/root-6.34.9999.ebuild b/sci-physics/root/root-6.34.9999.ebuild
index 0c7cfa523aa8..453459c31cfb 100644
--- a/sci-physics/root/root-6.34.9999.ebuild
+++ b/sci-physics/root/root-6.34.9999.ebuild
@@ -6,7 +6,7 @@ EAPI=8
# ninja does not work due to fortran
CMAKE_MAKEFILE_GENERATOR=emake
FORTRAN_NEEDED="fortran"
-PYTHON_COMPAT=( python3_{9..12} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit cmake cuda flag-o-matic fortran-2 python-single-r1 toolchain-funcs
@@ -89,7 +89,7 @@ CDEPEND="
graphviz? ( media-gfx/graphviz )
gsl? ( sci-libs/gsl:= )
http? ( dev-libs/fcgi:0= )
- libcxx? ( sys-libs/libcxx )
+ libcxx? ( llvm-runtimes/libcxx )
unuran? ( sci-mathematics/unuran:0= )
mpi? ( virtual/mpi[fortran?] )
mysql? ( dev-db/mysql-connector-c )
diff --git a/sci-physics/root/root-9999.ebuild b/sci-physics/root/root-9999.ebuild
index 0c7cfa523aa8..453459c31cfb 100644
--- a/sci-physics/root/root-9999.ebuild
+++ b/sci-physics/root/root-9999.ebuild
@@ -6,7 +6,7 @@ EAPI=8
# ninja does not work due to fortran
CMAKE_MAKEFILE_GENERATOR=emake
FORTRAN_NEEDED="fortran"
-PYTHON_COMPAT=( python3_{9..12} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit cmake cuda flag-o-matic fortran-2 python-single-r1 toolchain-funcs
@@ -89,7 +89,7 @@ CDEPEND="
graphviz? ( media-gfx/graphviz )
gsl? ( sci-libs/gsl:= )
http? ( dev-libs/fcgi:0= )
- libcxx? ( sys-libs/libcxx )
+ libcxx? ( llvm-runtimes/libcxx )
unuran? ( sci-mathematics/unuran:0= )
mpi? ( virtual/mpi[fortran?] )
mysql? ( dev-db/mysql-connector-c )