summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-visualization/gwyddion
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-visualization/gwyddion')
-rw-r--r--sci-visualization/gwyddion/Manifest1
-rw-r--r--sci-visualization/gwyddion/files/gwyddion-2.25-libpng15.patch10
-rw-r--r--sci-visualization/gwyddion/files/gwyddion-2.30-BGRA.patch22
-rw-r--r--sci-visualization/gwyddion/files/gwyddion-2.30-color-button-debris-crash.patch37
-rw-r--r--sci-visualization/gwyddion/gwyddion-2.39.ebuild90
-rw-r--r--sci-visualization/gwyddion/metadata.xml22
6 files changed, 182 insertions, 0 deletions
diff --git a/sci-visualization/gwyddion/Manifest b/sci-visualization/gwyddion/Manifest
new file mode 100644
index 000000000000..16e036ba67f8
--- /dev/null
+++ b/sci-visualization/gwyddion/Manifest
@@ -0,0 +1 @@
+DIST gwyddion-2.39.tar.xz 3130844 SHA256 f2346a706fa097e9186339f7e10b7837b20ce403b44bc7a85bc78b6b78a506d2 SHA512 5b9631c9eeb71a10d0be3533585eb61e8d27bc1147a1f3cf1ca333020271b579025ce752d302bd9474f1b3ed8c55ce679ac6a75bfb4a1093adef0727b824d435 WHIRLPOOL 90262b86d1bb01b6fdf5a67b447dc1177a523df368fbd040a87d7261e071844b86624dd6bb303c8a32302d16e5f7cb11e5f0744b2808e4f6d467cd27652efe23
diff --git a/sci-visualization/gwyddion/files/gwyddion-2.25-libpng15.patch b/sci-visualization/gwyddion/files/gwyddion-2.25-libpng15.patch
new file mode 100644
index 000000000000..f13eaa985ad5
--- /dev/null
+++ b/sci-visualization/gwyddion/files/gwyddion-2.25-libpng15.patch
@@ -0,0 +1,10 @@
+--- modules/file/pixmap.c
++++ modules/file/pixmap.c
+@@ -39,6 +39,7 @@
+ #include <gtk/gtk.h>
+
+ #ifdef HAVE_PNG
++#include <zlib.h>
+ #include <png.h>
+ #endif
+
diff --git a/sci-visualization/gwyddion/files/gwyddion-2.30-BGRA.patch b/sci-visualization/gwyddion/files/gwyddion-2.30-BGRA.patch
new file mode 100644
index 000000000000..c3b59122b99c
--- /dev/null
+++ b/sci-visualization/gwyddion/files/gwyddion-2.30-BGRA.patch
@@ -0,0 +1,22 @@
+Index: libgwydgets/gwy3dview.c
+===================================================================
+--- libgwydgets/gwy3dview.c (revision 13961)
++++ libgwydgets/gwy3dview.c (working copy)
+@@ -48,7 +48,6 @@
+ #include <GL/glext.h>
+ #endif
+ #endif
+-#endif
+
+ #ifndef GL_BGRA
+ #ifdef GL_BGRA_EXT
+@@ -57,6 +56,7 @@
+ #error FIXME: GL_BGRA is not available, should work around it.
+ #endif
+ #endif
++#endif
+
+ #include <libgwyddion/gwymacros.h>
+ #include <libgwyddion/gwymath.h>
+
+
diff --git a/sci-visualization/gwyddion/files/gwyddion-2.30-color-button-debris-crash.patch b/sci-visualization/gwyddion/files/gwyddion-2.30-color-button-debris-crash.patch
new file mode 100644
index 000000000000..e6ceedf919e3
--- /dev/null
+++ b/sci-visualization/gwyddion/files/gwyddion-2.30-color-button-debris-crash.patch
@@ -0,0 +1,37 @@
+Index: modules/file/pixmap.c
+===================================================================
+--- modules/file/pixmap.c (revision 13902)
++++ modules/file/pixmap.c (revision 13903)
+@@ -2933,8 +2933,6 @@
+ gwy_rgba_to_gdk_color(&controls->args->inset_color, &gdkcolor);
+
+ dialog = gtk_color_selection_dialog_new(_("Change Inset Color"));
+- if (gtk_major_version == 2 && gtk_minor_version < 10)
+-
+ selector = GTK_COLOR_SELECTION_DIALOG(dialog)->colorsel;
+ gtk_color_selection_set_current_color(GTK_COLOR_SELECTION(selector),
+ &gdkcolor);
+Index: libgwydgets/gwygraphareadialog.c
+===================================================================
+--- libgwydgets/gwygraphareadialog.c (revision 13902)
++++ libgwydgets/gwygraphareadialog.c (revision 13903)
+@@ -383,7 +383,6 @@
+ dialog->color_dialog = selector;
+ dialog->old_color = cmodel->color;
+
+- if (gtk_major_version == 2 && gtk_minor_version < 10)
+ colorsel = GTK_COLOR_SELECTION_DIALOG(selector)->colorsel;
+ g_signal_connect(selector, "response",
+ G_CALLBACK(colorsel_response_cb), dialog);
+Index: libgwydgets/gwydgetutils.c
+===================================================================
+--- libgwydgets/gwydgetutils.c (revision 13902)
++++ libgwydgets/gwydgetutils.c (revision 13903)
+@@ -561,7 +561,6 @@
+ dialog = gtk_color_selection_dialog_new(dialog_title
+ ? dialog_title
+ : _("Change Mask Color"));
+- if (gtk_major_version == 2 && gtk_minor_version < 10)
+ selector = GTK_COLOR_SELECTION_DIALOG(dialog)->colorsel;
+ gtk_color_selection_set_current_color(GTK_COLOR_SELECTION(selector),
+ &gdkcolor);
diff --git a/sci-visualization/gwyddion/gwyddion-2.39.ebuild b/sci-visualization/gwyddion/gwyddion-2.39.ebuild
new file mode 100644
index 000000000000..028a8e1b9c32
--- /dev/null
+++ b/sci-visualization/gwyddion/gwyddion-2.39.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+inherit autotools-utils fdo-mime gnome2-utils python-single-r1
+
+DESCRIPTION="Framework for Scanning Mode Microscopy data analysis"
+HOMEPAGE="http://gwyddion.net/"
+SRC_URI="http://gwyddion.net/download/${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE="doc fits fftw gnome kde nls opengl perl python ruby sourceview xml X"
+
+RDEPEND="
+ media-libs/libpng:0
+ x11-libs/cairo
+ x11-libs/gtk+:2
+ x11-libs/libXmu
+ x11-libs/pango
+ fits? ( sci-libs/cfitsio )
+ fftw? ( sci-libs/fftw:3.0 )
+ gnome? ( gnome-base/gconf:2 )
+ kde? ( kde-base/kdelibs:4 )
+ opengl? ( virtual/opengl x11-libs/gtkglext )
+ perl? ( dev-lang/perl )
+ python? (
+ ${PYTHON_DEPS}
+ dev-python/pygtk:2[${PYTHON_USEDEP}]
+ )
+ ruby? ( dev-ruby/narray )
+ sourceview? ( x11-libs/gtksourceview:2.0 )
+ xml? ( dev-libs/libxml2:2 )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( dev-util/gtk-doc )
+"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+MAKEOPTS+=" V=1"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-rpath
+ $(use_enable doc gtk-doc)
+ $(use_enable nls)
+ $(use_enable python pygwy)
+ $(use_enable fits cfitsio)
+ $(use_with perl)
+ $(use_with python)
+ $(use_with ruby)
+ $(use_with fftw fftw3)
+ $(use_with opengl gl) \
+ $(use_with sourceview gtksourceview)
+ $(use_with xml libxml2)
+ $(use_with X x)
+ $(use_with kde kde4-thumbnailer)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ use python && dodoc modules/pygwy/README.pygwy
+}
+
+pkg_postinst() {
+ use gnome && gnome2_gconf_install
+ fdo-mime_desktop_database_update
+}
+
+pkg_prerm() {
+ use gnome && gnome2_gconf_uninstall
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}
diff --git a/sci-visualization/gwyddion/metadata.xml b/sci-visualization/gwyddion/metadata.xml
new file mode 100644
index 000000000000..2079a95b89c8
--- /dev/null
+++ b/sci-visualization/gwyddion/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <longdescription lang="en">
+ Gwyddion is a modular program for SPM data analysis. Primarily it is
+ supposed to be used for analysis of height fields obtained by means of
+ scanning probe microscopy techniques (AFM, MFM, STM, NSOM), but
+ generally it can be used for any other height field analysis or
+ image analysis.
+</longdescription>
+ <use>
+ <flag name="sourceview">
+ Enable support for <pkg>x11-libs/gtksourceview</pkg>
+ </flag>
+ </use>
+ <use>
+ <flag name="fits">
+ Enable FITS image import via <pkg>sci-libs/cfitsio</pkg>
+ </flag>
+ </use>
+</pkgmetadata>