summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2021-11-14 19:10:28 -0800
committerJason Zaman <perfinion@gentoo.org>2021-11-15 09:52:06 -0800
commitc8c58442c194d85ee45febbcb55b752fe5d88cd4 (patch)
tree1f641f9b9b6f53b5dad29bf999fe1b4a5fd3c2b4 /sci-visualization
parentsci-visualization/tensorboard: bump 2.7.0 (diff)
downloadgentoo-c8c58442c194d85ee45febbcb55b752fe5d88cd4.tar.gz
gentoo-c8c58442c194d85ee45febbcb55b752fe5d88cd4.tar.bz2
gentoo-c8c58442c194d85ee45febbcb55b752fe5d88cd4.zip
sci-visualization/tensorboard: Drop old 2.4.0
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Jason Zaman <perfinion@gentoo.org>
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/tensorboard/Manifest1
-rw-r--r--sci-visualization/tensorboard/tensorboard-2.4.0.ebuild63
2 files changed, 0 insertions, 64 deletions
diff --git a/sci-visualization/tensorboard/Manifest b/sci-visualization/tensorboard/Manifest
index a152beeb93ed..afa3e03768b3 100644
--- a/sci-visualization/tensorboard/Manifest
+++ b/sci-visualization/tensorboard/Manifest
@@ -1,3 +1,2 @@
-DIST tensorboard-2.4.0.zip 10631832 BLAKE2B e892c3f62855bd900320adbbea2758191296e2863e8865f4ffed3c5623fe5273a5a26554504b63db58c60d2a8c407e234d6cf3edc3868c88dfebd894def99859 SHA512 2301f526a98ac85cf5d182fff0f565c86883ec795bbaf2322696416621c8473d850a3f508079f89ca2a86a05fe020acde1282b72e2bb5ad77aab2d0e5ea2db4f
DIST tensorboard-2.5.0.zip 6019104 BLAKE2B f07db4fec7cc39e15c4f580f479679f0db4f06e66d81768799ed3652bb9ba63c7b61bde7f12119d09474009e55c12d91ef0f2b3aeeb05682532630314cab871a SHA512 e39ca09bd00fab9b5f6f9393e48cb6be2313f86c24b2f0ffcfd08b08b9ed4e95e7e19297bb67d8b558e1913640774f9b9d512a34153251acb9f566d6485e0f78
DIST tensorboard-2.7.0.zip 5757617 BLAKE2B 98e67e322548f4b88448856da3a2457a6aae9ecb1540916d46a90401307f4919df37af8a3048bdb850ea78886d18423edc87fca51812f3b9489de62d3effa0fc SHA512 e9b046000250a78eab4e6e68e5cc05696254893cf7422b59d2e168d7322287501654370a797e90af7437e91b64a27743e348513bcb5571805b3f10bb2059636d
diff --git a/sci-visualization/tensorboard/tensorboard-2.4.0.ebuild b/sci-visualization/tensorboard/tensorboard-2.4.0.ebuild
deleted file mode 100644
index 7b70747a4e9b..000000000000
--- a/sci-visualization/tensorboard/tensorboard-2.4.0.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8} )
-inherit python-r1
-
-DESCRIPTION="TensorFlow's Visualization Toolkit"
-HOMEPAGE="https://www.tensorflow.org/"
-SRC_URI="https://files.pythonhosted.org/packages/py3/${PN::1}/${PN}/${P}-py3-none-any.whl -> ${P}.zip"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-REQUIRED_USE=${PYTHON_REQUIRED_USE}
-
-RDEPEND="
- ${PYTHON_DEPS}
- dev-python/bleach[${PYTHON_USEDEP}]
- >=dev-python/google-auth-1.6.3[${PYTHON_USEDEP}]
- >=dev-python/google-auth-oauthlib-0.4.1[${PYTHON_USEDEP}]
- dev-python/grpcio[${PYTHON_USEDEP}]
- dev-python/html5lib[${PYTHON_USEDEP}]
- dev-python/markdown[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/protobuf-python[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- >=dev-python/setuptools-41[${PYTHON_USEDEP}]
- dev-python/werkzeug[${PYTHON_USEDEP}]
- dev-python/wheel[${PYTHON_USEDEP}]
- >=dev-python/scipy-1.4.1[${PYTHON_USEDEP}]"
-BDEPEND="app-arch/unzip
- ${PYTHON_DEPS}"
-PDEPEND="sci-libs/tensorflow[python,${PYTHON_USEDEP}]"
-
-S="${WORKDIR}"
-
-src_prepare() {
- eapply_user
-
- rm -rf "${S}/${PN}/_vendor/bleach" || die
- rm -rf "${S}/${PN}/_vendor/html5lib" || die
- sed -i -e '/_vendor.bleach/d' -e '/_vendor.html5lib/d' "${S}/${P}.dist-info/RECORD" || die "failed to unvendor"
-
- find "${S}/${PN}" -name '*.py' -exec sed -i \
- -e 's/^from tensorboard\._vendor import html5lib/import html5lib/' \
- -e 's/^from tensorboard\._vendor import bleach/import bleach/' \
- -e 's/^from tensorboard\._vendor\.html5lib/from html5lib/' \
- -e 's/^from tensorboard\._vendor\.bleach/from bleach/' \
- {} + || die "failed to unvendor"
-
- sed -i -e '/tensorboard-plugin-/d' "${S}/${P}.dist-info/METADATA" || die "failed to remove plugin deps"
-}
-
-src_install() {
- do_install() {
- python_domodule "${PN}"
- python_domodule "${P}.dist-info"
- }
- python_foreach_impl do_install
-}