summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfred Persson Forsberg <cat@catcream.org>2023-02-24 13:36:18 +0100
committerSam James <sam@gentoo.org>2023-02-24 15:55:04 +0000
commit22428c7f5a828a6f80d89171520063277651104b (patch)
tree1b5465d08089e8c037384959bcf52734ba4db5cd /sys-apps/arch-chroot
parentmedia-libs/mesa: Version bump to 23.0.0 (diff)
downloadgentoo-22428c7f5a828a6f80d89171520063277651104b.tar.gz
gentoo-22428c7f5a828a6f80d89171520063277651104b.tar.bz2
gentoo-22428c7f5a828a6f80d89171520063277651104b.zip
sys-apps/arch-chroot: new package, add 28
Signed-off-by: Alfred Persson Forsberg <cat@catcream.org> Closes: https://github.com/gentoo/gentoo/pull/29766 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/arch-chroot')
-rw-r--r--sys-apps/arch-chroot/Manifest1
-rw-r--r--sys-apps/arch-chroot/arch-chroot-28.ebuild32
-rw-r--r--sys-apps/arch-chroot/metadata.xml15
3 files changed, 48 insertions, 0 deletions
diff --git a/sys-apps/arch-chroot/Manifest b/sys-apps/arch-chroot/Manifest
new file mode 100644
index 000000000000..8fa0f1e957d1
--- /dev/null
+++ b/sys-apps/arch-chroot/Manifest
@@ -0,0 +1 @@
+DIST arch-install-scripts-v28.tar.gz 19730 BLAKE2B 0ff5ba79b200ad642e049ec19217cc5c0794d627a28f42e03c0df2444fef4d8488a6ee011d26fb8fe958c1a1a2fa0a13920567e394b2389c772f516b1fe8f388 SHA512 09a027b04b70e01ccd1fd82e3a443c876bdf978b94a922de9dea4dbc187360460ea35720816724b72fc31b02338b11bf39b47ec9156518a8a3ade000530bf1df
diff --git a/sys-apps/arch-chroot/arch-chroot-28.ebuild b/sys-apps/arch-chroot/arch-chroot-28.ebuild
new file mode 100644
index 000000000000..a1cc9022d97a
--- /dev/null
+++ b/sys-apps/arch-chroot/arch-chroot-28.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1
+
+DESCRIPTION="Wraps the chroot command while ensuring that important filesystems are mounted"
+HOMEPAGE="https://github.com/archlinux/arch-install-scripts"
+SRC_URI="https://github.com/archlinux/arch-install-scripts/archive/refs/tags/v${PV}.tar.gz -> arch-install-scripts-v${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="app-text/asciidoc"
+
+S="${WORKDIR}/arch-install-scripts-${PV}"
+
+src_compile() {
+ emake MANS="doc/arch-chroot.8" BINPROGS="arch-chroot"
+}
+
+src_test() {
+ emake MANS="doc/arch-chroot.8" BINPROGS="arch-chroot" check
+}
+
+src_install() {
+ dobin arch-chroot
+ doman doc/arch-chroot.8
+ newbashcomp "completion/arch-chroot.bash" "arch-chroot"
+}
diff --git a/sys-apps/arch-chroot/metadata.xml b/sys-apps/arch-chroot/metadata.xml
new file mode 100644
index 000000000000..ca30cb18f61d
--- /dev/null
+++ b/sys-apps/arch-chroot/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM 'https://www.gentoo.org/dtd/metadata.dtd'>
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>cat@catcream.org</email>
+ <name>Alfred Persson</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">archlinux/arch-install-scripts</remote-id>
+ </upstream>
+</pkgmetadata>