summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-apps/audio-entropyd
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-apps/audio-entropyd')
-rw-r--r--sys-apps/audio-entropyd/Manifest1
-rw-r--r--sys-apps/audio-entropyd/audio-entropyd-2.0.3-r1.ebuild38
-rw-r--r--sys-apps/audio-entropyd/audio-entropyd-2.0.3.ebuild37
-rw-r--r--sys-apps/audio-entropyd/files/audio-entropyd-2.0.1-ldflags.patch13
-rw-r--r--sys-apps/audio-entropyd/files/audio-entropyd-2.0.1-uclibc.patch27
-rw-r--r--sys-apps/audio-entropyd/files/audio-entropyd.conf-213
-rw-r--r--sys-apps/audio-entropyd/files/audio-entropyd.init-227
-rw-r--r--sys-apps/audio-entropyd/files/audio-entropyd.service8
-rw-r--r--sys-apps/audio-entropyd/metadata.xml9
9 files changed, 173 insertions, 0 deletions
diff --git a/sys-apps/audio-entropyd/Manifest b/sys-apps/audio-entropyd/Manifest
new file mode 100644
index 000000000000..f70abfd24266
--- /dev/null
+++ b/sys-apps/audio-entropyd/Manifest
@@ -0,0 +1 @@
+DIST audio-entropyd-2.0.3.tgz 16681 SHA256 6fbaf1c4f77e988f4656cd079309d5eb6bd36cbae89c2ee01324c5690adaf3ff SHA512 d21c2d547235accdd460bcaf1ff5f5696db2988d385c3c52aad0d651865386409682f8747d1823765f0c0925bf28f38abdfc0b114d239f494c7eb699c5ed3ebf WHIRLPOOL e653b7cccda00323b5f17a675d72cef1a9adf9915dcd27041e63993073a378d92ab5779d25434ecd48ecbb74b45abc4217e4b629c98ba3885589727ef90edf6d
diff --git a/sys-apps/audio-entropyd/audio-entropyd-2.0.3-r1.ebuild b/sys-apps/audio-entropyd/audio-entropyd-2.0.3-r1.ebuild
new file mode 100644
index 000000000000..7657afd41b73
--- /dev/null
+++ b/sys-apps/audio-entropyd/audio-entropyd-2.0.3-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils systemd toolchain-funcs
+
+DESCRIPTION="Audio-entropyd generates entropy-data for the /dev/random device"
+HOMEPAGE="http://www.vanheusden.com/aed/"
+SRC_URI="http://www.vanheusden.com/aed/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ~sparc x86"
+IUSE="selinux"
+
+RDEPEND="selinux? ( sec-policy/selinux-entropyd )
+ media-sound/alsa-utils
+ media-libs/alsa-lib"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-2.0.1-uclibc.patch" \
+ "${FILESDIR}/${PN}-2.0.1-ldflags.patch"
+ sed -i -e "s:^OPT_FLAGS=.*:OPT_FLAGS=${CFLAGS}:" \
+ -e "/^WARNFLAGS/s: -g::" Makefile || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dosbin audio-entropyd
+ dodoc README TODO
+ systemd_dounit "${FILESDIR}/${PN}.service"
+ newinitd "${FILESDIR}/${PN}.init-2" ${PN}
+ newconfd "${FILESDIR}/${PN}.conf-2" ${PN}
+}
diff --git a/sys-apps/audio-entropyd/audio-entropyd-2.0.3.ebuild b/sys-apps/audio-entropyd/audio-entropyd-2.0.3.ebuild
new file mode 100644
index 000000000000..1dfc1007e9a2
--- /dev/null
+++ b/sys-apps/audio-entropyd/audio-entropyd-2.0.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Audio-entropyd generates entropy-data for the /dev/random device"
+HOMEPAGE="http://www.vanheusden.com/aed/"
+SRC_URI="http://www.vanheusden.com/aed/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ~sparc x86"
+IUSE="selinux"
+
+RDEPEND="selinux? ( sec-policy/selinux-entropyd )
+ media-sound/alsa-utils
+ media-libs/alsa-lib"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-2.0.1-uclibc.patch" \
+ "${FILESDIR}/${PN}-2.0.1-ldflags.patch"
+ sed -i -e "s:^OPT_FLAGS=.*:OPT_FLAGS=${CFLAGS}:" \
+ -e "/^WARNFLAGS/s: -g::" Makefile || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dosbin audio-entropyd
+ dodoc README TODO
+ newinitd "${FILESDIR}/${PN}.init-2" ${PN}
+ newconfd "${FILESDIR}/${PN}.conf-2" ${PN}
+}
diff --git a/sys-apps/audio-entropyd/files/audio-entropyd-2.0.1-ldflags.patch b/sys-apps/audio-entropyd/files/audio-entropyd-2.0.1-ldflags.patch
new file mode 100644
index 000000000000..870e9121140d
--- /dev/null
+++ b/sys-apps/audio-entropyd/files/audio-entropyd-2.0.1-ldflags.patch
@@ -0,0 +1,13 @@
+diff --git a/Makefile b/Makefile
+index 95a84a6..340f95f 100644
+--- a/Makefile
++++ b/Makefile
+@@ -12,7 +12,7 @@ TARGETS=audio-entropyd
+ all: $(TARGETS)
+
+ audio-entropyd: audio-entropyd.o error.o proc.o val.o RNGTEST.o error.o
+- $(CC) -o $@ $^ $(LFLAGS)
++ $(CC) $(LDFLAGS) -o $@ $^ $(LFLAGS)
+
+ install: audio-entropyd
+ cp audio-entropyd /usr/local/sbin/
diff --git a/sys-apps/audio-entropyd/files/audio-entropyd-2.0.1-uclibc.patch b/sys-apps/audio-entropyd/files/audio-entropyd-2.0.1-uclibc.patch
new file mode 100644
index 000000000000..bdf5adeff825
--- /dev/null
+++ b/sys-apps/audio-entropyd/files/audio-entropyd-2.0.1-uclibc.patch
@@ -0,0 +1,27 @@
+--- audio-entropyd-1.0.1.orig/error.c 2008-01-22 09:50:28 +0000
++++ audio-entropyd-1.0.1/error.c 2008-01-22 09:53:51 +0000
+@@ -9,13 +9,13 @@
+ #include <signal.h>
+ #include <syslog.h>
+ #include <regex.h>
+-#if defined(__GLIBC__)
++#if defined(__GLIBC__) && !defined(__UCLIBC__)
+ #include <execinfo.h>
+ #endif
+
+ void print_trace(void)
+ {
+-#if defined(__GLIBC__)
++#if defined(__GLIBC__) && !defined(__UCLIBC__)
+ void *array[MAX_BACKTRACE_LENGTH];
+ size_t size;
+
+@@ -39,7 +39,7 @@
+ printf("\n\n\nDebug information:\n");
+ if (errno) fprintf(stderr, "errno: %d=%s (if applicable)\n", errno, strerror(errno));
+
+-#if defined(__GLIBC__)
++#if defined(__GLIBC__) && !defined(__UCLIBC__)
+ print_trace();
+ #endif
+
diff --git a/sys-apps/audio-entropyd/files/audio-entropyd.conf-2 b/sys-apps/audio-entropyd/files/audio-entropyd.conf-2
new file mode 100644
index 000000000000..ec3a56fa5c1f
--- /dev/null
+++ b/sys-apps/audio-entropyd/files/audio-entropyd.conf-2
@@ -0,0 +1,13 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# /etc/conf.d/audio-entropyd
+
+# The acceptable values are DEVICE, READSIZE and SAMPLERATE
+# These defaults give the optimum entropy
+
+#DEVICE="hw:0"
+
+#SAMPLERATE must be a valid sampling rate of your audio source
+SAMPLERATE="44050"
diff --git a/sys-apps/audio-entropyd/files/audio-entropyd.init-2 b/sys-apps/audio-entropyd/files/audio-entropyd.init-2
new file mode 100644
index 000000000000..a31993b727c0
--- /dev/null
+++ b/sys-apps/audio-entropyd/files/audio-entropyd.init-2
@@ -0,0 +1,27 @@
+#!/sbin/runscript
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ need modules
+ use alsasound
+ provide entropy
+}
+
+start() {
+ local params=""
+ [ -n "$DEVICE" ] && params="$params -d $DEVICE"
+ [ -n "$SAMPLERATE" ] && params="$params -N $SAMPLERATE"
+
+ ebegin "Starting audio entropy gathering daemon"
+ start-stop-daemon --start --quiet --pidfile /var/run/audio-entropyd.pid \
+ --exec /usr/sbin/audio-entropyd -- ${params}
+ eend ${?}
+}
+
+stop() {
+ ebegin "Stopping audio entropy gathering daemon"
+ start-stop-daemon --stop --quiet --pidfile /var/run/audio-entropyd.pid
+ eend ${?}
+}
diff --git a/sys-apps/audio-entropyd/files/audio-entropyd.service b/sys-apps/audio-entropyd/files/audio-entropyd.service
new file mode 100644
index 000000000000..849ad0131c63
--- /dev/null
+++ b/sys-apps/audio-entropyd/files/audio-entropyd.service
@@ -0,0 +1,8 @@
+[Unit]
+Description=Audio Entropy Daemon
+
+[Service]
+ExecStart=/usr/sbin/audio-entropyd -n
+
+[Install]
+WantedBy=multi-user.target
diff --git a/sys-apps/audio-entropyd/metadata.xml b/sys-apps/audio-entropyd/metadata.xml
new file mode 100644
index 000000000000..bc557e5fa607
--- /dev/null
+++ b/sys-apps/audio-entropyd/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>angelos@gentoo.org</email>
+ <name>Christoph Mende</name>
+</maintainer>
+<longdescription>Audio-entropyd generates entropy-data for the /dev/random device.</longdescription>
+</pkgmetadata>