summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-05-13 15:51:44 +0200
committerDavid Seifert <soap@gentoo.org>2021-05-13 15:51:44 +0200
commitefc2b709bd69af45fdc92f3962de5a43d92c90e5 (patch)
tree770d8b8870ee054b1e0c6c5d01e901b6287c2ac7 /sys-apps/man2html
parentsys-apps/lsb-release: port to EAPI 7 (diff)
downloadgentoo-efc2b709bd69af45fdc92f3962de5a43d92c90e5.tar.gz
gentoo-efc2b709bd69af45fdc92f3962de5a43d92c90e5.tar.bz2
gentoo-efc2b709bd69af45fdc92f3962de5a43d92c90e5.zip
sys-apps/man2html: port to EAPI 7
Signed-off-by: Sam James <sam@gentoo.org> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sys-apps/man2html')
-rw-r--r--sys-apps/man2html/files/man-1.6-cross-compile.patch4
-rw-r--r--sys-apps/man2html/files/man-1.6f-man2html-compression-2.patch16
-rw-r--r--sys-apps/man2html/files/man-1.6g-compress.patch4
-rw-r--r--sys-apps/man2html/man2html-1.6g.ebuild27
4 files changed, 27 insertions, 24 deletions
diff --git a/sys-apps/man2html/files/man-1.6-cross-compile.patch b/sys-apps/man2html/files/man-1.6-cross-compile.patch
index 265265077a9c..79aa90af212d 100644
--- a/sys-apps/man2html/files/man-1.6-cross-compile.patch
+++ b/sys-apps/man2html/files/man-1.6-cross-compile.patch
@@ -1,8 +1,8 @@
Fix up to work with cross-compiling ... most of these tests only
need to see if the example compiled, not whether it runs ...
---- configure
-+++ configure
+--- a/configure
++++ b/configure
@@ -232,15 +232,13 @@
echo checking for POSIX.1 header files
diff --git a/sys-apps/man2html/files/man-1.6f-man2html-compression-2.patch b/sys-apps/man2html/files/man-1.6f-man2html-compression-2.patch
index b79b3a1872f1..cc9093371bb6 100644
--- a/sys-apps/man2html/files/man-1.6f-man2html-compression-2.patch
+++ b/sys-apps/man2html/files/man-1.6f-man2html-compression-2.patch
@@ -1,7 +1,7 @@
add support for bzip2/lzma to man2html and friends
---- man2html/glimpse_filters
-+++ man2html/glimpse_filters
+--- a/man2html/glimpse_filters
++++ b/man2html/glimpse_filters
@@ -1,3 +1,6 @@
+*.bz2 bzip2 -d -c
+*.lzma lzma -d -c
@@ -9,8 +9,8 @@ add support for bzip2/lzma to man2html and friends
*.gz gzip -d -c
*.Z gzip -d -c
---- man2html/scripts/cgi-bin/man/man2html
-+++ man2html/scripts/cgi-bin/man/man2html
+--- a/man2html/scripts/cgi-bin/man/man2html
++++ b/man2html/scripts/cgi-bin/man/man2html
@@ -93,6 +93,12 @@
*.bz2)
bzcat "$PAGE" | "$MAN2HTML" "$LL" -D "$PAGE"
@@ -37,8 +37,8 @@ add support for bzip2/lzma to man2html and friends
else
"$MAN2HTML" -E "Strange... Cannot find (or read) $PAGE."
fi
---- man2html/scripts/cgi-bin/man/mansearch
-+++ man2html/scripts/cgi-bin/man/mansearch
+--- a/man2html/scripts/cgi-bin/man/mansearch
++++ b/man2html/scripts/cgi-bin/man/mansearch
@@ -153,7 +153,7 @@
}
print "<DT> <a href=\"" cgipath "/man2html?" fullname "\">";
@@ -48,8 +48,8 @@ add support for bzip2/lzma to man2html and friends
sub(/\./, "(", textname);
textname = textname ")";
print textname;
---- man2html/scripts/cgi-bin/man/mansec
-+++ man2html/scripts/cgi-bin/man/mansec
+--- a/man2html/scripts/cgi-bin/man/mansec
++++ b/man2html/scripts/cgi-bin/man/mansec
@@ -128,7 +128,7 @@
# Print out alphabetic quick index and other links
}
diff --git a/sys-apps/man2html/files/man-1.6g-compress.patch b/sys-apps/man2html/files/man-1.6g-compress.patch
index 374d80730074..4a5e84a785b1 100644
--- a/sys-apps/man2html/files/man-1.6g-compress.patch
+++ b/sys-apps/man2html/files/man-1.6g-compress.patch
@@ -2,8 +2,8 @@ allow selection of default cache compressor
http://bugs.gentoo.org/205147
---- configure
-+++ configure
+--- a/configure
++++ b/configure
@@ -1012,6 +1012,10 @@
done
done
diff --git a/sys-apps/man2html/man2html-1.6g.ebuild b/sys-apps/man2html/man2html-1.6g.ebuild
index 9027484ba531..b84b64315a1e 100644
--- a/sys-apps/man2html/man2html-1.6g.ebuild
+++ b/sys-apps/man2html/man2html-1.6g.ebuild
@@ -1,33 +1,35 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=7
-inherit epatch toolchain-funcs
+inherit toolchain-funcs
MY_P="man-${PV}"
DESCRIPTION="Standard commands to read man pages"
HOMEPAGE="http://primates.ximian.com/~flucifredi/man/"
SRC_URI="http://primates.ximian.com/~flucifredi/man/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 sparc x86"
-IUSE=""
RDEPEND="!sys-apps/man"
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- epatch "${FILESDIR}"/man-1.6f-man2html-compression-2.patch
- epatch "${FILESDIR}"/man-1.6-cross-compile.patch
- epatch "${FILESDIR}"/man-1.6g-compress.patch #205147
-}
+PATCHES=(
+ "${FILESDIR}"/man-1.6f-man2html-compression-2.patch
+ "${FILESDIR}"/man-1.6-cross-compile.patch
+ "${FILESDIR}"/man-1.6g-compress.patch #205147
+)
-echoit() { echo "$@" ; "$@" ; }
src_configure() {
+ echoit() {
+ echo "$@"
+ "$@"
+ }
+
tc-export CC BUILD_CC
# Just a stub to disable configure check. man2html doesn't use it.
@@ -48,7 +50,8 @@ src_compile() {
src_install() {
# A little faster to run this by hand than `emake install`.
- cd man2html
+ cd man2html || die
+
dobin man2html
doman man2html.1
dodoc README TODO