summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-03-28 01:07:14 +0000
committerSam James <sam@gentoo.org>2024-03-28 01:07:14 +0000
commit002039936a768e0fd938652da0cce452d7d3ace2 (patch)
treeeab6f9376c9e1141b82d823103c8d97a24542baf /sys-apps/moar
parentsys-fs/btrfs-progs: add 6.8 (diff)
downloadgentoo-002039936a768e0fd938652da0cce452d7d3ace2.tar.gz
gentoo-002039936a768e0fd938652da0cce452d7d3ace2.tar.bz2
gentoo-002039936a768e0fd938652da0cce452d7d3ace2.zip
sys-apps/moar: add 1.23.9
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/moar')
-rw-r--r--sys-apps/moar/Manifest2
-rw-r--r--sys-apps/moar/moar-1.23.9.ebuild42
2 files changed, 44 insertions, 0 deletions
diff --git a/sys-apps/moar/Manifest b/sys-apps/moar/Manifest
index 5472dd7e5328..01f8428510a3 100644
--- a/sys-apps/moar/Manifest
+++ b/sys-apps/moar/Manifest
@@ -4,3 +4,5 @@ DIST moar-1.23.6-deps.tar.xz 37188500 BLAKE2B a5c92f8e56d4c7588265132f33089f1086
DIST moar-1.23.6.tar.gz 2801847 BLAKE2B d9e638d15ac363d3787fcce4bdc640c497a400ecaf5f40763dd8efed28cc3f5e479733d4b1f9a457395e4b9dda844748459a07fa674f50e3d6b630755af3ac4f SHA512 94103263f2c07464fbc0c5a90519a3a03ef5f163a67ca451a703c11bf46b98011b6e29a038b08bb47dc08230c28ae822ced49f2aec2bf8b6e83c6a4c1f330aa4
DIST moar-1.23.7-deps.tar.xz 37188500 BLAKE2B a5c92f8e56d4c7588265132f33089f1086fb7a14b1d1023caf7594cbda16772776751a80d44f451a9c5c765bd03d25687a63b5a00c4a50603b4598162920d840 SHA512 44c924339dbde95b647c464a00382786dfd8adfc72f307a9df63ed39f85fefe76260fde082a39738fb97c571217e8d591bdeada054dbe75ed56aa0156e7cf2fa
DIST moar-1.23.7.tar.gz 2802061 BLAKE2B 767efc6919415f342a3c31dc99692f23d991c22e92f2c7387765aa63ab591c5791d9bf5c6ddea704456924c55b976af141af7b39e726fe651262fce21dd353fe SHA512 56958508d9ee710cb91df90f6b18bb7f0db95444e65eb8fa80a5ee33c4ad99f4f4482c1eec1ef44b64906e016e9465002571fa141ce03eeeaecc62cba102ead0
+DIST moar-1.23.9-deps.tar.xz 37188500 BLAKE2B a5c92f8e56d4c7588265132f33089f1086fb7a14b1d1023caf7594cbda16772776751a80d44f451a9c5c765bd03d25687a63b5a00c4a50603b4598162920d840 SHA512 44c924339dbde95b647c464a00382786dfd8adfc72f307a9df63ed39f85fefe76260fde082a39738fb97c571217e8d591bdeada054dbe75ed56aa0156e7cf2fa
+DIST moar-1.23.9.tar.gz 2804191 BLAKE2B d5663fedd70fc80d70a206c276ece6ec11da4f4b4dc396a3e11b1fb8edd5bd9f3395e943158c4bb297b5ebfeecd8f61bdbaaff79e78c4a89458f1b1a02db0e71 SHA512 9ab4a3e49b66b39f642b6a1f882c0980a4e755e3e127ca37d1319615ae836fe3250676a8c0e95ccd0f8e714357df5dc00235bf67be6097a7b2811f0e3bf02e9f
diff --git a/sys-apps/moar/moar-1.23.9.ebuild b/sys-apps/moar/moar-1.23.9.ebuild
new file mode 100644
index 000000000000..7ba82f9aa27b
--- /dev/null
+++ b/sys-apps/moar/moar-1.23.9.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="Pager designed to do the right thing without any configuration"
+HOMEPAGE="https://github.com/walles/moar"
+SRC_URI="https://github.com/walles/moar/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-deps.tar.xz"
+
+LICENSE="BSD-2 BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# moarvm: https://github.com/walles/moar/issues/143
+RDEPEND="!dev-lang/moarvm"
+BDEPEND="
+ test? (
+ app-arch/bzip2
+ app-arch/xz-utils
+ )
+"
+
+src_compile() {
+ # https://github.com/walles/moar/blob/master/build.sh#L28
+ ego build -ldflags="-w -X main.versionString=${PV}" -o moar
+}
+
+src_test() {
+ # From test.sh (we don't run that because it has some linting etc)
+ ego test -timeout 20s ./...
+}
+
+src_install() {
+ dobin moar
+ doman moar.1
+ einstalldocs
+}