summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-01-14 03:55:23 +0000
committerSam James <sam@gentoo.org>2024-01-14 03:55:23 +0000
commit6972fd561fd6655624dcf2300f5cf20c2ee01b8d (patch)
tree7dc8eda544b3d77d8bf15f597ec109cb4b5ba641 /sys-apps/moar
parentsys-apps/attr: fix LICENSE (diff)
downloadgentoo-6972fd561fd6655624dcf2300f5cf20c2ee01b8d.tar.gz
gentoo-6972fd561fd6655624dcf2300f5cf20c2ee01b8d.tar.bz2
gentoo-6972fd561fd6655624dcf2300f5cf20c2ee01b8d.zip
sys-apps/moar: add 1.22.3
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/moar')
-rw-r--r--sys-apps/moar/Manifest2
-rw-r--r--sys-apps/moar/moar-1.22.3.ebuild42
2 files changed, 44 insertions, 0 deletions
diff --git a/sys-apps/moar/Manifest b/sys-apps/moar/Manifest
index ed08f8de8418..a73e4079ffbe 100644
--- a/sys-apps/moar/Manifest
+++ b/sys-apps/moar/Manifest
@@ -2,3 +2,5 @@ DIST moar-1.20.0-deps.tar.xz 5100896 BLAKE2B 0be3ca9e2fa88f8d57705f0a79a21088cf1
DIST moar-1.20.0.tar.gz 2793794 BLAKE2B 10fa1f59a0ec20703d8a478e190188555c668fddb37128dbe4821f47acba035dfa102403d5bb9f4f19af809d2e08fac9ede1e25f1aa333949ffc332ea41c2f7c SHA512 d85eb1b8e9cc01384eca606b0ccf0f76b55dd7d8635a5c4f075dbd5784bebaa4004c379b8a5ba018643d75c088dad83599a7d2faa7c15ff9d008b0c7ade76787
DIST moar-1.21.0-deps.tar.xz 5100896 BLAKE2B 0be3ca9e2fa88f8d57705f0a79a21088cf1c004740c784b3b8249fde03eae0557bfba97e9e9b5266ae37364e4a686c3e8c5a5556f8ff23f8aef90845f5c891eb SHA512 ec2e5dc41fab5327b7ec25a5aed199712421121fa6f2bed0c76658784ff6260cb6cdba3e478eb3bcdee7ae177acb2be34c35ca01ad7c35f36a1b62c8ff7ad673
DIST moar-1.21.0.tar.gz 2793970 BLAKE2B 696fc70d7fa05f6e3537272730a7d844c2fd5de94fb2a154906b8102096425c384fd8c54a0f9cdd5bde44b3310119fb5f1e52d98edc10e284c13cdfc44255a6e SHA512 8c91b6f910689496ebe3a5a59325fffc99aeee6808e0c65f01eead47b902481ee02841cdd33a62c90d99d760a2f052df89695b144ed2d7c5446733be7957dcb6
+DIST moar-1.22.3-deps.tar.xz 61027724 BLAKE2B ba22db246b20f4a6b28c19a3654f1b1cd68e0a92aff43ff02a592b303ff3318c3766381bd4b0abff5f479fe571b753a272213d7dc7da809a33ded36228dac100 SHA512 a1be9f66480867faa06fb451bcc6a294bb1e2e4601c97c1beac67a3f866104b196ecd2653dc9ddd48a5223d4f3067a01abbaf45fc07333d97c4f8489424ff5cf
+DIST moar-1.22.3.tar.gz 2799819 BLAKE2B 681297e9a84f6846d7ea6cd591403fd3100079fc8418ce5841a50755927239eca5abbfc0477d1a74e3af687ef1ebe372d4f708c38a64ba61b3095ac161f1cb8e SHA512 377cdf4916b036088f48abd4aa9818f002dd5ab025a54f4d91626380bb3d370daf046da6f3dc31fcc11a375d7da1a84288fb3e2e3357181a6ecc6a46af78c452
diff --git a/sys-apps/moar/moar-1.22.3.ebuild b/sys-apps/moar/moar-1.22.3.ebuild
new file mode 100644
index 000000000000..7ba82f9aa27b
--- /dev/null
+++ b/sys-apps/moar/moar-1.22.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="Pager designed to do the right thing without any configuration"
+HOMEPAGE="https://github.com/walles/moar"
+SRC_URI="https://github.com/walles/moar/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-deps.tar.xz"
+
+LICENSE="BSD-2 BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# moarvm: https://github.com/walles/moar/issues/143
+RDEPEND="!dev-lang/moarvm"
+BDEPEND="
+ test? (
+ app-arch/bzip2
+ app-arch/xz-utils
+ )
+"
+
+src_compile() {
+ # https://github.com/walles/moar/blob/master/build.sh#L28
+ ego build -ldflags="-w -X main.versionString=${PV}" -o moar
+}
+
+src_test() {
+ # From test.sh (we don't run that because it has some linting etc)
+ ego test -timeout 20s ./...
+}
+
+src_install() {
+ dobin moar
+ doman moar.1
+ einstalldocs
+}