summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@atlas.cz>2023-02-17 22:25:03 +0100
committerSam James <sam@gentoo.org>2023-02-21 08:00:59 +0000
commitce487acde97451ff96619579ce49390e72c15fb7 (patch)
tree59cd7fb0cdb2901a587aff5edf35cf5f1512e507 /sys-apps/s6
parentdev-lang/execline: add 2.9.2.0 (diff)
downloadgentoo-ce487acde97451ff96619579ce49390e72c15fb7.tar.gz
gentoo-ce487acde97451ff96619579ce49390e72c15fb7.tar.bz2
gentoo-ce487acde97451ff96619579ce49390e72c15fb7.zip
sys-apps/s6: add 2.11.3.0
The package newly installs libraries to /lib* rather than /usr/lib* because utilities are installed to /bin, therefore, they should link shared libraries from /lib*. The /lib/s6 destination is used helper utilities instead of /usr/libexec. See-also: https://github.com/gentoo/gentoo/pull/12120#discussion_r296437625 Signed-off-by: Petr Vaněk <arkamar@atlas.cz> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/s6')
-rw-r--r--sys-apps/s6/Manifest1
-rw-r--r--sys-apps/s6/s6-2.11.3.0.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/sys-apps/s6/Manifest b/sys-apps/s6/Manifest
index 25935bf02a7e..1aff200dddf0 100644
--- a/sys-apps/s6/Manifest
+++ b/sys-apps/s6/Manifest
@@ -1,2 +1,3 @@
DIST s6-2.11.1.2.tar.gz 229092 BLAKE2B 672321d1b9b1b66e7c920a9c587d2ad3a3ca66be7bac0e3f9b4d8290c9d716a3e90ccaac709dbe7ac6525b972ef95429c776805fce3e36fc5b197e9cc826d258 SHA512 31feb2b1704d9561aff9fccdcb284e13f4ceb0f530214db8a393bdc10267801fbe1fc30b4271ad9bdf189dc52e2844f3db40f8f3e9cd438ac12415a51661f17d
DIST s6-2.11.2.0.tar.gz 246294 BLAKE2B c11fc25b9a209195a12cb12cb03560673c196c97cf5a0a66c850ed251dd387cdc1c6a002c9867ff9ad99faf1d8da42b4bb867074410d043c7cd2a8e8f1a2d44a SHA512 6666283d833f300d6d01984ffcc912e2ab49f88b756dc1748a2b997324c17494ad0e9dd40c0b0af8d367eaea99ab33be2d7afb070fa44e1991eb33776172e8a5
+DIST s6-2.11.3.0.tar.gz 247736 BLAKE2B a409e2f759e7096fa95c4cc60294b89b7625a712b95901fc3336d6c14af007a0a603db1f43db9a5e379657af3f2b0f4a995897a519346ee8a61e63ad5519fd19 SHA512 764981bb54c6add6bff7c77b41c6c61055fd8b9ba284c7b41e13e4103c8d5a3dddd442145d8eb572e5be6883ab6a9e3025c064d946e8e273e956d404528c5479
diff --git a/sys-apps/s6/s6-2.11.3.0.ebuild b/sys-apps/s6/s6-2.11.3.0.ebuild
new file mode 100644
index 000000000000..589e48f8ebb4
--- /dev/null
+++ b/sys-apps/s6/s6-2.11.3.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="skarnet.org's small and secure supervision software suite"
+HOMEPAGE="https://www.skarnet.org/software/s6/"
+SRC_URI="https://www.skarnet.org/software/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~riscv ~x86"
+IUSE="+execline"
+
+RDEPEND="
+ >=dev-libs/skalibs-2.13.1.0:=
+ execline? ( dev-lang/execline:= )
+"
+DEPEND="${RDEPEND}"
+
+HTML_DOCS=( doc/. )
+
+src_prepare() {
+ default
+
+ # Avoid QA warning for LDFLAGS addition
+ sed -i -e 's/.*-Wl,--hash-style=both$/:/' configure || die
+
+ sed -i -e '/AR := /d' -e '/RANLIB := /d' Makefile || die
+}
+
+src_configure() {
+ tc-export AR CC RANLIB
+
+ local myconf=(
+ --bindir=/bin
+ --dynlibdir="/$(get_libdir)"
+ --libdir="/usr/$(get_libdir)/${PN}"
+ --libexecdir=/lib/s6
+ --with-dynlib="/$(get_libdir)"
+ --with-lib="/usr/$(get_libdir)/execline"
+ --with-lib="/usr/$(get_libdir)/skalibs"
+ --with-sysdeps="/usr/$(get_libdir)/skalibs"
+ --enable-shared
+ --disable-allstatic
+ --disable-static
+ --disable-static-libc
+ $(use_enable execline)
+ )
+
+ econf "${myconf[@]}"
+}