summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Davies <jpds@protonmail.com>2021-03-18 01:00:37 +0000
committerJason Zaman <perfinion@gentoo.org>2021-04-02 21:15:31 -0700
commit2b55250a66d6f8f2ce5b5a11875986a121d63c55 (patch)
tree109a1afbc58f030d5ff71c62459ed1c939fb7fe5 /sys-apps/secilc
parentsys-apps/secilc: Version updated to 3.2. (diff)
downloadgentoo-2b55250a66d6f8f2ce5b5a11875986a121d63c55.tar.gz
gentoo-2b55250a66d6f8f2ce5b5a11875986a121d63c55.tar.bz2
gentoo-2b55250a66d6f8f2ce5b5a11875986a121d63c55.zip
sys-apps/secilc: Sync live ebuild.
Signed-off-by: Jonathan Davies <jpds@protonmail.com> Signed-off-by: Jason Zaman <perfinion@gentoo.org>
Diffstat (limited to 'sys-apps/secilc')
-rw-r--r--sys-apps/secilc/secilc-9999.ebuild12
1 files changed, 3 insertions, 9 deletions
diff --git a/sys-apps/secilc/secilc-9999.ebuild b/sys-apps/secilc/secilc-9999.ebuild
index 0642e837b999..c7694587c83e 100644
--- a/sys-apps/secilc/secilc-9999.ebuild
+++ b/sys-apps/secilc/secilc-9999.ebuild
@@ -4,28 +4,22 @@
EAPI="7"
inherit toolchain-funcs
-MY_P="${P//_/-}"
-MY_RELEASEDATE="20200710"
-
-SEPOL_VER="${PV}"
-
DESCRIPTION="SELinux Common Intermediate Language (CIL) Compiler"
HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
- S="${WORKDIR}/${MY_P}/${PN}"
+ S="${WORKDIR}/${P}/${PN}"
else
- SRC_URI="https://github.com/SELinuxProject/selinux/releases/download/${MY_RELEASEDATE}/${MY_P}.tar.gz"
+ SRC_URI="https://github.com/SELinuxProject/selinux/releases/download/${PV}/${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
- S="${WORKDIR}/${MY_P}"
fi
LICENSE="GPL-2"
SLOT="0"
-DEPEND=">=sys-libs/libsepol-${SEPOL_VER}"
+DEPEND=">=sys-libs/libsepol-${PV}"
RDEPEND="${DEPEND}"
BDEPEND="app-text/xmlto"