summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-10-06 11:11:31 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-10-06 17:20:45 +0200
commitbcc522bcb303b38d4164ae82cfe3966a4de5819b (patch)
treec44246527ebae301f9cff4b84cf0eabef3e57956 /sys-apps/system-monitoring-center
parentdev-python/python-ironicclient: Stabilize 5.4.0 ALLARCHES, #915290 (diff)
downloadgentoo-bcc522bcb303b38d4164ae82cfe3966a4de5819b.tar.gz
gentoo-bcc522bcb303b38d4164ae82cfe3966a4de5819b.tar.bz2
gentoo-bcc522bcb303b38d4164ae82cfe3966a4de5819b.zip
sys-apps/system-monitoring-center: bump to 2.24.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'sys-apps/system-monitoring-center')
-rw-r--r--sys-apps/system-monitoring-center/Manifest1
-rw-r--r--sys-apps/system-monitoring-center/system-monitoring-center-2.24.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/sys-apps/system-monitoring-center/Manifest b/sys-apps/system-monitoring-center/Manifest
index e8faf43e59ac..7870a1c03c98 100644
--- a/sys-apps/system-monitoring-center/Manifest
+++ b/sys-apps/system-monitoring-center/Manifest
@@ -2,3 +2,4 @@ DIST system-monitoring-center-2.21.1.tar.gz 1505833 BLAKE2B a2270f20e745191eb72c
DIST system-monitoring-center-2.21.2.tar.gz 1511509 BLAKE2B 44c573a83cc8eb3288543e5ab69c334d0d47dbc1fe05d64f6197a870f7df9c81cd3c57fb67c4219e04bd889554a057276af388e8374de15d02e83ec7ff487ae2 SHA512 95d7622079aa2fa89b1f7e98c886e2c215a204b6cc2b52d4e2892964350639004514fbbd1244df9c70acc7238308071b459997dacc7fa997aae840c9cc95e817
DIST system-monitoring-center-2.22.1.tar.gz 1741958 BLAKE2B 152e8d461219449bee1950172d52807fdf752503cc7446053cd76916fc8cf8045bb5a0e73ba75bdfc9c20f06a1ca0924366a31cb05f724e84fa14dcc3bae0ca0 SHA512 3a5e38d5e81a354442ba304e4b30faf5d1848fd7ec876508858a1dcf69bba2abfcea87191a5facab01bc02db79fbea9c992ae9b749812d30346c1024b2f35745
DIST system-monitoring-center-2.23.0.tar.gz 1753271 BLAKE2B 1426aa8c639f4958ba7e9dbbaba062a1b6768cfe32308888c3d92395a2861b3e3aca7ccd838f89e2c224ea94c6acd9e2c9a904e07e8bc64c31f8d88a2faed7ad SHA512 14347644fe7d5ff112c3b0ad09d394c9c0d70fe75b1fd092d3d4b0e9f6f8de3387c362d546f3272ba645cb9dba9b08089a9361cd7463bd4e3765c9df7338fd17
+DIST system-monitoring-center-2.24.0.tar.gz 1756467 BLAKE2B a0a477292b66cdffad5b2909a118381191e605bcf6b633362d4356cba309fbc6836c99ca46e1043c9398d97f85ca2df19afe0b2cede83d5c3bf7adf18fa50700 SHA512 54b80fb91d6845e2d13b42b27ab7c1f1c2379e2ff415f57c81ab1dc82b8e73783cf1aa151a096be5ce810cc001164f18c46e405f7acff318755ec358f7c299d8
diff --git a/sys-apps/system-monitoring-center/system-monitoring-center-2.24.0.ebuild b/sys-apps/system-monitoring-center/system-monitoring-center-2.24.0.ebuild
new file mode 100644
index 000000000000..0d57d2200134
--- /dev/null
+++ b/sys-apps/system-monitoring-center/system-monitoring-center-2.24.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit meson python-single-r1 xdg
+
+DESCRIPTION="Multi-featured system monitor GUI written in Python"
+HOMEPAGE="https://github.com/hakandundar34coding/system-monitoring-center/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/hakandundar34coding/${PN}.git"
+else
+ SRC_URI="https://github.com/hakandundar34coding/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ gui-libs/gtk:4[introspection]
+ gui-libs/libadwaita:1
+ sys-apps/dmidecode
+ sys-apps/hwdata
+ $(python_gen_cond_dep '
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+"
+
+src_install() {
+ meson_src_install
+ python_optimize "${ED}"/usr/share/${PN}
+
+ mv "${ED}"/usr/share/appdata "${ED}"/usr/share/metainfo || die
+}