summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-apps/udevil/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-apps/udevil/files')
-rw-r--r--sys-apps/udevil/files/udevil-0.4.1-automake-1.13.patch11
-rw-r--r--sys-apps/udevil/files/udevil-0.4.1-flags.patch46
-rw-r--r--sys-apps/udevil/files/udevil-0.4.3-flags.patch46
-rw-r--r--sys-apps/udevil/files/udevil-0.4.4-stat.patch11
4 files changed, 114 insertions, 0 deletions
diff --git a/sys-apps/udevil/files/udevil-0.4.1-automake-1.13.patch b/sys-apps/udevil/files/udevil-0.4.1-automake-1.13.patch
new file mode 100644
index 000000000000..44da794b195b
--- /dev/null
+++ b/sys-apps/udevil/files/udevil-0.4.1-automake-1.13.patch
@@ -0,0 +1,11 @@
+--- udevil-0.4.1/configure.ac
++++ udevil-0.4.1/configure.ac
+@@ -1,7 +1,7 @@
+ AC_PREREQ(2.52)
+
+ AC_INIT(src/udevil.c)
+-AM_CONFIG_HEADER(config.h)
++AC_CONFIG_HEADERS(config.h)
+ AC_CONFIG_SRCDIR(src)
+ AM_INIT_AUTOMAKE(udevil, 0.4.1)
+
diff --git a/sys-apps/udevil/files/udevil-0.4.1-flags.patch b/sys-apps/udevil/files/udevil-0.4.1-flags.patch
new file mode 100644
index 000000000000..166a4357e9f3
--- /dev/null
+++ b/sys-apps/udevil/files/udevil-0.4.1-flags.patch
@@ -0,0 +1,46 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Sun Oct 21 19:33:04 UTC 2012
+Subject: build system
+
+ respect flags where possible
+
+--- configure.ac
++++ configure.ac
+@@ -18,26 +18,6 @@
+
+
+ dnl linker optimizations
+-AC_MSG_CHECKING([whether $LD accepts --as-needed])
+-case `$LD --as-needed -v 2>&1 </dev/null` in
+-*GNU* | *'with BFD'*)
+- LDFLAGS="$LDFLAGS -Wl,--as-needed"
+- AC_MSG_RESULT([yes])
+- ;;
+-*)
+- AC_MSG_RESULT([no])
+- ;;
+-esac
+-AC_MSG_CHECKING([whether $LD accepts -O1])
+-case `$LD -O1 -v 2>&1 </dev/null` in
+-*GNU* | *'with BFD'*)
+- LDFLAGS="$LDFLAGS -Wl,-O1"
+- AC_MSG_RESULT([yes])
+- ;;
+-*)
+- AC_MSG_RESULT([no])
+- ;;
+-esac
+ AC_MSG_CHECKING([whether $LD accepts -Bsymbolic-functions])
+ case `$LD -Bsymbolic-functions -v 2>&1 </dev/null` in
+ *GNU* | *'with BFD'*)
+@@ -49,10 +29,6 @@
+ ;;
+ esac
+
+-dnl advanced compiler tweaking
+-CPPFLAGS="$CPPFLAGS -fstrict-aliasing -fmessage-length=0"
+-
+-
+ # program paths
+ AC_ARG_WITH(mount-prog,
+ AC_HELP_STRING([--with-mount-prog=PATH], [Path to mount program (default: /bin/mount)]),
diff --git a/sys-apps/udevil/files/udevil-0.4.3-flags.patch b/sys-apps/udevil/files/udevil-0.4.3-flags.patch
new file mode 100644
index 000000000000..166a4357e9f3
--- /dev/null
+++ b/sys-apps/udevil/files/udevil-0.4.3-flags.patch
@@ -0,0 +1,46 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Sun Oct 21 19:33:04 UTC 2012
+Subject: build system
+
+ respect flags where possible
+
+--- configure.ac
++++ configure.ac
+@@ -18,26 +18,6 @@
+
+
+ dnl linker optimizations
+-AC_MSG_CHECKING([whether $LD accepts --as-needed])
+-case `$LD --as-needed -v 2>&1 </dev/null` in
+-*GNU* | *'with BFD'*)
+- LDFLAGS="$LDFLAGS -Wl,--as-needed"
+- AC_MSG_RESULT([yes])
+- ;;
+-*)
+- AC_MSG_RESULT([no])
+- ;;
+-esac
+-AC_MSG_CHECKING([whether $LD accepts -O1])
+-case `$LD -O1 -v 2>&1 </dev/null` in
+-*GNU* | *'with BFD'*)
+- LDFLAGS="$LDFLAGS -Wl,-O1"
+- AC_MSG_RESULT([yes])
+- ;;
+-*)
+- AC_MSG_RESULT([no])
+- ;;
+-esac
+ AC_MSG_CHECKING([whether $LD accepts -Bsymbolic-functions])
+ case `$LD -Bsymbolic-functions -v 2>&1 </dev/null` in
+ *GNU* | *'with BFD'*)
+@@ -49,10 +29,6 @@
+ ;;
+ esac
+
+-dnl advanced compiler tweaking
+-CPPFLAGS="$CPPFLAGS -fstrict-aliasing -fmessage-length=0"
+-
+-
+ # program paths
+ AC_ARG_WITH(mount-prog,
+ AC_HELP_STRING([--with-mount-prog=PATH], [Path to mount program (default: /bin/mount)]),
diff --git a/sys-apps/udevil/files/udevil-0.4.4-stat.patch b/sys-apps/udevil/files/udevil-0.4.4-stat.patch
new file mode 100644
index 000000000000..22e41d467821
--- /dev/null
+++ b/sys-apps/udevil/files/udevil-0.4.4-stat.patch
@@ -0,0 +1,11 @@
+Fixes bug #552072. Thanks Helmut Jarausch.
+--- src/device-info.h
++++ src/device-info.h
+@@ -14,6 +14,7 @@
+ #include <libudev.h>
+ #include <fcntl.h>
+ #include <errno.h>
++#include <sys/stat.h>
+
+ // intltool
+ #include <glib/gi18n.h>