summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-05-06 10:34:10 +0100
committerSam James <sam@gentoo.org>2023-05-06 10:40:09 +0100
commite0c5b00aca2ab62b2027a36ff557713f68a1e092 (patch)
tree8e7cb37c92c034c05bf8bf62ab95b1990454b820 /sys-apps/xdg-desktop-portal-gnome
parentsys-apps/xdg-desktop-portal: add delay/slowness backport (diff)
downloadgentoo-e0c5b00aca2ab62b2027a36ff557713f68a1e092.tar.gz
gentoo-e0c5b00aca2ab62b2027a36ff557713f68a1e092.tar.bz2
gentoo-e0c5b00aca2ab62b2027a36ff557713f68a1e092.zip
sys-apps/xdg-desktop-portal-gnome: depend on newer sys-apps/xdg-desktop-portal
Should help with delays opening applications. Bug: https://bugs.gentoo.org/905482 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/xdg-desktop-portal-gnome')
-rw-r--r--sys-apps/xdg-desktop-portal-gnome/xdg-desktop-portal-gnome-44.1-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/sys-apps/xdg-desktop-portal-gnome/xdg-desktop-portal-gnome-44.1-r1.ebuild b/sys-apps/xdg-desktop-portal-gnome/xdg-desktop-portal-gnome-44.1-r1.ebuild
new file mode 100644
index 000000000000..d75beb04c2ad
--- /dev/null
+++ b/sys-apps/xdg-desktop-portal-gnome/xdg-desktop-portal-gnome-44.1-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org meson systemd xdg
+
+DESCRIPTION="Backend implementation for xdg-desktop-portal using GNOME"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/xdg-desktop-portal-gnome"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+IUSE="wayland X"
+
+# Newer-than-strictly-required xdg-desktop-portal dep for hang/slowness fixes
+# https://gitlab.gnome.org/GNOME/xdg-desktop-portal-gnome/-/issues/74
+DEPEND="
+ dev-libs/glib:2
+ gnome-base/gnome-desktop:4=
+ gui-libs/libadwaita:1
+ media-libs/fontconfig
+ sys-apps/dbus
+ >=sys-apps/xdg-desktop-portal-1.16.0-r1
+ >=sys-apps/xdg-desktop-portal-gtk-1.14.0
+ gui-libs/gtk:4[wayland?,X?]
+ X? ( x11-libs/libX11 )
+ wayland? ( dev-libs/wayland )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ dev-util/gdbus-codegen
+ sys-devel/gettext
+ virtual/pkgconfig
+
+ wayland? ( dev-util/wayland-scanner )
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dsystemduserunitdir="$(systemd_get_userunitdir)"
+ )
+
+ meson_src_configure
+}