summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-06-16 16:53:03 +0100
committerSam James <sam@gentoo.org>2022-06-16 16:53:04 +0100
commit30e6071c742a0e20a8af79c877fcea75ae3182dc (patch)
treea15c259cc0b6ff577f29c4a75b25e57844ec164d /sys-apps
parentvirtual/dist-kernel: Stabilize 5.4.197 arm64, #852218 (diff)
downloadgentoo-30e6071c742a0e20a8af79c877fcea75ae3182dc.tar.gz
gentoo-30e6071c742a0e20a8af79c877fcea75ae3182dc.tar.bz2
gentoo-30e6071c742a0e20a8af79c877fcea75ae3182dc.zip
sys-apps/kmod: minor ebuild tidying
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/kmod/kmod-29-r1.ebuild13
-rw-r--r--sys-apps/kmod/kmod-9999.ebuild13
2 files changed, 14 insertions, 12 deletions
diff --git a/sys-apps/kmod/kmod-29-r1.ebuild b/sys-apps/kmod/kmod-29-r1.ebuild
index e500c5c7fb00..48747e41ed50 100644
--- a/sys-apps/kmod/kmod-29-r1.ebuild
+++ b/sys-apps/kmod/kmod-29-r1.ebuild
@@ -5,7 +5,7 @@ EAPI=8
PYTHON_COMPAT=( python3_{8..10} )
-inherit autotools bash-completion-r1 multilib python-r1
+inherit autotools libtool bash-completion-r1 python-r1
if [[ ${PV} == 9999* ]]; then
EGIT_REPO_URI="https://git.kernel.org/pub/scm/utils/kernel/${PN}/${PN}.git"
@@ -13,7 +13,6 @@ if [[ ${PV} == 9999* ]]; then
else
SRC_URI="https://www.kernel.org/pub/linux/utils/kernel/kmod/${P}.tar.xz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
- #inherit libtool
fi
DESCRIPTION="library and tools for managing linux kernel modules"
@@ -78,7 +77,7 @@ src_prepare() {
elibtoolize
fi
- # Restore possibility of running --enable-static wrt #472608
+ # Restore possibility of running --enable-static, bug #472608
sed -i \
-e '/--enable-static is not supported by kmod/s:as_fn_error:echo:' \
configure || die
@@ -119,7 +118,7 @@ src_compile() {
emake -C "${BUILD_DIR}"
if use python; then
- local native_builddir=${BUILD_DIR}
+ local native_builddir="${BUILD_DIR}"
python_compile() {
emake -C "${BUILD_DIR}" -f Makefile -f - python \
@@ -135,10 +134,11 @@ src_compile() {
src_install() {
emake -C "${BUILD_DIR}" DESTDIR="${D}" install
+
einstalldocs
if use python; then
- local native_builddir=${BUILD_DIR}
+ local native_builddir="${BUILD_DIR}"
python_install() {
emake -C "${BUILD_DIR}" DESTDIR="${D}" \
@@ -171,7 +171,8 @@ src_install() {
EOF
insinto /lib/modprobe.d
- doins "${T}"/usb-load-ehci-first.conf #260139
+ # bug #260139
+ doins "${T}"/usb-load-ehci-first.conf
newinitd "${FILESDIR}"/kmod-static-nodes-r1 kmod-static-nodes
}
diff --git a/sys-apps/kmod/kmod-9999.ebuild b/sys-apps/kmod/kmod-9999.ebuild
index e500c5c7fb00..48747e41ed50 100644
--- a/sys-apps/kmod/kmod-9999.ebuild
+++ b/sys-apps/kmod/kmod-9999.ebuild
@@ -5,7 +5,7 @@ EAPI=8
PYTHON_COMPAT=( python3_{8..10} )
-inherit autotools bash-completion-r1 multilib python-r1
+inherit autotools libtool bash-completion-r1 python-r1
if [[ ${PV} == 9999* ]]; then
EGIT_REPO_URI="https://git.kernel.org/pub/scm/utils/kernel/${PN}/${PN}.git"
@@ -13,7 +13,6 @@ if [[ ${PV} == 9999* ]]; then
else
SRC_URI="https://www.kernel.org/pub/linux/utils/kernel/kmod/${P}.tar.xz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
- #inherit libtool
fi
DESCRIPTION="library and tools for managing linux kernel modules"
@@ -78,7 +77,7 @@ src_prepare() {
elibtoolize
fi
- # Restore possibility of running --enable-static wrt #472608
+ # Restore possibility of running --enable-static, bug #472608
sed -i \
-e '/--enable-static is not supported by kmod/s:as_fn_error:echo:' \
configure || die
@@ -119,7 +118,7 @@ src_compile() {
emake -C "${BUILD_DIR}"
if use python; then
- local native_builddir=${BUILD_DIR}
+ local native_builddir="${BUILD_DIR}"
python_compile() {
emake -C "${BUILD_DIR}" -f Makefile -f - python \
@@ -135,10 +134,11 @@ src_compile() {
src_install() {
emake -C "${BUILD_DIR}" DESTDIR="${D}" install
+
einstalldocs
if use python; then
- local native_builddir=${BUILD_DIR}
+ local native_builddir="${BUILD_DIR}"
python_install() {
emake -C "${BUILD_DIR}" DESTDIR="${D}" \
@@ -171,7 +171,8 @@ src_install() {
EOF
insinto /lib/modprobe.d
- doins "${T}"/usb-load-ehci-first.conf #260139
+ # bug #260139
+ doins "${T}"/usb-load-ehci-first.conf
newinitd "${FILESDIR}"/kmod-static-nodes-r1 kmod-static-nodes
}