summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNathan Du <nathandu@outlook.com>2023-10-01 17:35:01 +0800
committerMike Gilbert <floppym@gentoo.org>2023-10-01 15:12:17 -0400
commit35d66e67ccba6342efb8ccaf845a7f9020f01dff (patch)
treea5dfb6050dfd23f667f4582d97552fcd14352b00 /sys-apps
parentsys-apps/systemd-utils: drop 252.9, 253.6, 254.3, 254.4 (diff)
downloadgentoo-35d66e67ccba6342efb8ccaf845a7f9020f01dff.tar.gz
gentoo-35d66e67ccba6342efb8ccaf845a7f9020f01dff.tar.bz2
gentoo-35d66e67ccba6342efb8ccaf845a7f9020f01dff.zip
sys-apps/systemd-utils: install libudev man pages
Closes: https://bugs.gentoo.org/915011 Signed-off-by: Nathan Du <nathandu@outlook.com> Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/systemd-utils/systemd-utils-253.11-r1.ebuild (renamed from sys-apps/systemd-utils/systemd-utils-253.11.ebuild)14
-rw-r--r--sys-apps/systemd-utils/systemd-utils-253.12-r1.ebuild (renamed from sys-apps/systemd-utils/systemd-utils-253.12.ebuild)14
-rw-r--r--sys-apps/systemd-utils/systemd-utils-254.5-r1.ebuild (renamed from sys-apps/systemd-utils/systemd-utils-254.5.ebuild)14
3 files changed, 42 insertions, 0 deletions
diff --git a/sys-apps/systemd-utils/systemd-utils-253.11.ebuild b/sys-apps/systemd-utils/systemd-utils-253.11-r1.ebuild
index b0af755e370d..de6425e32cf7 100644
--- a/sys-apps/systemd-utils/systemd-utils-253.11.ebuild
+++ b/sys-apps/systemd-utils/systemd-utils-253.11-r1.ebuild
@@ -347,6 +347,18 @@ multilib_src_compile() {
targets+=(
udev:shared_library
src/libudev/libudev.pc
+ man/libudev.3
+ man/udev_device_get_syspath.3
+ man/udev_device_has_tag.3
+ man/udev_device_new_from_syspath.3
+ man/udev_enumerate_add_match_subsystem.3
+ man/udev_enumerate_new.3
+ man/udev_enumerate_scan_devices.3
+ man/udev_list_entry.3
+ man/udev_monitor_filter_update.3
+ man/udev_monitor_new_from_netlink.3
+ man/udev_monitor_receive_device.3
+ man/udev_new.3
)
if use test; then
targets+=(
@@ -458,6 +470,8 @@ multilib_src_install() {
gen_usr_ldscript -a udev
insinto "/usr/$(get_libdir)/pkgconfig"
doins src/libudev/libudev.pc
+ doman man/libudev.3
+ doman man/udev_*.3
fi
}
diff --git a/sys-apps/systemd-utils/systemd-utils-253.12.ebuild b/sys-apps/systemd-utils/systemd-utils-253.12-r1.ebuild
index c06d1b1a0d0c..16e6b7cebd76 100644
--- a/sys-apps/systemd-utils/systemd-utils-253.12.ebuild
+++ b/sys-apps/systemd-utils/systemd-utils-253.12-r1.ebuild
@@ -347,6 +347,18 @@ multilib_src_compile() {
targets+=(
udev:shared_library
src/libudev/libudev.pc
+ man/libudev.3
+ man/udev_device_get_syspath.3
+ man/udev_device_has_tag.3
+ man/udev_device_new_from_syspath.3
+ man/udev_enumerate_add_match_subsystem.3
+ man/udev_enumerate_new.3
+ man/udev_enumerate_scan_devices.3
+ man/udev_list_entry.3
+ man/udev_monitor_filter_update.3
+ man/udev_monitor_new_from_netlink.3
+ man/udev_monitor_receive_device.3
+ man/udev_new.3
)
if use test; then
targets+=(
@@ -458,6 +470,8 @@ multilib_src_install() {
gen_usr_ldscript -a udev
insinto "/usr/$(get_libdir)/pkgconfig"
doins src/libudev/libudev.pc
+ doman man/libudev.3
+ doman man/udev_*.3
fi
}
diff --git a/sys-apps/systemd-utils/systemd-utils-254.5.ebuild b/sys-apps/systemd-utils/systemd-utils-254.5-r1.ebuild
index 849af65cc76c..78bd97986039 100644
--- a/sys-apps/systemd-utils/systemd-utils-254.5.ebuild
+++ b/sys-apps/systemd-utils/systemd-utils-254.5-r1.ebuild
@@ -352,6 +352,18 @@ multilib_src_compile() {
targets+=(
udev:shared_library
src/libudev/libudev.pc
+ man/libudev.3
+ man/udev_device_get_syspath.3
+ man/udev_device_has_tag.3
+ man/udev_device_new_from_syspath.3
+ man/udev_enumerate_add_match_subsystem.3
+ man/udev_enumerate_new.3
+ man/udev_enumerate_scan_devices.3
+ man/udev_list_entry.3
+ man/udev_monitor_filter_update.3
+ man/udev_monitor_new_from_netlink.3
+ man/udev_monitor_receive_device.3
+ man/udev_new.3
)
if use test; then
targets+=(
@@ -460,6 +472,8 @@ multilib_src_install() {
gen_usr_ldscript -a udev
insinto "/usr/$(get_libdir)/pkgconfig"
doins src/libudev/libudev.pc
+ doman man/libudev.3
+ doman man/udev_*.3
fi
}