summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-06-25 04:50:15 +0100
committerSam James <sam@gentoo.org>2024-06-25 04:50:15 +0100
commitcf372294b8555b1830e34684a783656f19daa5fd (patch)
treecda3443537184a379ba11787284176ceabddd43b /sys-apps
parentdev-build/meson: Stabilize 1.4.1 arm64, #934824 (diff)
downloadgentoo-cf372294b8555b1830e34684a783656f19daa5fd.tar.gz
gentoo-cf372294b8555b1830e34684a783656f19daa5fd.tar.bz2
gentoo-cf372294b8555b1830e34684a783656f19daa5fd.zip
sys-apps/pv: add 1.8.10
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/pv/Manifest2
-rw-r--r--sys-apps/pv/pv-1.8.10.ebuild61
2 files changed, 63 insertions, 0 deletions
diff --git a/sys-apps/pv/Manifest b/sys-apps/pv/Manifest
index 2d299974d165..e00f04eb47dc 100644
--- a/sys-apps/pv/Manifest
+++ b/sys-apps/pv/Manifest
@@ -1,3 +1,5 @@
+DIST pv-1.8.10.tar.gz 328069 BLAKE2B 03e2c6717954e55b9ce2bdb7462e83c07a3d1d71799aa20a225a3140a0cdda4b3b8a7b038e065ee939bfd881392471f24846422e751f07909c6ca2fb1d4f515c SHA512 4bb60d55f7c8e5453793ec6771f70b791b25324f07a673f111afdfdb79225f28987265f736b9dd5d5bdfa279634be46b8db2cb774f78c91c88f25d254cd9be78
+DIST pv-1.8.10.tar.gz.asc 691 BLAKE2B 5425cbac5a3212a9f13222d8e8de28fc60a3418acdd32e094394afe59e3f69dedc9101e56a9888d39baf68e0f0f7482b57f74544d20bb6919a05597f7954b325 SHA512 ab9b1ed2a58a25eba30f48d6b176464ae6fd93e14b55571b7db7c815dc1810c022eff9b92885f64002a12c341b640bb2fdda3b0495dfb6e65d5b1ec4564e0b86
DIST pv-1.8.5.tar.gz 327072 BLAKE2B ef7fcf64430a72e04ca3a922115e7012c999109bb7e1a52f480c27eeb6c49952f4be52e6041a063c710d934c68555cfb65796103920fd240e4ebde2fa6a323c7 SHA512 6d7a0f785ace5e25c5677af4cf38a003386774e60563865de7f1dae60f1785685541da93e1f88236b8b2e14431584bc2cb2adb3a575fb90dc774bc6bacf22e21
DIST pv-1.8.5.tar.gz.asc 691 BLAKE2B ac5bd2b05e145d4ea5aedbb148b39a317d68329787f06f39f808be75951da0e0f460254b4a5049a8eafabad07edfbe936be00154f5dfa660628c8a3dfa3b7ffd SHA512 8414b2485347579a54233a2f241c080ab6461799c149567ab1063ce812b08ab2293f55bf8a24bcadabf94d12ce3dce36fe57277d822d115db9e53c957fe99c20
DIST pv-1.8.9.tar.gz 330129 BLAKE2B a8e8b567a0e9eed9fa9b938b5ef52623adda8907b26d6dc3664fb0e3c8bee193e615ad0f357f688a53fa0014d978bf98a157a072d0159e9aaded447d3e4b16e0 SHA512 d6e483d2cb5ef3def1df9c72774ab70a5210e7a45f165d3d1527f11366e7bbab57320f1987d460783eda94605a17c5ef2a027fa4a7e9d58b529f4b1b05ec07a8
diff --git a/sys-apps/pv/pv-1.8.10.ebuild b/sys-apps/pv/pv-1.8.10.ebuild
new file mode 100644
index 000000000000..89cf567ffe13
--- /dev/null
+++ b/sys-apps/pv/pv-1.8.10.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/pv.asc
+inherit linux-info toolchain-funcs verify-sig
+
+DESCRIPTION="Pipe Viewer: a tool for monitoring the progress of data through a pipe"
+HOMEPAGE="https://www.ivarch.com/programs/pv.shtml https://codeberg.org/a-j-wood/pv"
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://codeberg.org/a-j-wood/pv"
+ inherit autotools git-r3
+else
+ SRC_URI="
+ https://www.ivarch.com/programs/sources/${P}.tar.gz
+ verify-sig? ( https://www.ivarch.com/programs/sources/${P}.tar.gz.txt -> ${P}.tar.gz.asc )
+ "
+
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="debug nls"
+
+BDEPEND="verify-sig? ( sec-keys/openpgp-keys-pv )"
+
+pkg_setup() {
+ if use kernel_linux; then
+ CONFIG_CHECK="~SYSVIPC"
+ ERROR_SYSVIPC="You will need to enable CONFIG_SYSVIPC in your kernel to use the --remote option."
+ linux-info_pkg_setup
+ fi
+}
+
+src_prepare() {
+ default
+
+ # Valgrind isn't reliable within sandbox.
+ cat <<-EOF > tests/run-valgrind.sh || die
+ #!/bin/sh
+ exit 77
+ EOF
+ chmod +x tests/run-valgrind.sh || Die
+
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ tc-export AR
+
+ econf \
+ $(use_enable debug debugging) \
+ $(use_enable nls)
+}
+
+src_test() {
+ emake -Onone check
+}