summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2023-01-31 04:08:54 +0100
committerConrad Kostecki <conikost@gentoo.org>2023-01-31 16:15:26 +0100
commit405a8cc8a5db79b97cf3e164a1094ac807d8a2d6 (patch)
treec626ed8630bc1f88bfceb88adcc2e7958e2e3ec6 /sys-auth
parentsys-auth/AusweisApp2: drop 1.24.4 (diff)
downloadgentoo-405a8cc8a5db79b97cf3e164a1094ac807d8a2d6.tar.gz
gentoo-405a8cc8a5db79b97cf3e164a1094ac807d8a2d6.tar.bz2
gentoo-405a8cc8a5db79b97cf3e164a1094ac807d8a2d6.zip
sys-auth/AusweisApp2: add 1.26.2
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/AusweisApp2/AusweisApp2-1.26.2.ebuild51
-rw-r--r--sys-auth/AusweisApp2/Manifest1
2 files changed, 52 insertions, 0 deletions
diff --git a/sys-auth/AusweisApp2/AusweisApp2-1.26.2.ebuild b/sys-auth/AusweisApp2/AusweisApp2-1.26.2.ebuild
new file mode 100644
index 000000000000..e5e3ddda4634
--- /dev/null
+++ b/sys-auth/AusweisApp2/AusweisApp2-1.26.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg-utils
+
+DESCRIPTION="Official authentication app for German ID cards and residence permits"
+HOMEPAGE="https://www.ausweisapp.bund.de/"
+SRC_URI="https://github.com/Governikus/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="EUPL-1.2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ virtual/pkgconfig"
+
+RDEPEND="
+ dev-libs/openssl:0=
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtquickcontrols2:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwebsockets:5[qml]
+ dev-qt/qtwidgets:5
+ net-libs/http-parser:0=
+ sys-apps/pcsc-lite
+ virtual/udev"
+
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=OFF
+ -DQt=Qt5
+ )
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}
diff --git a/sys-auth/AusweisApp2/Manifest b/sys-auth/AusweisApp2/Manifest
index 1d8ec464e0ac..8129f5cf4641 100644
--- a/sys-auth/AusweisApp2/Manifest
+++ b/sys-auth/AusweisApp2/Manifest
@@ -1 +1,2 @@
DIST AusweisApp2-1.26.1.tar.gz 11488062 BLAKE2B a46dfc13bcbc6b6594732ff22bc41a35c587f659cea32e9c339dad9042c92ebf3c1591bd4b2c41ebed34c231b50d9aca1344e863de405af0ce54c5159b6d7c6f SHA512 ffad0d735adf963c3f4df054bd113f15d2dc0da59b77a91af676b5646f779dcc0d1d3a313d3a666dc406401cd154215ac7462ed0ecf97df69b8da19f799cdaf3
+DIST AusweisApp2-1.26.2.tar.gz 11491524 BLAKE2B dc73b9e62d3b50c5a904303f61a6ce6bfce6ab8795f0989a943c238e889f8d60bd27db2a403cf98aada4875253a58a5de46be415c0da0e201b292aca102a675d SHA512 8a133ad64ff7910852069b70250abb476fbb4a9f68f08efb9c5fb882bfa3328671e81b185a3ea7d3b936694057bc31cedaeb99cdfe07e3da79ea0474607b1273