summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>2024-10-22 15:53:00 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2024-10-23 09:20:36 +0300
commitbd7a367e7bbf306c53ff814c0bb9f9c278acc70b (patch)
tree797078e7c09f3f1596c401da9cd2b932a02da5a8 /sys-auth
parentdev-python/types-psutil: Bump to 6.1.0.20241022 (diff)
downloadgentoo-bd7a367e7bbf306c53ff814c0bb9f9c278acc70b.tar.gz
gentoo-bd7a367e7bbf306c53ff814c0bb9f9c278acc70b.tar.bz2
gentoo-bd7a367e7bbf306c53ff814c0bb9f9c278acc70b.zip
sys-auth/seatd: add 0.9.0
Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me> Closes: https://github.com/gentoo/gentoo/pull/39077 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/seatd/Manifest1
-rw-r--r--sys-auth/seatd/seatd-0.9.0.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/sys-auth/seatd/Manifest b/sys-auth/seatd/Manifest
index a5d51ded54e6..6af47d778a2b 100644
--- a/sys-auth/seatd/Manifest
+++ b/sys-auth/seatd/Manifest
@@ -1 +1,2 @@
DIST seatd-0.8.0.tar.gz 39349 BLAKE2B 920270808f28c85badb173af22edb03960f2b9cdce5af3124c64fe68c52a77f002272d2f19e97d107303c55ad6de498d279f6b05311793270c6ee84565fc435e SHA512 93b1e5c170564ce9654e4df9985af95cb505274b36e950998bb1f16803d2d46712140eded2bdd8d5e85aec62070afd9c224184276d79a0ff0813408dfc472db7
+DIST seatd-0.9.0.tar.gz 41606 BLAKE2B 17d366fd44541404cd675561d3d22b3f2a45dcb29fc2636f4019df7b2d58f4d90745645ec906d4e2a7325c02ca78029b017106671520b653fb3f96e73e1fb9bc SHA512 531ae25f67ae2c11fc45700391dd6bc38c1213379da6a0867735315595dc760ea89d94eb37d9efce8049bd427c898d33aa54f1c36ccb5286c840e011fc78d264
diff --git a/sys-auth/seatd/seatd-0.9.0.ebuild b/sys-auth/seatd/seatd-0.9.0.ebuild
new file mode 100644
index 000000000000..1d71f62aae4a
--- /dev/null
+++ b/sys-auth/seatd/seatd-0.9.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson systemd
+
+DESCRIPTION="Minimal seat management daemon and universal library"
+HOMEPAGE="https://sr.ht/~kennylevinsen/seatd"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.sr.ht/~kennylevinsen/seatd"
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+ SRC_URI="https://git.sr.ht/~kennylevinsen/seatd/archive/${PV}.tar.gz -> ${P}.tar.gz"
+fi
+LICENSE="MIT"
+SLOT="0/1"
+IUSE="builtin elogind server systemd"
+REQUIRED_USE="?? ( elogind systemd )"
+
+DEPEND="
+ elogind? ( sys-auth/elogind )
+ systemd? ( sys-apps/systemd:= )
+"
+RDEPEND="${DEPEND}
+ server? ( acct-group/seat )
+"
+BDEPEND=">=app-text/scdoc-1.9.7"
+
+src_configure() {
+ local emesonargs=(
+ -Dman-pages=enabled
+ $(meson_feature builtin libseat-builtin)
+ $(meson_feature server)
+ )
+
+ if use elogind ; then
+ emesonargs+=( -Dlibseat-logind=elogind )
+ elif use systemd; then
+ emesonargs+=( -Dlibseat-logind=systemd )
+ else
+ emesonargs+=( -Dlibseat-logind=disabled )
+ fi
+
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ if use server; then
+ newinitd "${FILESDIR}/seatd.initd-r1" seatd
+ systemd_dounit contrib/systemd/seatd.service
+
+ if has_version '<sys-auth/seatd-0.7.0-r2'; then
+ elog "For OpenRC users: seatd is now using the 'seat' group instead of the 'video' group"
+ elog "Make sure your user(s) are in the 'seat' group."
+ elog "Note: 'video' is still needed for GPU access like OpenGL"
+ fi
+ fi
+}