summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-09-05 05:19:39 +0100
committerSam James <sam@gentoo.org>2021-09-05 06:24:49 +0100
commitdd501e0c4e7026e86a65885333ec84275bb6f003 (patch)
tree38239a7cd4f77aa1e0e76483c46dd3c4aba0d373 /sys-block/fio
parentsys-apps/util-linux: enable IUSE="+hardlink" by default (diff)
downloadgentoo-dd501e0c4e7026e86a65885333ec84275bb6f003.tar.gz
gentoo-dd501e0c4e7026e86a65885333ec84275bb6f003.tar.bz2
gentoo-dd501e0c4e7026e86a65885333ec84275bb6f003.zip
sys-block/fio: fix build with linux-headers-5.14
Closes: https://bugs.gentoo.org/811699 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-block/fio')
-rw-r--r--sys-block/fio/files/fio-2.2.13-libmtd.patch5
-rw-r--r--sys-block/fio/files/fio-3.27-drop-raw.patch118
-rw-r--r--sys-block/fio/fio-3.27-r1.ebuild155
3 files changed, 275 insertions, 3 deletions
diff --git a/sys-block/fio/files/fio-2.2.13-libmtd.patch b/sys-block/fio/files/fio-2.2.13-libmtd.patch
index 7ab9a96c25e3..9581def526e1 100644
--- a/sys-block/fio/files/fio-2.2.13-libmtd.patch
+++ b/sys-block/fio/files/fio-2.2.13-libmtd.patch
@@ -1,6 +1,5 @@
-diff -Nuar --exclude config.log fio-2.2.13/oslib/libmtd.h fio-2.2.13.new/oslib/libmtd.h
---- fio-2.2.13/oslib/libmtd.h 2016-01-26 18:02:07.000000000 -0800
-+++ fio-2.2.13.new/oslib/libmtd.h 2016-02-03 08:10:19.104693006 -0800
+--- fio-2.2.13/oslib/libmtd.h
++++ fio-2.2.13.new/oslib/libmtd.h
@@ -29,6 +29,8 @@
extern "C" {
#endif
diff --git a/sys-block/fio/files/fio-3.27-drop-raw.patch b/sys-block/fio/files/fio-3.27-drop-raw.patch
new file mode 100644
index 000000000000..1c9f8671d12e
--- /dev/null
+++ b/sys-block/fio/files/fio-3.27-drop-raw.patch
@@ -0,0 +1,118 @@
+https://github.com/axboe/fio/commit/382975557e632efb506836bc1709789e615c9094.patch
+
+Fixes build with >=sys-kernel/linux-headers-5.14.
+
+From: Eric Sandeen <esandeen@redhat.com>
+Date: Tue, 3 Aug 2021 10:23:35 -0700
+Subject: [PATCH] fio: remove raw device support
+
+As of Linux kernel commit 603e4922f1c ("remove the raw driver"),
+linux/raw.h is gone, and raw device support no longer exists.
+Because of this, fio can no longer build against the current Linux
+kernel headers.
+
+So, remove raw device support from fio as well.
+
+Signed-off-by: Eric Sandeen <sandeen@redhat.com>
+Signed-off-by: Jens Axboe <axboe@kernel.dk>
+--- a/diskutil.c
++++ b/diskutil.c
+@@ -166,14 +166,10 @@ static int get_device_numbers(char *file_name, int *maj, int *min)
+ if (S_ISBLK(st.st_mode)) {
+ majdev = major(st.st_rdev);
+ mindev = minor(st.st_rdev);
+- } else if (S_ISCHR(st.st_mode)) {
+- majdev = major(st.st_rdev);
+- mindev = minor(st.st_rdev);
+- if (fio_lookup_raw(st.st_rdev, &majdev, &mindev))
+- return -1;
+- } else if (S_ISFIFO(st.st_mode))
++ } else if (S_ISCHR(st.st_mode) ||
++ S_ISFIFO(st.st_mode)) {
+ return -1;
+- else {
++ } else {
+ majdev = major(st.st_dev);
+ mindev = minor(st.st_dev);
+ }
+--- a/fio.1
++++ b/fio.1
+@@ -1700,9 +1700,7 @@ Sets size to something really large and waits for ENOSPC (no space left on
+ device) or EDQUOT (disk quota exceeded)
+ as the terminating condition. Only makes sense with sequential
+ write. For a read workload, the mount point will be filled first then I/O
+-started on the result. This option doesn't make sense if operating on a raw
+-device node, since the size of that is already known by the file system.
+-Additionally, writing beyond end-of-device will not return ENOSPC there.
++started on the result.
+ .SS "I/O engine"
+ .TP
+ .BI ioengine \fR=\fPstr
+--- a/os/os-linux.h
++++ b/os/os-linux.h
+@@ -14,7 +14,6 @@
+ #include <errno.h>
+ #include <sched.h>
+ #include <linux/unistd.h>
+-#include <linux/raw.h>
+ #include <linux/major.h>
+ #include <linux/fs.h>
+ #include <scsi/sg.h>
+@@ -41,7 +40,6 @@
+ #define FIO_HAVE_IOSCHED_SWITCH
+ #define FIO_HAVE_ODIRECT
+ #define FIO_HAVE_HUGETLB
+-#define FIO_HAVE_RAWBIND
+ #define FIO_HAVE_BLKTRACE
+ #define FIO_HAVE_CL_SIZE
+ #define FIO_HAVE_CGROUPS
+@@ -178,36 +176,6 @@ static inline unsigned long long os_phys_mem(void)
+ return (unsigned long long) pages * (unsigned long long) pagesize;
+ }
+
+-static inline int fio_lookup_raw(dev_t dev, int *majdev, int *mindev)
+-{
+- struct raw_config_request rq;
+- int fd;
+-
+- if (major(dev) != RAW_MAJOR)
+- return 1;
+-
+- /*
+- * we should be able to find /dev/rawctl or /dev/raw/rawctl
+- */
+- fd = open("/dev/rawctl", O_RDONLY);
+- if (fd < 0) {
+- fd = open("/dev/raw/rawctl", O_RDONLY);
+- if (fd < 0)
+- return 1;
+- }
+-
+- rq.raw_minor = minor(dev);
+- if (ioctl(fd, RAW_GETBIND, &rq) < 0) {
+- close(fd);
+- return 1;
+- }
+-
+- close(fd);
+- *majdev = rq.block_major;
+- *mindev = rq.block_minor;
+- return 0;
+-}
+-
+ #ifdef O_NOATIME
+ #define FIO_O_NOATIME O_NOATIME
+ #else
+--- a/os/os.h
++++ b/os/os.h
+@@ -157,10 +157,6 @@ extern int fio_cpus_split(os_cpu_mask_t *mask, unsigned int cpu);
+ #define OS_RAND_MAX RAND_MAX
+ #endif
+
+-#ifndef FIO_HAVE_RAWBIND
+-#define fio_lookup_raw(dev, majdev, mindev) 1
+-#endif
+-
+ #ifndef FIO_PREFERRED_ENGINE
+ #define FIO_PREFERRED_ENGINE "psync"
+ #endif
diff --git a/sys-block/fio/fio-3.27-r1.ebuild b/sys-block/fio/fio-3.27-r1.ebuild
new file mode 100644
index 000000000000..21af46927775
--- /dev/null
+++ b/sys-block/fio/fio-3.27-r1.ebuild
@@ -0,0 +1,155 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit python-r1 toolchain-funcs
+
+MY_PV="${PV/_rc/-rc}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="Jens Axboe's Flexible IO tester"
+HOMEPAGE="https://brick.kernel.dk/snaps/"
+SRC_URI="https://brick.kernel.dk/snaps/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="aio curl glusterfs gnuplot gtk io-uring numa python rbd rdma static tcmalloc test zbc zlib"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )
+ gnuplot? ( python )
+ io-uring? ( aio )"
+RESTRICT="!test? ( test )"
+
+BDEPEND="virtual/pkgconfig"
+
+# GTK+:2 does not offer static libaries.
+LIB_DEPEND="aio? ( dev-libs/libaio[static-libs(+)] )
+ curl? (
+ net-misc/curl:=[static-libs(+)]
+ dev-libs/openssl:0=[static-libs(+)]
+ )
+ glusterfs? ( sys-cluster/glusterfs[static-libs(+)] )
+ gtk? ( dev-libs/glib:2[static-libs(+)] )
+ io-uring? ( sys-libs/liburing:=[static-libs(+)] )
+ numa? ( sys-process/numactl[static-libs(+)] )
+ rbd? ( sys-cluster/ceph[static-libs(+)] )
+ rdma? (
+ sys-fabric/libibverbs[static-libs(+)]
+ sys-fabric/librdmacm[static-libs(+)]
+ )
+ tcmalloc? ( dev-util/google-perftools:=[static-libs(+)] )
+ zbc? ( >=sys-block/libzbc-5 )
+ zlib? ( sys-libs/zlib[static-libs(+)] )"
+RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )
+ gtk? ( x11-libs/gtk+:2 )"
+DEPEND="${RDEPEND}
+ static? ( ${LIB_DEPEND} )
+ test? ( dev-util/cunit )"
+RDEPEND+="
+ python? (
+ ${PYTHON_DEPS}
+ $(python_gen_any_dep 'dev-python/pandas[${PYTHON_USEDEP}]')
+ )
+ gnuplot? ( sci-visualization/gnuplot )"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}"/fio-2.2.13-libmtd.patch
+ # Upstream patch, should be able to drop in the next release
+ "${FILESDIR}"/fio-3.27-drop-raw.patch
+)
+
+python_check_deps() {
+ has_version "dev-python/pandas[${PYTHON_USEDEP}]"
+}
+
+src_prepare() {
+ default
+
+ sed -i '/^DEBUGFLAGS/s: -D_FORTIFY_SOURCE=2::g' Makefile || die
+
+ # Many checks don't have configure flags.
+ sed -i \
+ -e "s:\<pkg-config\>:$(tc-getPKG_CONFIG):" \
+ -e '/if compile_prog "" "-lzbc" "libzbc" *; *then/ '"s::if $(usex zbc true false) ; then:" \
+ -e '/if compile_prog "" "-lz" "zlib" *; *then/ '"s::if $(usex zlib true false) ; then:" \
+ -e '/if compile_prog "" "-laio" "libaio" *; *then/'"s::if $(usex aio true false) ; then:" \
+ -e '/if compile_prog "" "-lcunit" "CUnit" *; *then/'"s::if $(usex test true false) ; then:" \
+ configure || die
+}
+
+src_configure() {
+ chmod g-w "${T}"
+ # not a real configure script
+ # TODO: cuda
+ # TODO: libnbd - not packaged in Gentoo
+ # TODO: pmem - not packaged in Gentoo
+ set -- \
+ ./configure \
+ --disable-optimizations \
+ --extra-cflags="${CFLAGS} ${CPPFLAGS}" \
+ --cc="$(tc-getCC)" \
+ --disable-pmem \
+ $(usex curl '' '--disable-http') \
+ $(usex glusterfs '' '--disable-gfapi') \
+ $(usex gtk '--enable-gfio' '') \
+ $(usex numa '' '--disable-numa') \
+ $(usex rbd '' '--disable-rbd') \
+ $(usex rdma '' '--disable-rdma') \
+ $(usex static '--build-static' '') \
+ $(usex tcmalloc '' '--disable-tcmalloc')
+ echo "$@"
+ "$@" || die 'configure failed'
+}
+
+src_compile() {
+ emake V=1 OPTFLAGS=
+}
+
+src_install() {
+ emake install DESTDIR="${D}" prefix="${EPREFIX}/usr" mandir="${EPREFIX}/usr/share/man"
+
+ local python2_7_files=(
+ "${ED}"/usr/bin/fiologparser_hist.py
+ "${ED}"/usr/bin/fiologparser.py
+ )
+ local python_files=(
+ "${python2_7_files[@]}"
+ "${ED}"/usr/bin/fio_jsonplus_clat2csv
+ )
+ if use python ; then
+ sed -i 's:python2.7:python:g' "${python2_7_files[@]}" || die
+ python_replicate_script "${python2_7_files[@]}"
+ else
+ rm "${python_files[@]}" || die
+ fi
+
+ local gnuplot_python2_7_files=(
+ "${ED}"/usr/bin/fio2gnuplot
+ )
+ local gnuplot_files=(
+ "${gnuplot_python2_7_files[@]}"
+ "${ED}"/usr/bin/fio_generate_plots
+ "${ED}"/usr/share/man/man1/fio_generate_plots.1
+ "${ED}"/usr/share/man/man1/fio2gnuplot.1
+ "${ED}"/usr/share/fio/*.gpm
+ )
+ if use gnuplot ; then
+ sed -i 's:python2.7:python:g' "${gnuplot_python2_7_files[@]}" || die
+ python_replicate_script "${gnuplot_python2_7_files[@]}"
+ else
+ rm "${gnuplot_files[@]}" || die
+ rmdir "${ED}"/usr/share/fio/ || die
+ fi
+
+ # This tool has security/parallel issues -- it hardcodes /tmp/template.fio.
+ rm "${ED}"/usr/bin/genfio || die
+
+ dodoc README REPORTING-BUGS HOWTO
+ docinto examples
+ dodoc examples/*
+}