summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-boot/elilo
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-boot/elilo')
-rw-r--r--sys-boot/elilo/Manifest6
-rw-r--r--sys-boot/elilo/elilo-3.10.ebuild71
-rw-r--r--sys-boot/elilo/elilo-3.12.ebuild71
-rw-r--r--sys-boot/elilo/elilo-3.6_p20060314.ebuild87
-rw-r--r--sys-boot/elilo/files/elilo.conf.sample9
-rw-r--r--sys-boot/elilo/files/elilo.sh-chkspace.patch15
-rw-r--r--sys-boot/elilo/files/elilo.sh-vmm.patch43
-rw-r--r--sys-boot/elilo/metadata.xml8
8 files changed, 310 insertions, 0 deletions
diff --git a/sys-boot/elilo/Manifest b/sys-boot/elilo/Manifest
new file mode 100644
index 000000000000..ebf2b3bb6172
--- /dev/null
+++ b/sys-boot/elilo/Manifest
@@ -0,0 +1,6 @@
+DIST elilo-3.10.tar.gz 210896 SHA256 65d0d7cc31bd0ef6824b9394dbf8991eb850aa4ba2dde1f9302e3da3cb2a4399
+DIST elilo-3.12-source.tar.gz 215125 SHA256 5005534ae972603c65caa8debb2bf3c4a22b895588323bc1b0a7a9f114e030ee
+DIST elilo-nightly_2006-03-14.tgz 168991 SHA256 b5174f1d921212b65f708869ea374e7c3e4e1b0771738b03ae6a1830cb4fe65c
+DIST elilo_3.10-1.diff.gz 26456 SHA256 de81eb071d4c7a3f02c629911cfd95f0fdc8705575df7a596e5630788bbb3643
+DIST elilo_3.12-1.diff.gz 28806 SHA256 26532bdf9a8c3455d12f22c59d1d5d9656dcb432dabd1a80cdbcd010e93305b5
+DIST elilo_3.6-1.diff.gz 14944 SHA256 cc9e3d753823ad1bc50f935017e8b5cdc5d76cac2a37c498c862ef021e0e0073
diff --git a/sys-boot/elilo/elilo-3.10.ebuild b/sys-boot/elilo/elilo-3.10.ebuild
new file mode 100644
index 000000000000..06485c29c45b
--- /dev/null
+++ b/sys-boot/elilo/elilo-3.10.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="Linux boot loader for EFI-based systems such as IA-64"
+HOMEPAGE="http://elilo.sourceforge.net/"
+SRC_URI="mirror://sourceforge/elilo/${P}.tar.gz"
+SRC_URI="${SRC_URI} mirror://debian/pool/main/e/elilo/elilo_3.10-1.diff.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ia64 ~x86"
+IUSE=""
+
+# gnu-efi contains only static libs, so there's no run-time dep on it
+DEPEND=">=sys-boot/gnu-efi-3.0g
+ sys-devel/patch
+ dev-util/patchutils"
+RDEPEND="sys-boot/efibootmgr
+ sys-fs/dosfstools"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ ebegin Applying ../*.diff
+ # Using epatch on this is annoying because it wants to create the elilo-3.6/
+ # directory. Since all the files are new, it doesn't know better.
+ filterdiff -p1 -i debian/\* ../*.diff | patch -s -p1
+ eend $? || return
+
+ # Now Gentooize it
+ sed -i "
+ 1s:/bin/sh:/bin/bash:;
+ s/##VERSION##/$PV/;
+ s/Debian GNU\//Gentoo /g;
+ s/Debian/Gentoo/g;
+ s/debian/gentoo/g;
+ s/dpkg --print-installation-architecture/uname -m/" debian/elilo.sh
+}
+
+src_compile() {
+ local iarch
+ case $(tc-arch) in
+ ia64) iarch=ia64 ;;
+ x86) iarch=ia32 ;;
+ amd64) iarch=x86_64 ;;
+ *) die "unknown architecture: $(tc-arch)" ;;
+ esac
+
+ # "prefix" on the next line specifies where to find gcc, as, ld,
+ # etc. It's not the usual meaning of "prefix". By blanking it we
+ # allow PATH to be searched.
+ emake -j1 prefix= CC="$(tc-getCC)" ARCH=${iarch} || die "emake failed"
+}
+
+src_install() {
+ exeinto /usr/lib/elilo
+ doexe elilo.efi || die "elilo.efi failed"
+
+ newsbin debian/elilo.sh elilo || die "elilo failed"
+ dosbin tools/eliloalt || die "eliloalt failed"
+
+ insinto /etc
+ newins "${FILESDIR}"/elilo.conf.sample elilo.conf
+
+ dodoc docs/* "${FILESDIR}"/elilo.conf.sample
+ doman debian/*.[0-9]
+}
diff --git a/sys-boot/elilo/elilo-3.12.ebuild b/sys-boot/elilo/elilo-3.12.ebuild
new file mode 100644
index 000000000000..d56f2d60422e
--- /dev/null
+++ b/sys-boot/elilo/elilo-3.12.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="Linux boot loader for EFI-based systems such as IA-64"
+HOMEPAGE="http://elilo.sourceforge.net/"
+SRC_URI="mirror://sourceforge/elilo/${P}-source.tar.gz"
+SRC_URI="${SRC_URI} mirror://debian/pool/main/e/elilo/elilo_3.12-1.diff.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ia64 ~x86"
+IUSE=""
+
+# gnu-efi contains only static libs, so there's no run-time dep on it
+DEPEND=">=sys-boot/gnu-efi-3.0g
+ sys-devel/patch
+ dev-util/patchutils"
+RDEPEND="sys-boot/efibootmgr
+ sys-fs/dosfstools"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ ebegin Applying ../*.diff
+ # Using epatch on this is annoying because it wants to create the elilo-3.6/
+ # directory. Since all the files are new, it doesn't know better.
+ filterdiff -p1 -i debian/\* ../*.diff | patch -s -p1
+ eend $? || return
+
+ # Now Gentooize it
+ sed -i "
+ 1s:/bin/sh:/bin/bash:;
+ s/##VERSION##/$PV/;
+ s/Debian GNU\//Gentoo /g;
+ s/Debian/Gentoo/g;
+ s/debian/gentoo/g;
+ s/dpkg --print-architecture/uname -m/" debian/elilo.sh
+}
+
+src_compile() {
+ local iarch
+ case $(tc-arch) in
+ ia64) iarch=ia64 ;;
+ x86) iarch=ia32 ;;
+ amd64) iarch=x86_64 ;;
+ *) die "unknown architecture: $(tc-arch)" ;;
+ esac
+
+ # "prefix" on the next line specifies where to find gcc, as, ld,
+ # etc. It's not the usual meaning of "prefix". By blanking it we
+ # allow PATH to be searched.
+ emake -j1 prefix= CC="$(tc-getCC)" ARCH=${iarch} || die "emake failed"
+}
+
+src_install() {
+ exeinto /usr/lib/elilo
+ doexe elilo.efi || die "elilo.efi failed"
+
+ newsbin debian/elilo.sh elilo || die "elilo failed"
+ dosbin tools/eliloalt || die "eliloalt failed"
+
+ insinto /etc
+ newins "${FILESDIR}"/elilo.conf.sample elilo.conf
+
+ dodoc docs/* "${FILESDIR}"/elilo.conf.sample
+ doman debian/*.[0-9]
+}
diff --git a/sys-boot/elilo/elilo-3.6_p20060314.ebuild b/sys-boot/elilo/elilo-3.6_p20060314.ebuild
new file mode 100644
index 000000000000..ea7593c0ce03
--- /dev/null
+++ b/sys-boot/elilo/elilo-3.6_p20060314.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="Linux boot loader for EFI-based systems such as IA-64"
+HOMEPAGE="http://elilo.sourceforge.net/"
+if [[ $PV == *_p* ]] ; then
+ MY_P=${PV#*_p}
+ MY_P=${PN}-nightly_${MY_P:0:4}-${MY_P:4:2}-${MY_P:6:2}
+ SRC_URI="http://elilo.sourceforge.net/nightlies/${MY_P}.tgz"
+ S=${WORKDIR}/elilo
+else
+ MY_P=${P}
+ SRC_URI="mirror://sourceforge/elilo/${P}.src.tgz"
+fi
+SRC_URI="${SRC_URI} mirror://debian/pool/main/e/elilo/elilo_3.6-1.diff.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="ia64"
+IUSE=""
+
+# gnu-efi contains only static libs, so there's no run-time dep on it
+DEPEND=">=sys-boot/gnu-efi-3.0
+ sys-devel/patch
+ dev-util/patchutils"
+RDEPEND="sys-boot/efibootmgr
+ sys-fs/dosfstools"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ ebegin Applying ../*.diff
+ # Using epatch on this is annoying because it wants to create the elilo-3.6/
+ # directory. Since all the files are new, it doesn't know better.
+ filterdiff -p1 -i debian/\* ../*.diff | patch -s -p1
+ eend $? || return
+
+ # Add patch for vmm support, from
+ # http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=350185
+ epatch "${FILESDIR}"/elilo.sh-vmm.patch
+
+ # Don't count files twice when summing bytesneeded
+ epatch "${FILESDIR}"/elilo.sh-chkspace.patch
+
+ # Now Gentooize it
+ sed -i "
+ 1s/sh/bash/;
+ s/##VERSION##/$PV/;
+ s/Debian GNU\//Gentoo /g;
+ s/Debian/Gentoo/g;
+ s/debian/gentoo/g;
+ s/dpkg --print-installation-architecture/uname -m/" debian/elilo.sh
+}
+
+src_compile() {
+ local iarch
+ case $(tc-arch) in
+ ia64) iarch=ia64 ;;
+ x86) iarch=ia32 ;;
+ *) die "unknown architecture: $(tc-arch)" ;;
+ esac
+
+ # "prefix" on the next line specifies where to find gcc, as, ld,
+ # etc. It's not the usual meaning of "prefix". By blanking it we
+ # allow PATH to be searched.
+ emake -j1 prefix= CC="$(tc-getCC)" ARCH=${iarch} || die "emake failed"
+}
+
+src_install() {
+ exeinto /usr/lib/elilo
+ doexe elilo.efi || die "elilo.efi failed"
+
+ newsbin debian/elilo.sh elilo || die "elilo failed"
+ dosbin tools/eliloalt || die "eliloalt failed"
+
+ insinto /etc
+ newins "${FILESDIR}"/elilo.conf.sample elilo.conf
+
+ dodoc docs/* "${FILESDIR}"/elilo.conf.sample
+ doman debian/*.[0-9]
+}
diff --git a/sys-boot/elilo/files/elilo.conf.sample b/sys-boot/elilo/files/elilo.conf.sample
new file mode 100644
index 000000000000..ed97975c69d7
--- /dev/null
+++ b/sys-boot/elilo/files/elilo.conf.sample
@@ -0,0 +1,9 @@
+boot=/dev/sda1
+install=/usr/lib/elilo/elilo.efi
+delay=20
+default=gentoo
+
+image=/boot/kernel-2.6.12-gentoo-r6
+ label=gentoo
+ root=/dev/sda3
+ read-only
diff --git a/sys-boot/elilo/files/elilo.sh-chkspace.patch b/sys-boot/elilo/files/elilo.sh-chkspace.patch
new file mode 100644
index 000000000000..710780e8da6c
--- /dev/null
+++ b/sys-boot/elilo/files/elilo.sh-chkspace.patch
@@ -0,0 +1,15 @@
+Don't count duplicate files twice when summing bytesneeded
+
+--- elilo/debian/elilo.sh.chkspace 2006-03-16 07:53:00.000000000 -0500
++++ elilo/debian/elilo.sh 2006-03-16 07:53:27.000000000 -0500
+@@ -580,7 +580,9 @@
+ sed 's/.*=[[:space:]]*//' | grep -v ':'`
+ vmmfiles=`grep '^[[:space:]]*vmm[[:space:]]*=' $bootconf | \
+ sed 's/.*=[[:space:]]*//' | grep -v ':'`
+- bytesneeded=`cat $imagefiles $initrdfiles $vmmfiles 2>/dev/null | wc -c`
++ allfiles=`for f in $imagefiles $initrdfiles $install $bootconf; do \
++ echo $f; done | sort -u`
++ bytesneeded=`cat $allfiles 2>/dev/null | wc -c`
+ # convert to KB, allowing 5% overhead
+ kbneeded=$(( bytesneeded / 1024 + bytesneeded / 20480 ))
+ kbavailable=$(df -P -k $TARGET | sed -n "s|^$boot[[:space:]]\+[0-9]\+[[:space:]]\+[0-9]\+[[:space:]]\+\([0-9]\+\).*$|\1|p")
diff --git a/sys-boot/elilo/files/elilo.sh-vmm.patch b/sys-boot/elilo/files/elilo.sh-vmm.patch
new file mode 100644
index 000000000000..294eb03b2226
--- /dev/null
+++ b/sys-boot/elilo/files/elilo.sh-vmm.patch
@@ -0,0 +1,43 @@
+Patch from Alex Williamson in
+http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=350185 support of vmm= in the
+elilo script
+
+--- elilo/debian/elilo.sh.novmm 2006-03-16 07:49:19.000000000 -0500
++++ elilo/debian/elilo.sh 2006-03-16 07:48:47.000000000 -0500
+@@ -364,6 +364,8 @@
+ sed 's/^image[[:space:]]*=[[:space:]]*//' | grep -v ':'`
+ initrdfiles=`grep '^[[:space:]]*initrd[[:space:]]*=' $bootconf | \
+ sed 's/.*=[[:space:]]*//' | grep -v ':'`
++ vmmfiles=`grep '^[[:space:]]*vmm[[:space:]]*=' $bootconf | \
++ sed 's/.*=[[:space:]]*//' | grep -v ':'`
+
+ ## Point of no return, removing the old EFI/debian tree
+ rm -rf $TARGET/$EFIROOT
+@@ -398,6 +400,7 @@
+ -e "s|\t| |g" \
+ -e "s|\(^image[[:space:]]*=[[:space:]]*\)\([^:]*\)$|\1$EFIROOT\2|" \
+ -e "s|\(^[[:space:]]*initrd[[:space:]]*=[[:space:]]*\)\([^:]*\)$|\1$EFIROOT\2|" \
++ -e "s|\(^[[:space:]]*vmm[[:space:]]*=[[:space:]]*\)\([^:]*\)$|\1$EFIROOT\2|" \
+ < "$bootconf" > "$TARGET/$EFIROOT/$CFFILE"
+ if [ $? != 0 ] ; then
+ echo 1>&2 "$PRG: An error occured while writing to $boot"
+@@ -406,7 +409,7 @@
+
+ [ "$DEBUG" = 1 ] && echo "----" && cat "$TARGET/$EFIROOT/$CFFILE" && echo "----"
+
+- for i in $imagefiles $initrdfiles; do
++ for i in $imagefiles $initrdfiles $vmmfiles; do
+ [ "$VERBOSE" = 1 ] && echo "$PRG: Installing $i on $boot..."
+ if [ -f $i ]; then
+ mkdir -p `dirname "$TARGET/$EFIROOT/$i"`
+@@ -575,7 +578,9 @@
+ sed 's/^image[[:space:]]*=[[:space:]]*//' | grep -v ':'`
+ initrdfiles=`grep '^[[:space:]]*initrd[[:space:]]*=' $bootconf | \
+ sed 's/.*=[[:space:]]*//' | grep -v ':'`
+- bytesneeded=`cat $imagefiles $initrdfiles $install $bootconf 2>/dev/null | wc -c`
++ vmmfiles=`grep '^[[:space:]]*vmm[[:space:]]*=' $bootconf | \
++ sed 's/.*=[[:space:]]*//' | grep -v ':'`
++ bytesneeded=`cat $imagefiles $initrdfiles $vmmfiles 2>/dev/null | wc -c`
+ # convert to KB, allowing 5% overhead
+ kbneeded=$(( bytesneeded / 1024 + bytesneeded / 20480 ))
+ kbavailable=$(df -P -k $TARGET | sed -n "s|^$boot[[:space:]]\+[0-9]\+[[:space:]]\+[0-9]\+[[:space:]]\+\([0-9]\+\).*$|\1|p")
diff --git a/sys-boot/elilo/metadata.xml b/sys-boot/elilo/metadata.xml
new file mode 100644
index 000000000000..9b47aaca752f
--- /dev/null
+++ b/sys-boot/elilo/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ia64</herd>
+ <upstream>
+ <remote-id type="sourceforge">elilo</remote-id>
+ </upstream>
+</pkgmetadata>