summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBiosias <jakub@gdos.sk>2024-08-27 22:50:42 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-08-28 09:38:41 +0200
commitf4eef50f627f344978f566025d4bee7137ff51aa (patch)
tree72135dc8fcaa64276b82474d899db745e4e7adc4 /sys-boot
parentsys-boot/uefi-mkconfig: drop 1.6, 2.1 (diff)
downloadgentoo-f4eef50f627f344978f566025d4bee7137ff51aa.tar.gz
gentoo-f4eef50f627f344978f566025d4bee7137ff51aa.tar.bz2
gentoo-f4eef50f627f344978f566025d4bee7137ff51aa.zip
sys-boot/uefi-mkconfig: add 2.3
Signed-off-by: Biosias <jakub@gdos.sk> Closes: https://github.com/gentoo/gentoo/pull/38308 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/uefi-mkconfig/Manifest1
-rw-r--r--sys-boot/uefi-mkconfig/uefi-mkconfig-2.3.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/sys-boot/uefi-mkconfig/Manifest b/sys-boot/uefi-mkconfig/Manifest
index da37f9ec7d38..e9eb42816478 100644
--- a/sys-boot/uefi-mkconfig/Manifest
+++ b/sys-boot/uefi-mkconfig/Manifest
@@ -1 +1,2 @@
DIST uefi-mkconfig-2.2.tar.gz 10176 BLAKE2B 7078c23d39dc4e6b80785502c0d186ec1c8ca4ad4b758bcfdf4b74df38e47cef23952e5139d185a9b2b1253cd69f018145c63254f3a421952c70371e33fb1911 SHA512 5489aacc869afb57dc4d48deba4306b141ea08fa5763b8486f156b3b01aecf987f7927b70e7acbb1abe9e145b1d1d4ef57cd93e12d78bec10cc9e61a37ccf02c
+DIST uefi-mkconfig-2.3.tar.gz 10295 BLAKE2B cae2301b1c181f87efbb47fbb393184ed383d763932999719223a298062cd802c318aeb9a1e4571483fe872b31ee27c86186a1200531d038e4ffe867ac683361 SHA512 730546552739db386249e0f86bce029ccb2695bd4b065326ae91ae92ab350ee387e46b661514b80728e609aa851a78efdda97a86fd7418c6f0044341c393c452
diff --git a/sys-boot/uefi-mkconfig/uefi-mkconfig-2.3.ebuild b/sys-boot/uefi-mkconfig/uefi-mkconfig-2.3.ebuild
new file mode 100644
index 000000000000..8b272798d1ff
--- /dev/null
+++ b/sys-boot/uefi-mkconfig/uefi-mkconfig-2.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info optfeature
+
+DESCRIPTION="Automatic management of UEFI entries"
+HOMEPAGE="https://github.com/Biosias/uefi-mkconfig"
+SRC_URI="https://github.com/Biosias/uefi-mkconfig/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ app-shells/bash
+ sys-boot/efibootmgr
+"
+
+CONFIG_CHECK="EFI_STUB"
+
+src_install() {
+ dobin uefi-mkconfig
+ einstalldocs
+}
+
+pkg_postinst() {
+ elog "uefi-mkconfig: Automatic management of UEFI entries"
+ elog "Run uefi-mkconfig while having all efi partitions mounted"
+ elog "Please use with care, this package was tested on a limited number of machines"
+ elog "Some problems may arise due to different implementations of UEFI"
+ elog "Don't forget to add kernel commands to the configuration file before using this package!"
+ elog
+ optfeature "Add UEFI entries on kernel installation " \ "sys-kernel/installkernel[-systemd,efistub]"
+}