summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-05-05 22:46:02 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-05-05 22:46:13 +0100
commitd2bd0ad359f6b217b1e8c1da7956eb54addfa355 (patch)
tree1dd594aded1a7939aa2ab5c04e219018f0793084 /sys-cluster/corosync
parentnet-libs/nodejs: Version 14.2.0 (diff)
downloadgentoo-d2bd0ad359f6b217b1e8c1da7956eb54addfa355.tar.gz
gentoo-d2bd0ad359f6b217b1e8c1da7956eb54addfa355.tar.bz2
gentoo-d2bd0ad359f6b217b1e8c1da7956eb54addfa355.zip
sys-cluster/corosync: drop invalid version check, bug #705276
'if [[ ${REPLACING_VERSIONS} < 2.0 ]]; then' uses lexicographical version compare. That should be ver_cmp version compare or similar. As it's a guard against non-existent version let's just drop the ewarn. Closes: https://bugs.gentoo.org/705276 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'sys-cluster/corosync')
-rw-r--r--sys-cluster/corosync/corosync-2.3.5.ebuild11
-rw-r--r--sys-cluster/corosync/corosync-2.4.2.ebuild11
2 files changed, 0 insertions, 22 deletions
diff --git a/sys-cluster/corosync/corosync-2.3.5.ebuild b/sys-cluster/corosync/corosync-2.3.5.ebuild
index 3e4bf6a0f565..3485dedb6bb1 100644
--- a/sys-cluster/corosync/corosync-2.3.5.ebuild
+++ b/sys-cluster/corosync/corosync-2.3.5.ebuild
@@ -73,14 +73,3 @@ src_install() {
use static-libs || rm -rf "${D}"/usr/$(get_libdir)/*.{,l}a || die
}
-
-pkg_postinst() {
- if [[ ${REPLACING_VERSIONS} < 2.0 ]]; then
- ewarn "!! IMPORTANT !!"
- ewarn " "
- ewarn "Migrating from a previous version of corosync can be dangerous !"
- ewarn " "
- ewarn "Make sure you backup your cluster configuration before proceeding"
- ewarn " "
- fi
-}
diff --git a/sys-cluster/corosync/corosync-2.4.2.ebuild b/sys-cluster/corosync/corosync-2.4.2.ebuild
index 49840bb0216f..bdea670c8da2 100644
--- a/sys-cluster/corosync/corosync-2.4.2.ebuild
+++ b/sys-cluster/corosync/corosync-2.4.2.ebuild
@@ -69,14 +69,3 @@ src_install() {
use static-libs || rm -rf "${D}"/usr/$(get_libdir)/*.{,l}a || die
}
-
-pkg_postinst() {
- if [[ ${REPLACING_VERSIONS} < 2.0 ]]; then
- ewarn "!! IMPORTANT !!"
- ewarn " "
- ewarn "Migrating from a previous version of corosync can be dangerous !"
- ewarn " "
- ewarn "Make sure you backup your cluster configuration before proceeding"
- ewarn " "
- fi
-}