summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKurt Kanzenbach <kurt@kmk-computers.de>2020-03-27 12:45:47 +0100
committerJoonas Niilola <juippis@gentoo.org>2020-03-28 16:21:17 +0200
commit4dca60e502225ecc15d164779cd415c75ed4341f (patch)
treee084f7f8b33d28c162dc76eaf614c4d7e6693c07 /sys-cluster/hpx
parentsys-cluster/hpx: Add MPI support (diff)
downloadgentoo-4dca60e502225ecc15d164779cd415c75ed4341f.tar.gz
gentoo-4dca60e502225ecc15d164779cd415c75ed4341f.tar.bz2
gentoo-4dca60e502225ecc15d164779cd415c75ed4341f.zip
sys-cluster/hpx: Sync live ebuild
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Kurt Kanzenbach <kurt@kmk-computers.de> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-cluster/hpx')
-rw-r--r--sys-cluster/hpx/hpx-9999.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/sys-cluster/hpx/hpx-9999.ebuild b/sys-cluster/hpx/hpx-9999.ebuild
index 5abc3de483fb..25019566f392 100644
--- a/sys-cluster/hpx/hpx-9999.ebuild
+++ b/sys-cluster/hpx/hpx-9999.ebuild
@@ -19,7 +19,7 @@ HOMEPAGE="https://stellar.cct.lsu.edu/tag/hpx/"
SLOT="0"
LICENSE="Boost-1.0"
-IUSE="doc examples jemalloc papi +perftools tbb test"
+IUSE="doc examples jemalloc mpi papi +perftools tbb test"
RESTRICT="!test? ( test )"
REQUIRED_USE="
@@ -45,6 +45,7 @@ RDEPEND="
dev-libs/boost:=
sys-apps/hwloc
sys-libs/zlib
+ mpi? ( virtual/mpi )
papi? ( dev-libs/papi )
perftools? ( dev-util/google-perftools )
tbb? ( dev-cpp/tbb )
@@ -77,6 +78,7 @@ src_configure() {
local mycmakeargs=(
-DHPX_WITH_EXAMPLES=OFF
-DHPX_WITH_DOCUMENTATION=$(usex doc)
+ -DHPX_WITH_PARCELPORT_MPI=$(usex mpi)
-DHPX_WITH_PAPI=$(usex papi)
-DHPX_WITH_GOOGLE_PERFTOOLS=$(usex perftools)
-DBUILD_TESTING=$(usex test)