summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-03-26 12:42:08 +0100
committerDavid Seifert <soap@gentoo.org>2021-03-26 12:42:08 +0100
commit4cf4b5fe7683285d3e8d46b08f004fba85907865 (patch)
tree3e387bc477ac8d95e70fa0e902059dc02534d6a7 /sys-devel/bmake/files
parentmedia-fonts/umeplus-fonts: Stabilize 20180604 ALLARCHES, #777576 (diff)
downloadgentoo-4cf4b5fe7683285d3e8d46b08f004fba85907865.tar.gz
gentoo-4cf4b5fe7683285d3e8d46b08f004fba85907865.tar.bz2
gentoo-4cf4b5fe7683285d3e8d46b08f004fba85907865.zip
sys-devel/bmake: Patch the default lib.mk rule
* Bmake ships default mk rules, and lib.mk containes default LD_shared variable which in turn creates naming problems when we build libraries on Linux, so we have to fix LD_shared to prevent that Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sys-devel/bmake/files')
-rw-r--r--sys-devel/bmake/files/bmake-20210206-lib-mk.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/sys-devel/bmake/files/bmake-20210206-lib-mk.patch b/sys-devel/bmake/files/bmake-20210206-lib-mk.patch
new file mode 100644
index 000000000000..5f860b6f15aa
--- /dev/null
+++ b/sys-devel/bmake/files/bmake-20210206-lib-mk.patch
@@ -0,0 +1,11 @@
+--- a/mk/lib.mk
++++ b/mk/lib.mk
+@@ -170,7 +170,7 @@ LD_solib= lib${LIB}_pic.a
+ .elif ${TARGET_OSNAME} == "Linux"
+ SHLIB_LD = ${CC}
+ # this is ambiguous of course
+-LD_shared=-shared -Wl,"-soname lib${LIB}.so.${SHLIB_MAJOR}"
++LD_shared=-shared -Wl,-soname,lib${LIB}.so.${SHLIB_MAJOR}
+ LD_solib= -Wl,--whole-archive lib${LIB}_pic.a -Wl,--no-whole-archive
+ .if ${COMPILER_TYPE} == "gcc"
+ # Linux uses GNU ld, which is a multi-pass linker