summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-10-18 16:15:16 +0100
committerSam James <sam@gentoo.org>2023-10-18 16:16:21 +0100
commitcf4bad70939bdd18646d47fa733e99c44172ae00 (patch)
treed611ae03c1a4eeecd175ba0b28584e1e1c171d23 /sys-devel/clang-common
parentnet-misc/yt-dlp: stabilize 2023.10.13 for ALLARCHES (diff)
downloadgentoo-cf4bad70939bdd18646d47fa733e99c44172ae00.tar.gz
gentoo-cf4bad70939bdd18646d47fa733e99c44172ae00.tar.bz2
gentoo-cf4bad70939bdd18646d47fa733e99c44172ae00.zip
sys-devel/clang-common: drop USE=stricter for >=16
For >=16, this doesn't have much value apart from deprecated-non-prototype. It ends up confusing people more than anything else. >=16 already has strict enough defaults for the bits which matter. See https://wiki.gentoo.org/wiki/Modern_C_porting as usual for background. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-devel/clang-common')
-rw-r--r--sys-devel/clang-common/clang-common-16.0.6-r2.ebuild24
-rw-r--r--sys-devel/clang-common/clang-common-17.0.1.ebuild24
-rw-r--r--sys-devel/clang-common/clang-common-17.0.2.ebuild24
-rw-r--r--sys-devel/clang-common/clang-common-17.0.3.9999.ebuild24
-rw-r--r--sys-devel/clang-common/clang-common-17.0.3.ebuild24
-rw-r--r--sys-devel/clang-common/clang-common-18.0.0.9999.ebuild24
-rw-r--r--sys-devel/clang-common/clang-common-18.0.0_pre20230925.ebuild24
-rw-r--r--sys-devel/clang-common/clang-common-18.0.0_pre20231002.ebuild24
-rw-r--r--sys-devel/clang-common/clang-common-18.0.0_pre20231013.ebuild24
9 files changed, 9 insertions, 207 deletions
diff --git a/sys-devel/clang-common/clang-common-16.0.6-r2.ebuild b/sys-devel/clang-common/clang-common-16.0.6-r2.ebuild
index bdbbd9cb2892..88fce05309fd 100644
--- a/sys-devel/clang-common/clang-common-16.0.6-r2.ebuild
+++ b/sys-devel/clang-common/clang-common-16.0.6-r2.ebuild
@@ -13,7 +13,7 @@ SLOT="0"
KEYWORDS="amd64 arm arm64 ~loong ppc ppc64 ~riscv sparc x86 ~amd64-linux ~ppc-macos ~x64-macos"
IUSE="
default-compiler-rt default-libcxx default-lld llvm-libunwind
- hardened stricter
+ hardened
"
PDEPEND="
@@ -146,28 +146,6 @@ src_install() {
EOF
fi
- if use stricter; then
- newins - gentoo-stricter.cfg <<-EOF
- # This file increases the strictness of older clang versions
- # to match the newest upstream version.
-
- # clang-16 defaults
- -Werror=implicit-function-declaration
- -Werror=implicit-int
- -Werror=incompatible-function-pointer-types
-
- # constructs banned by C2x
- -Werror=deprecated-non-prototype
-
- # deprecated but large blast radius
- #-Werror=strict-prototypes
- EOF
-
- cat >> "${ED}/etc/clang/gentoo-common.cfg" <<-EOF || die
- @gentoo-stricter.cfg
- EOF
- fi
-
local tool
for tool in clang{,++,-cpp}; do
newins - "${tool}.cfg" <<-EOF
diff --git a/sys-devel/clang-common/clang-common-17.0.1.ebuild b/sys-devel/clang-common/clang-common-17.0.1.ebuild
index 1cbfe719be70..696ae8ee4996 100644
--- a/sys-devel/clang-common/clang-common-17.0.1.ebuild
+++ b/sys-devel/clang-common/clang-common-17.0.1.ebuild
@@ -13,7 +13,7 @@ SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos"
IUSE="
default-compiler-rt default-libcxx default-lld llvm-libunwind
- hardened stricter
+ hardened
"
PDEPEND="
@@ -202,28 +202,6 @@ src_install() {
EOF
fi
- if use stricter; then
- newins - gentoo-stricter.cfg <<-EOF
- # This file increases the strictness of older clang versions
- # to match the newest upstream version.
-
- # clang-16 defaults
- -Werror=implicit-function-declaration
- -Werror=implicit-int
- -Werror=incompatible-function-pointer-types
-
- # constructs banned by C2x
- -Werror=deprecated-non-prototype
-
- # deprecated but large blast radius
- #-Werror=strict-prototypes
- EOF
-
- cat >> "${ED}/etc/clang/gentoo-common.cfg" <<-EOF || die
- @gentoo-stricter.cfg
- EOF
- fi
-
# We only install config files for supported ABIs because unprefixed tools
# might be used for crosscompilation where e.g. PIE may not be supported.
# See bug #912237 and bug #901247.
diff --git a/sys-devel/clang-common/clang-common-17.0.2.ebuild b/sys-devel/clang-common/clang-common-17.0.2.ebuild
index 1cbfe719be70..696ae8ee4996 100644
--- a/sys-devel/clang-common/clang-common-17.0.2.ebuild
+++ b/sys-devel/clang-common/clang-common-17.0.2.ebuild
@@ -13,7 +13,7 @@ SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos"
IUSE="
default-compiler-rt default-libcxx default-lld llvm-libunwind
- hardened stricter
+ hardened
"
PDEPEND="
@@ -202,28 +202,6 @@ src_install() {
EOF
fi
- if use stricter; then
- newins - gentoo-stricter.cfg <<-EOF
- # This file increases the strictness of older clang versions
- # to match the newest upstream version.
-
- # clang-16 defaults
- -Werror=implicit-function-declaration
- -Werror=implicit-int
- -Werror=incompatible-function-pointer-types
-
- # constructs banned by C2x
- -Werror=deprecated-non-prototype
-
- # deprecated but large blast radius
- #-Werror=strict-prototypes
- EOF
-
- cat >> "${ED}/etc/clang/gentoo-common.cfg" <<-EOF || die
- @gentoo-stricter.cfg
- EOF
- fi
-
# We only install config files for supported ABIs because unprefixed tools
# might be used for crosscompilation where e.g. PIE may not be supported.
# See bug #912237 and bug #901247.
diff --git a/sys-devel/clang-common/clang-common-17.0.3.9999.ebuild b/sys-devel/clang-common/clang-common-17.0.3.9999.ebuild
index e3a7af989d05..1367bb7cefae 100644
--- a/sys-devel/clang-common/clang-common-17.0.3.9999.ebuild
+++ b/sys-devel/clang-common/clang-common-17.0.3.9999.ebuild
@@ -13,7 +13,7 @@ SLOT="0"
KEYWORDS=""
IUSE="
default-compiler-rt default-libcxx default-lld llvm-libunwind
- hardened stricter
+ hardened
"
PDEPEND="
@@ -202,28 +202,6 @@ src_install() {
EOF
fi
- if use stricter; then
- newins - gentoo-stricter.cfg <<-EOF
- # This file increases the strictness of older clang versions
- # to match the newest upstream version.
-
- # clang-16 defaults
- -Werror=implicit-function-declaration
- -Werror=implicit-int
- -Werror=incompatible-function-pointer-types
-
- # constructs banned by C2x
- -Werror=deprecated-non-prototype
-
- # deprecated but large blast radius
- #-Werror=strict-prototypes
- EOF
-
- cat >> "${ED}/etc/clang/gentoo-common.cfg" <<-EOF || die
- @gentoo-stricter.cfg
- EOF
- fi
-
# We only install config files for supported ABIs because unprefixed tools
# might be used for crosscompilation where e.g. PIE may not be supported.
# See bug #912237 and bug #901247.
diff --git a/sys-devel/clang-common/clang-common-17.0.3.ebuild b/sys-devel/clang-common/clang-common-17.0.3.ebuild
index 1cbfe719be70..696ae8ee4996 100644
--- a/sys-devel/clang-common/clang-common-17.0.3.ebuild
+++ b/sys-devel/clang-common/clang-common-17.0.3.ebuild
@@ -13,7 +13,7 @@ SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos"
IUSE="
default-compiler-rt default-libcxx default-lld llvm-libunwind
- hardened stricter
+ hardened
"
PDEPEND="
@@ -202,28 +202,6 @@ src_install() {
EOF
fi
- if use stricter; then
- newins - gentoo-stricter.cfg <<-EOF
- # This file increases the strictness of older clang versions
- # to match the newest upstream version.
-
- # clang-16 defaults
- -Werror=implicit-function-declaration
- -Werror=implicit-int
- -Werror=incompatible-function-pointer-types
-
- # constructs banned by C2x
- -Werror=deprecated-non-prototype
-
- # deprecated but large blast radius
- #-Werror=strict-prototypes
- EOF
-
- cat >> "${ED}/etc/clang/gentoo-common.cfg" <<-EOF || die
- @gentoo-stricter.cfg
- EOF
- fi
-
# We only install config files for supported ABIs because unprefixed tools
# might be used for crosscompilation where e.g. PIE may not be supported.
# See bug #912237 and bug #901247.
diff --git a/sys-devel/clang-common/clang-common-18.0.0.9999.ebuild b/sys-devel/clang-common/clang-common-18.0.0.9999.ebuild
index baa1dffade6a..231f4111793f 100644
--- a/sys-devel/clang-common/clang-common-18.0.0.9999.ebuild
+++ b/sys-devel/clang-common/clang-common-18.0.0.9999.ebuild
@@ -13,7 +13,7 @@ SLOT="0"
KEYWORDS=""
IUSE="
default-compiler-rt default-libcxx default-lld llvm-libunwind
- hardened stricter
+ hardened
"
PDEPEND="
@@ -202,28 +202,6 @@ src_install() {
EOF
fi
- if use stricter; then
- newins - gentoo-stricter.cfg <<-EOF
- # This file increases the strictness of older clang versions
- # to match the newest upstream version.
-
- # clang-16 defaults
- -Werror=implicit-function-declaration
- -Werror=implicit-int
- -Werror=incompatible-function-pointer-types
-
- # constructs banned by C2x
- -Werror=deprecated-non-prototype
-
- # deprecated but large blast radius
- #-Werror=strict-prototypes
- EOF
-
- cat >> "${ED}/etc/clang/gentoo-common.cfg" <<-EOF || die
- @gentoo-stricter.cfg
- EOF
- fi
-
# We only install config files for supported ABIs because unprefixed tools
# might be used for crosscompilation where e.g. PIE may not be supported.
# See bug #912237 and bug #901247.
diff --git a/sys-devel/clang-common/clang-common-18.0.0_pre20230925.ebuild b/sys-devel/clang-common/clang-common-18.0.0_pre20230925.ebuild
index baa1dffade6a..231f4111793f 100644
--- a/sys-devel/clang-common/clang-common-18.0.0_pre20230925.ebuild
+++ b/sys-devel/clang-common/clang-common-18.0.0_pre20230925.ebuild
@@ -13,7 +13,7 @@ SLOT="0"
KEYWORDS=""
IUSE="
default-compiler-rt default-libcxx default-lld llvm-libunwind
- hardened stricter
+ hardened
"
PDEPEND="
@@ -202,28 +202,6 @@ src_install() {
EOF
fi
- if use stricter; then
- newins - gentoo-stricter.cfg <<-EOF
- # This file increases the strictness of older clang versions
- # to match the newest upstream version.
-
- # clang-16 defaults
- -Werror=implicit-function-declaration
- -Werror=implicit-int
- -Werror=incompatible-function-pointer-types
-
- # constructs banned by C2x
- -Werror=deprecated-non-prototype
-
- # deprecated but large blast radius
- #-Werror=strict-prototypes
- EOF
-
- cat >> "${ED}/etc/clang/gentoo-common.cfg" <<-EOF || die
- @gentoo-stricter.cfg
- EOF
- fi
-
# We only install config files for supported ABIs because unprefixed tools
# might be used for crosscompilation where e.g. PIE may not be supported.
# See bug #912237 and bug #901247.
diff --git a/sys-devel/clang-common/clang-common-18.0.0_pre20231002.ebuild b/sys-devel/clang-common/clang-common-18.0.0_pre20231002.ebuild
index baa1dffade6a..231f4111793f 100644
--- a/sys-devel/clang-common/clang-common-18.0.0_pre20231002.ebuild
+++ b/sys-devel/clang-common/clang-common-18.0.0_pre20231002.ebuild
@@ -13,7 +13,7 @@ SLOT="0"
KEYWORDS=""
IUSE="
default-compiler-rt default-libcxx default-lld llvm-libunwind
- hardened stricter
+ hardened
"
PDEPEND="
@@ -202,28 +202,6 @@ src_install() {
EOF
fi
- if use stricter; then
- newins - gentoo-stricter.cfg <<-EOF
- # This file increases the strictness of older clang versions
- # to match the newest upstream version.
-
- # clang-16 defaults
- -Werror=implicit-function-declaration
- -Werror=implicit-int
- -Werror=incompatible-function-pointer-types
-
- # constructs banned by C2x
- -Werror=deprecated-non-prototype
-
- # deprecated but large blast radius
- #-Werror=strict-prototypes
- EOF
-
- cat >> "${ED}/etc/clang/gentoo-common.cfg" <<-EOF || die
- @gentoo-stricter.cfg
- EOF
- fi
-
# We only install config files for supported ABIs because unprefixed tools
# might be used for crosscompilation where e.g. PIE may not be supported.
# See bug #912237 and bug #901247.
diff --git a/sys-devel/clang-common/clang-common-18.0.0_pre20231013.ebuild b/sys-devel/clang-common/clang-common-18.0.0_pre20231013.ebuild
index baa1dffade6a..231f4111793f 100644
--- a/sys-devel/clang-common/clang-common-18.0.0_pre20231013.ebuild
+++ b/sys-devel/clang-common/clang-common-18.0.0_pre20231013.ebuild
@@ -13,7 +13,7 @@ SLOT="0"
KEYWORDS=""
IUSE="
default-compiler-rt default-libcxx default-lld llvm-libunwind
- hardened stricter
+ hardened
"
PDEPEND="
@@ -202,28 +202,6 @@ src_install() {
EOF
fi
- if use stricter; then
- newins - gentoo-stricter.cfg <<-EOF
- # This file increases the strictness of older clang versions
- # to match the newest upstream version.
-
- # clang-16 defaults
- -Werror=implicit-function-declaration
- -Werror=implicit-int
- -Werror=incompatible-function-pointer-types
-
- # constructs banned by C2x
- -Werror=deprecated-non-prototype
-
- # deprecated but large blast radius
- #-Werror=strict-prototypes
- EOF
-
- cat >> "${ED}/etc/clang/gentoo-common.cfg" <<-EOF || die
- @gentoo-stricter.cfg
- EOF
- fi
-
# We only install config files for supported ABIs because unprefixed tools
# might be used for crosscompilation where e.g. PIE may not be supported.
# See bug #912237 and bug #901247.