summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2017-03-23 16:09:49 +0100
committerFabian Groffen <grobian@gentoo.org>2017-03-23 16:10:02 +0100
commit754124d7de028fc8c203cf4940b9bcad7e59f5a9 (patch)
tree351c119e89792b5800d1044f9c430225c02e2e5f /sys-devel/libtool/libtool-9999.ebuild
parentsys-apps/prefix-chain-utils: add Cygwin support (diff)
downloadgentoo-754124d7de028fc8c203cf4940b9bcad7e59f5a9.tar.gz
gentoo-754124d7de028fc8c203cf4940b9bcad7e59f5a9.tar.bz2
gentoo-754124d7de028fc8c203cf4940b9bcad7e59f5a9.zip
sys-devel/libtool: add Prefix keywords and patches
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'sys-devel/libtool/libtool-9999.ebuild')
-rw-r--r--sys-devel/libtool/libtool-9999.ebuild24
1 files changed, 20 insertions, 4 deletions
diff --git a/sys-devel/libtool/libtool-9999.ebuild b/sys-devel/libtool/libtool-9999.ebuild
index 22a5d3c10437..c6a8101849e7 100644
--- a/sys-devel/libtool/libtool-9999.ebuild
+++ b/sys-devel/libtool/libtool-9999.ebuild
@@ -5,7 +5,7 @@ EAPI="5"
LIBTOOLIZE="true" #225559
WANT_LIBTOOL="none"
-inherit eutils autotools multilib unpacker
+inherit eutils autotools multilib unpacker prefix
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="git://git.savannah.gnu.org/${PN}.git
@@ -13,7 +13,7 @@ if [[ ${PV} == "9999" ]] ; then
inherit git-r3
else
SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~ppc-aix ~x64-cygwin ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi
DESCRIPTION="A shared library tool for developers"
@@ -46,6 +46,20 @@ src_prepare() {
use vanilla && return 0
epatch "${FILESDIR}"/${PN}-2.4.3-use-linux-version-in-fbsd.patch #109105
+ epatch "${FILESDIR}"/${PN}-2.4.6-mint.patch
+ epatch "${FILESDIR}"/${PN}-2.2.6a-darwin-module-bundle.patch
+ epatch "${FILESDIR}"/${PN}-2.4.6-darwin-use-linux-version.patch
+ if use prefix ; then
+ # seems that libtool has to know about EPREFIX a little bit
+ # better, since it fails to find prefix paths to search libs
+ # from, resulting in some packages building static only, since
+ # libtool is fooled into thinking that libraries are unavailable
+ # (argh...). This could also be fixed by making the gcc wrapper
+ # return the correct result for -print-search-dirs (doesn't
+ # include prefix dirs ...).
+ epatch "${FILESDIR}"/${PN}-2.2.10-eprefix.patch
+ eprefixify m4/libtool.m4
+ fi
pushd libltdl >/dev/null
AT_NOELIBTOOLIZE=yes eautoreconf
popd >/dev/null
@@ -64,12 +78,14 @@ src_configure() {
# to find a bash shell. if /bin/sh is bash, it uses that. this can
# cause problems for people who switch /bin/sh on the fly to other
# shells, so just force libtool to use /bin/bash all the time.
- export CONFIG_SHELL=/bin/bash
+ export CONFIG_SHELL=$(type -P bash)
# Do not bother hardcoding the full path to sed. Just rely on $PATH. #574550
export ac_cv_path_SED=$(basename "$(type -P sed)")
- ECONF_SOURCE=${S} econf --disable-ltdl-install
+ local myconf
+ [[ ${CHOST} == *-darwin* ]] && myconf="--program-prefix=g"
+ ECONF_SOURCE=${S} econf ${myconf} --disable-ltdl-install
}
src_test() {