summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-09-30 20:26:06 +0200
committerMichał Górny <mgorny@gentoo.org>2022-09-30 20:27:33 +0200
commit23d0a39186610053fa16320267217ec37d538a65 (patch)
tree59e5dd5a0ec4ee7382f57b84e7e3ae55dca2f6d5 /sys-devel/lld/lld-16.0.0.9999.ebuild
parentnet-im/synapse: Keyword 1.68.0 ppc64, #873274 (diff)
downloadgentoo-23d0a39186610053fa16320267217ec37d538a65.tar.gz
gentoo-23d0a39186610053fa16320267217ec37d538a65.tar.bz2
gentoo-23d0a39186610053fa16320267217ec37d538a65.zip
sys-devel/lld: Revert "Add zstd support to 16.x"
Reverts: 861536e5487b9c63f9cf878b4f2ecc3e8a220daf Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel/lld/lld-16.0.0.9999.ebuild')
-rw-r--r--sys-devel/lld/lld-16.0.0.9999.ebuild16
1 files changed, 3 insertions, 13 deletions
diff --git a/sys-devel/lld/lld-16.0.0.9999.ebuild b/sys-devel/lld/lld-16.0.0.9999.ebuild
index c683b72095e6..f8773e9ca849 100644
--- a/sys-devel/lld/lld-16.0.0.9999.ebuild
+++ b/sys-devel/lld/lld-16.0.0.9999.ebuild
@@ -4,7 +4,7 @@
EAPI=8
PYTHON_COMPAT=( python3_{8..11} )
-inherit cmake flag-o-matic llvm llvm.org multilib python-any-r1
+inherit cmake flag-o-matic llvm llvm.org python-any-r1
DESCRIPTION="The LLVM linker (link editor)"
HOMEPAGE="https://llvm.org/"
@@ -12,12 +12,11 @@ HOMEPAGE="https://llvm.org/"
LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
SLOT="0"
KEYWORDS=""
-IUSE="debug test zstd"
+IUSE="debug test"
RESTRICT="!test? ( test )"
DEPEND="
- ~sys-devel/llvm-${PV}[zstd=]
- zstd? ( app-arch/zstd:= )
+ ~sys-devel/llvm-${PV}
"
RDEPEND="
${DEPEND}
@@ -62,19 +61,10 @@ src_configure() {
use elibc_musl && append-ldflags -Wl,-z,stack-size=2097152
- if use zstd; then
- cat > "${T}"/zstdConfig.cmake <<-EOF || die
- add_library(zstd::libzstd_shared SHARED IMPORTED)
- set_target_properties(zstd::libzstd_shared PROPERTIES
- IMPORTED_LOCATION "${EPREFIX}/usr/$(get_libdir)/libzstd$(get_libname)")
- EOF
- fi
-
local mycmakeargs=(
-DBUILD_SHARED_LIBS=ON
-DLLVM_INCLUDE_TESTS=$(usex test)
-DLLVM_MAIN_SRC_DIR="${WORKDIR}/llvm"
- -Dzstd_DIR="${T}"
)
use test && mycmakeargs+=(
-DLLVM_BUILD_TESTS=ON