summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-01 08:49:54 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-01 15:32:35 +0200
commitb9ec9c5199f8ab0bd49585cf850243170fa081bf (patch)
tree3549d8f1b89df7e56e4a9d4dcd45b1624e9903b4 /sys-devel
parentmedia-sound/hydrogen: updated live ebuild (diff)
downloadgentoo-b9ec9c5199f8ab0bd49585cf850243170fa081bf.tar.gz
gentoo-b9ec9c5199f8ab0bd49585cf850243170fa081bf.tar.bz2
gentoo-b9ec9c5199f8ab0bd49585cf850243170fa081bf.zip
sys-devel/llvm: Add dependencies for llvm-debuginfod
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/llvm/llvm-17.0.0.9999.ebuild14
-rw-r--r--sys-devel/llvm/metadata.xml1
2 files changed, 12 insertions, 3 deletions
diff --git a/sys-devel/llvm/llvm-17.0.0.9999.ebuild b/sys-devel/llvm/llvm-17.0.0.9999.ebuild
index f7e501b7f98e..94ec3e2b1216 100644
--- a/sys-devel/llvm/llvm-17.0.0.9999.ebuild
+++ b/sys-devel/llvm/llvm-17.0.0.9999.ebuild
@@ -20,13 +20,17 @@ LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA BSD public-domain rc"
SLOT="${LLVM_MAJOR}/${LLVM_SOABI}"
KEYWORDS=""
IUSE="
- +binutils-plugin debug doc exegesis libedit +libffi ncurses test xar
- xml z3 zstd
+ +binutils-plugin debug debuginfod doc exegesis libedit +libffi
+ ncurses test xar xml z3 zstd
"
RESTRICT="!test? ( test )"
RDEPEND="
sys-libs/zlib:0=[${MULTILIB_USEDEP}]
+ debuginfod? (
+ net-misc/curl:=
+ dev-cpp/cpp-httplib:=
+ )
exegesis? ( dev-libs/libpfm:= )
libedit? ( dev-libs/libedit:0=[${MULTILIB_USEDEP}] )
libffi? ( >=dev-libs/libffi-3.0.13-r1:0=[${MULTILIB_USEDEP}] )
@@ -245,7 +249,6 @@ get_distribution_components() {
llvm-cxxfilt
llvm-cxxmap
llvm-debuginfo-analyzer
- llvm-debuginfod
llvm-debuginfod-find
llvm-diff
llvm-dis
@@ -326,6 +329,9 @@ get_distribution_components() {
use binutils-plugin && out+=(
LLVMgold
)
+ use debuginfod && out+=(
+ llvm-debuginfod
+ )
fi
printf "%s${sep}" "${out[@]}"
@@ -372,6 +378,8 @@ multilib_src_configure() {
-DLLVM_ENABLE_RTTI=ON
-DLLVM_ENABLE_Z3_SOLVER=$(usex z3)
-DLLVM_ENABLE_ZSTD=$(usex zstd)
+ -DLLVM_ENABLE_CURL=$(usex debuginfod)
+ -DLLVM_ENABLE_HTTPLIB=$(usex debuginfod)
-DLLVM_HOST_TRIPLE="${CHOST}"
diff --git a/sys-devel/llvm/metadata.xml b/sys-devel/llvm/metadata.xml
index 084e1821104b..d9ba661926c8 100644
--- a/sys-devel/llvm/metadata.xml
+++ b/sys-devel/llvm/metadata.xml
@@ -11,6 +11,7 @@
4. LLVM does not imply things that you would expect from a high-level virtual machine. It does not require garbage collection or run-time code generation (In fact, LLVM makes a great static compiler!). Note that optional LLVM components can be used to build high-level virtual machines and other systems that need these services.</longdescription>
<use>
<flag name="binutils-plugin">Build the binutils plugin</flag>
+ <flag name="debuginfod">Install llvm-debuginfod (requires <pkg>net-misc/curl</pkg> and <pkg>dev-cpp/cpp-httplib</pkg>)</flag>
<flag name="doc">Build and install the HTML documentation and regenerate the man pages</flag>
<flag name="exegesis">Enable performance counter support for llvm-exegesis tool
that can be used to measure host machine instruction characteristics</flag>