summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-11 20:24:37 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-11 20:25:01 +0200
commitbf78047aff79cc4eb8cf1661b5fe3472cc21fc04 (patch)
tree9a24e7d1ec0cc3b9a40b3009a65bce1bba92d14c /sys-devel
parentnet-p2p/syncthing: Stabilize 1.23.2 amd64, #904108 (diff)
downloadgentoo-bf78047aff79cc4eb8cf1661b5fe3472cc21fc04.tar.gz
gentoo-bf78047aff79cc4eb8cf1661b5fe3472cc21fc04.tar.bz2
gentoo-bf78047aff79cc4eb8cf1661b5fe3472cc21fc04.zip
sys-devel/clang: Install clang-*-wrapper tools in 15.0.7-r1
Add missing `clang-*-wrapper` tools to 15.0.7-r1. Since these tools aren't crucial to clang operation, let's add them without revbump to avoid forcing a huge rebuild on everyone. The `clang-linker-wrapper` is already installed by 17.x, and I have requested backporting a fix to get it installed into 16.x release branch. The two remaining tools were already removed in 16.x. Bug: https://bugs.gentoo.org/904143 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/clang/clang-15.0.7-r1.ebuild7
1 files changed, 7 insertions, 0 deletions
diff --git a/sys-devel/clang/clang-15.0.7-r1.ebuild b/sys-devel/clang/clang-15.0.7-r1.ebuild
index 3a9fc612178a..7141f0e0a887 100644
--- a/sys-devel/clang/clang-15.0.7-r1.ebuild
+++ b/sys-devel/clang/clang-15.0.7-r1.ebuild
@@ -431,6 +431,13 @@ src_install() {
multilib_src_install() {
DESTDIR=${D} cmake_build install-distribution
+ if multilib_is_native_abi; then
+ # install clang-*-wrapper tools
+ # https://bugs.gentoo.org/904143
+ exeinto "/usr/lib/llvm/${LLVM_MAJOR}/bin"
+ doexe "${BUILD_DIR}"/bin/clang-{linker,nvlink}-wrapper
+ fi
+
# move headers to /usr/include for wrapping & ABI mismatch checks
# (also drop the version suffix from runtime headers)
rm -rf "${ED}"/usr/include || die