summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Jolly <kangie@gentoo.org>2024-11-10 11:24:12 +1000
committerMatt Jolly <kangie@gentoo.org>2024-11-11 18:49:16 +1000
commit20c78cda3f6a7edfb22c791e0e16c5d5ca20bdb3 (patch)
tree717d375d4bc34b50cfb78c9712a992489ed8d73b /sys-fs/bcachefs-tools
parenteclass: update rust usedep handling; address feedback (diff)
downloadgentoo-20c78cda3f6a7edfb22c791e0e16c5d5ca20bdb3.tar.gz
gentoo-20c78cda3f6a7edfb22c791e0e16c5d5ca20bdb3.tar.bz2
gentoo-20c78cda3f6a7edfb22c791e0e16c5d5ca20bdb3.zip
*/*: fix rust eclass usedep/mutlilib handling; inherit order
The rust eclass has been updated to directly inject a required MULTILIB_USEDEP when requested. RUST_USEDEP has been renamed to RUST_REQUIRED_USE to be consistent with other eclasses. llvm-r1 should be imported after cargo and the eclass now enables this. Signed-off-by: Matt Jolly <kangie@gentoo.org>
Diffstat (limited to 'sys-fs/bcachefs-tools')
-rw-r--r--sys-fs/bcachefs-tools/bcachefs-tools-1.11.0-r1.ebuild2
-rw-r--r--sys-fs/bcachefs-tools/bcachefs-tools-1.13.0-r1.ebuild2
-rw-r--r--sys-fs/bcachefs-tools/bcachefs-tools-1.7.0-r1.ebuild2
-rw-r--r--sys-fs/bcachefs-tools/bcachefs-tools-1.9.4-r1.ebuild2
4 files changed, 4 insertions, 4 deletions
diff --git a/sys-fs/bcachefs-tools/bcachefs-tools-1.11.0-r1.ebuild b/sys-fs/bcachefs-tools/bcachefs-tools-1.11.0-r1.ebuild
index a15809aa8729..5206e7db0647 100644
--- a/sys-fs/bcachefs-tools/bcachefs-tools-1.11.0-r1.ebuild
+++ b/sys-fs/bcachefs-tools/bcachefs-tools-1.11.0-r1.ebuild
@@ -99,7 +99,7 @@ CRATES="
LLVM_COMPAT=( {16..18} )
PYTHON_COMPAT=( python3_{10..13} )
-inherit llvm-r1 cargo flag-o-matic python-any-r1 shell-completion toolchain-funcs unpacker
+inherit cargo flag-o-matic llvm-r1 python-any-r1 shell-completion toolchain-funcs unpacker
DESCRIPTION="Tools for bcachefs"
HOMEPAGE="https://bcachefs.org/"
diff --git a/sys-fs/bcachefs-tools/bcachefs-tools-1.13.0-r1.ebuild b/sys-fs/bcachefs-tools/bcachefs-tools-1.13.0-r1.ebuild
index da8e0cb0bcd2..77446216158b 100644
--- a/sys-fs/bcachefs-tools/bcachefs-tools-1.13.0-r1.ebuild
+++ b/sys-fs/bcachefs-tools/bcachefs-tools-1.13.0-r1.ebuild
@@ -91,7 +91,7 @@ LLVM_COMPAT=( {16..18} )
PYTHON_COMPAT=( python3_{10..13} )
VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/kentoverstreet.asc
-inherit llvm-r1 cargo flag-o-matic python-any-r1 shell-completion toolchain-funcs unpacker verify-sig
+inherit cargo flag-o-matic llvm-r1 python-any-r1 shell-completion toolchain-funcs unpacker verify-sig
DESCRIPTION="Tools for bcachefs"
HOMEPAGE="https://bcachefs.org/"
diff --git a/sys-fs/bcachefs-tools/bcachefs-tools-1.7.0-r1.ebuild b/sys-fs/bcachefs-tools/bcachefs-tools-1.7.0-r1.ebuild
index 413ed976120b..8e3a3edaebac 100644
--- a/sys-fs/bcachefs-tools/bcachefs-tools-1.7.0-r1.ebuild
+++ b/sys-fs/bcachefs-tools/bcachefs-tools-1.7.0-r1.ebuild
@@ -95,7 +95,7 @@ CRATES="
LLVM_COMPAT=( {16..18} )
PYTHON_COMPAT=( python3_{10..12} )
-inherit llvm-r1 cargo flag-o-matic multiprocessing python-any-r1 shell-completion toolchain-funcs unpacker
+inherit cargo flag-o-matic llvm-r1 multiprocessing python-any-r1 shell-completion toolchain-funcs unpacker
DESCRIPTION="Tools for bcachefs"
HOMEPAGE="https://bcachefs.org/"
diff --git a/sys-fs/bcachefs-tools/bcachefs-tools-1.9.4-r1.ebuild b/sys-fs/bcachefs-tools/bcachefs-tools-1.9.4-r1.ebuild
index 7a9612a910b2..3df9428b78c0 100644
--- a/sys-fs/bcachefs-tools/bcachefs-tools-1.9.4-r1.ebuild
+++ b/sys-fs/bcachefs-tools/bcachefs-tools-1.9.4-r1.ebuild
@@ -102,7 +102,7 @@ CRATES="
LLVM_COMPAT=( {16..18} )
PYTHON_COMPAT=( python3_{10..13} )
-inherit llvm-r1 cargo flag-o-matic multiprocessing python-any-r1 shell-completion toolchain-funcs unpacker
+inherit cargo flag-o-matic llvm-r1 multiprocessing python-any-r1 shell-completion toolchain-funcs unpacker
DESCRIPTION="Tools for bcachefs"
HOMEPAGE="https://bcachefs.org/"