summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2019-09-08 14:09:48 -0400
committerMike Gilbert <floppym@gentoo.org>2019-09-08 14:09:48 -0400
commite0df6cd103723e2a8deb50a19ef257d7ef1c7060 (patch)
tree1be9e60b111a67c5f33973532644743a43f901be /sys-fs/lvm2
parenttmpfiles.eclass: fix @USAGE to not include function names (diff)
downloadgentoo-e0df6cd103723e2a8deb50a19ef257d7ef1c7060.tar.gz
gentoo-e0df6cd103723e2a8deb50a19ef257d7ef1c7060.tar.bz2
gentoo-e0df6cd103723e2a8deb50a19ef257d7ef1c7060.zip
sys-fs/lvm2: drop unused usr-ldscript.eclass
Package-Manager: Portage-2.3.75_p2, Repoman-2.3.17_p44 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-fs/lvm2')
-rw-r--r--sys-fs/lvm2/lvm2-2.02.116.ebuild4
-rw-r--r--sys-fs/lvm2/lvm2-2.02.145-r2.ebuild4
-rw-r--r--sys-fs/lvm2/lvm2-2.02.183.ebuild4
-rw-r--r--sys-fs/lvm2/lvm2-2.02.184-r4.ebuild4
-rw-r--r--sys-fs/lvm2/lvm2-2.02.185-r1.ebuild4
-rw-r--r--sys-fs/lvm2/lvm2-2.02.186.ebuild4
-rw-r--r--sys-fs/lvm2/lvm2-2.03.05-r1.ebuild4
7 files changed, 7 insertions, 21 deletions
diff --git a/sys-fs/lvm2/lvm2-2.02.116.ebuild b/sys-fs/lvm2/lvm2-2.02.116.ebuild
index c08ea9082043..f7e83264dbc1 100644
--- a/sys-fs/lvm2/lvm2-2.02.116.ebuild
+++ b/sys-fs/lvm2/lvm2-2.02.116.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-inherit autotools eutils linux-info multilib systemd toolchain-funcs udev flag-o-matic usr-ldscript
+inherit autotools eutils linux-info multilib systemd toolchain-funcs udev flag-o-matic
DESCRIPTION="User-land utilities for LVM2 (device-mapper) software"
HOMEPAGE="https://sourceware.org/lvm2/"
@@ -212,9 +212,7 @@ src_install() {
if use static-libs; then
dolib.a libdm/ioctl/libdevmapper.a
dolib.a libdaemon/client/libdaemonclient.a #462908
- #gen_usr_ldscript libdevmapper.so
dolib.a daemons/dmeventd/libdevmapper-event.a
- #gen_usr_ldscript libdevmapper-event.so
else
rm -f "${ED}"usr/$(get_libdir)/{libdevmapper-event,liblvm2cmd,liblvm2app,libdevmapper}.a
fi
diff --git a/sys-fs/lvm2/lvm2-2.02.145-r2.ebuild b/sys-fs/lvm2/lvm2-2.02.145-r2.ebuild
index 9123620e40b1..d014bed6e223 100644
--- a/sys-fs/lvm2/lvm2-2.02.145-r2.ebuild
+++ b/sys-fs/lvm2/lvm2-2.02.145-r2.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit autotools eutils linux-info multilib systemd toolchain-funcs udev flag-o-matic usr-ldscript
+inherit autotools eutils linux-info multilib systemd toolchain-funcs udev flag-o-matic
DESCRIPTION="User-land utilities for LVM2 (device-mapper) software"
HOMEPAGE="https://sourceware.org/lvm2/"
@@ -222,9 +222,7 @@ src_install() {
dolib.a libdm/ioctl/libdevmapper.a
if use !device-mapper-only ; then
dolib.a libdaemon/client/libdaemonclient.a #462908
- #gen_usr_ldscript libdevmapper.so
dolib.a daemons/dmeventd/libdevmapper-event.a
- #gen_usr_ldscript libdevmapper-event.so
fi
else
rm -f "${ED}"usr/$(get_libdir)/{libdevmapper-event,liblvm2cmd,liblvm2app,libdevmapper}.a
diff --git a/sys-fs/lvm2/lvm2-2.02.183.ebuild b/sys-fs/lvm2/lvm2-2.02.183.ebuild
index 595dd187372a..1438959ea365 100644
--- a/sys-fs/lvm2/lvm2-2.02.183.ebuild
+++ b/sys-fs/lvm2/lvm2-2.02.183.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit autotools linux-info multilib systemd toolchain-funcs udev flag-o-matic usr-ldscript
+inherit autotools linux-info multilib systemd toolchain-funcs udev flag-o-matic
DESCRIPTION="User-land utilities for LVM2 (device-mapper) software"
HOMEPAGE="https://sourceware.org/lvm2/"
@@ -228,9 +228,7 @@ src_install() {
if use static-libs; then
dolib.a libdm/ioctl/libdevmapper.a
dolib.a libdaemon/client/libdaemonclient.a #462908
- #gen_usr_ldscript libdevmapper.so
dolib.a daemons/dmeventd/libdevmapper-event.a
- #gen_usr_ldscript libdevmapper-event.so
else
rm -f "${ED%/}"/usr/$(get_libdir)/{libdevmapper-event,liblvm2cmd,liblvm2app,libdevmapper}.a
fi
diff --git a/sys-fs/lvm2/lvm2-2.02.184-r4.ebuild b/sys-fs/lvm2/lvm2-2.02.184-r4.ebuild
index eab949397c29..0c4acb77beb2 100644
--- a/sys-fs/lvm2/lvm2-2.02.184-r4.ebuild
+++ b/sys-fs/lvm2/lvm2-2.02.184-r4.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit autotools linux-info multilib systemd toolchain-funcs udev flag-o-matic usr-ldscript
+inherit autotools linux-info multilib systemd toolchain-funcs udev flag-o-matic
DESCRIPTION="User-land utilities for LVM2 (device-mapper) software"
HOMEPAGE="https://sourceware.org/lvm2/"
@@ -240,9 +240,7 @@ src_install() {
if use static-libs; then
dolib.a libdm/ioctl/libdevmapper.a
dolib.a libdaemon/client/libdaemonclient.a #462908
- #gen_usr_ldscript libdevmapper.so
dolib.a daemons/dmeventd/libdevmapper-event.a
- #gen_usr_ldscript libdevmapper-event.so
else
rm -f "${ED%/}"/usr/$(get_libdir)/{libdevmapper-event,liblvm2cmd,liblvm2app,libdevmapper}.a
fi
diff --git a/sys-fs/lvm2/lvm2-2.02.185-r1.ebuild b/sys-fs/lvm2/lvm2-2.02.185-r1.ebuild
index c18e5334dcd1..de7273ad6448 100644
--- a/sys-fs/lvm2/lvm2-2.02.185-r1.ebuild
+++ b/sys-fs/lvm2/lvm2-2.02.185-r1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit autotools linux-info multilib systemd toolchain-funcs udev flag-o-matic usr-ldscript
+inherit autotools linux-info multilib systemd toolchain-funcs udev flag-o-matic
DESCRIPTION="User-land utilities for LVM2 (device-mapper) software"
HOMEPAGE="https://sourceware.org/lvm2/"
@@ -242,13 +242,11 @@ src_install() {
if use static-libs; then
dolib.a libdm/ioctl/libdevmapper.a
- #gen_usr_ldscript libdevmapper.so
if use !device-mapper-only; then
# depends on lvmetad
dolib.a libdaemon/client/libdaemonclient.a #462908
# depends on dmeventd
dolib.a daemons/dmeventd/libdevmapper-event.a
- #gen_usr_ldscript libdevmapper-event.so
fi
else
rm -f "${ED}"/usr/$(get_libdir)/{libdevmapper-event,liblvm2cmd,liblvm2app,libdevmapper}.a
diff --git a/sys-fs/lvm2/lvm2-2.02.186.ebuild b/sys-fs/lvm2/lvm2-2.02.186.ebuild
index c18e5334dcd1..de7273ad6448 100644
--- a/sys-fs/lvm2/lvm2-2.02.186.ebuild
+++ b/sys-fs/lvm2/lvm2-2.02.186.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit autotools linux-info multilib systemd toolchain-funcs udev flag-o-matic usr-ldscript
+inherit autotools linux-info multilib systemd toolchain-funcs udev flag-o-matic
DESCRIPTION="User-land utilities for LVM2 (device-mapper) software"
HOMEPAGE="https://sourceware.org/lvm2/"
@@ -242,13 +242,11 @@ src_install() {
if use static-libs; then
dolib.a libdm/ioctl/libdevmapper.a
- #gen_usr_ldscript libdevmapper.so
if use !device-mapper-only; then
# depends on lvmetad
dolib.a libdaemon/client/libdaemonclient.a #462908
# depends on dmeventd
dolib.a daemons/dmeventd/libdevmapper-event.a
- #gen_usr_ldscript libdevmapper-event.so
fi
else
rm -f "${ED}"/usr/$(get_libdir)/{libdevmapper-event,liblvm2cmd,liblvm2app,libdevmapper}.a
diff --git a/sys-fs/lvm2/lvm2-2.03.05-r1.ebuild b/sys-fs/lvm2/lvm2-2.03.05-r1.ebuild
index e1103033f62a..aa341d835815 100644
--- a/sys-fs/lvm2/lvm2-2.03.05-r1.ebuild
+++ b/sys-fs/lvm2/lvm2-2.03.05-r1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit autotools linux-info multilib systemd toolchain-funcs udev flag-o-matic usr-ldscript
+inherit autotools linux-info multilib systemd toolchain-funcs udev flag-o-matic
DESCRIPTION="User-land utilities for LVM2 (device-mapper) software"
HOMEPAGE="https://sourceware.org/lvm2/"
@@ -230,13 +230,11 @@ src_install() {
if use static-libs; then
dolib.a libdm/ioctl/libdevmapper.a
- #gen_usr_ldscript libdevmapper.so
if use !device-mapper-only; then
# depends on lvmetad
dolib.a libdaemon/client/libdaemonclient.a #462908
# depends on dmeventd
dolib.a daemons/dmeventd/libdevmapper-event.a
- #gen_usr_ldscript libdevmapper-event.so
fi
else
rm -f "${ED}"/usr/$(get_libdir)/{libdevmapper-event,liblvm2cmd,liblvm2app,libdevmapper}.a